summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2021-09-20 19:03:54 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-09-24 10:33:20 -0700
commit6db826e810332e5e040e943836eddd79db7d0ee9 (patch)
tree0456590ef041756c9548577a525f2620e7587c5c /net-im
parentmedia-libs/tg_owt: Bump to 0_pre20210914 (diff)
downloadgentoo-6db826e810332e5e040e943836eddd79db7d0ee9.tar.gz
gentoo-6db826e810332e5e040e943836eddd79db7d0ee9.tar.bz2
gentoo-6db826e810332e5e040e943836eddd79db7d0ee9.zip
net-im/telegram-desktop: Bump to 3.1.0
Also fix openssl3 compilation error in this new version. Won't backport fixes, by the time openssl3 goes stable these will be phased out anyway... Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22342 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telegram-desktop/Manifest1
-rw-r--r--net-im/telegram-desktop/files/tdesktop-3.1.0-fix-openssl3.patch19
-rw-r--r--net-im/telegram-desktop/files/tdesktop-3.1.0-jemalloc-only-telegram.patch35
-rw-r--r--net-im/telegram-desktop/telegram-desktop-3.1.0.ebuild146
4 files changed, 201 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/Manifest b/net-im/telegram-desktop/Manifest
index f2bd8bdf9dce..857e615c8cec 100644
--- a/net-im/telegram-desktop/Manifest
+++ b/net-im/telegram-desktop/Manifest
@@ -1,2 +1,3 @@
DIST tdesktop-2.9.3-full.tar.gz 37335782 BLAKE2B 197583ba6568c455218c51f590c1ba1a3f10c390caa4fd03657098f499ce113a4f5f57ca9dd53bc4baba31992d4229768ed35e68ad6b0685010bc335817edcac SHA512 810cfac5d7e6ce9413b1b2406927e89c1383ea5b725233a68b2cb29dd374b4c3386c22186640afde4492c844516c88889a5db8e5b167a09d6d6c1270ac965ac4
DIST tdesktop-3.0.1-full.tar.gz 37531917 BLAKE2B c139501f23c742f76d4acd43def69963413ffafef1be584f13d7359b3c20625def7ec283a981556c795aa4dc5ad2e117e1f8aada28cd4815f66f02510e607435 SHA512 6bff6be5f2c0c7a17df61dccc5a3216dcbb95a1c6d3176442c530e2c1b525e6d15079b230d40751f20684da2a1067d4518a9a1ab90d49d1a7338d3e05239d447
+DIST tdesktop-3.1.0-full.tar.gz 38465279 BLAKE2B c9442507d3ec6f6e36e68d44ec86a9c1dfb864498ee90eef5f50b12482de4e1c93256352fc21bf997c38cda0dfce03f53776c47afe1a3066b109c1675ffc8749 SHA512 7fbb5722917c482aed820154e425642c4a3c7649defebae7076e48ac25da8744933877b70539d5cd6952e9f80493ccc5f144bf2c0c01083bade3473f00a23ec4
diff --git a/net-im/telegram-desktop/files/tdesktop-3.1.0-fix-openssl3.patch b/net-im/telegram-desktop/files/tdesktop-3.1.0-fix-openssl3.patch
new file mode 100644
index 000000000000..2b92e8adce4f
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-3.1.0-fix-openssl3.patch
@@ -0,0 +1,19 @@
+Fix openssl 3.x compatibility
+
+FIPS_mode_set was merely used to clean up resources. This isn't necessary
+anymore on the newer openssl version.
+
+There's still a lot of functions that are used that were deprecated. I hope
+upstream can fix those, as I'm unsure what to do with them.
+
+--- tdesktop-3.1.0-full.orig/Telegram/SourceFiles/core/utils.cpp
++++ tdesktop-3.1.0-full/Telegram/SourceFiles/core/utils.cpp
+@@ -124,7 +124,7 @@
+
+ void finish() {
+ CRYPTO_cleanup_all_ex_data();
+-#ifndef LIBRESSL_VERSION_NUMBER
++#if !defined(LIBRESSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER < 0x20000000L
+ FIPS_mode_set(0);
+ #endif
+ ENGINE_cleanup();
diff --git a/net-im/telegram-desktop/files/tdesktop-3.1.0-jemalloc-only-telegram.patch b/net-im/telegram-desktop/files/tdesktop-3.1.0-jemalloc-only-telegram.patch
new file mode 100644
index 000000000000..7ad3e75e49ba
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-3.1.0-jemalloc-only-telegram.patch
@@ -0,0 +1,35 @@
+Only link jemalloc for the Telegram binary
+
+Some combination of factors is making the different codegen tools hang when
+jemalloc is linked for those, and they're ran under portage's sandbox. Since
+this is only used during build-time, and jemalloc is merely necessary to
+improve runtime memory use, it's unnecessary to use it for anything else.
+
+--- tdesktop-3.1.0-full.orig/Telegram/CMakeLists.txt
++++ tdesktop-3.1.0-full/Telegram/CMakeLists.txt
+@@ -1256,6 +1256,11 @@
+ endif()
+ endif()
+ else()
++ target_link_libraries(Telegram
++ PRIVATE
++ desktop-app::external_jemalloc
++ )
++
+ if (NOT DESKTOP_APP_DISABLE_DBUS_INTEGRATION)
+ target_link_libraries(Telegram
+ PRIVATE
+--- tdesktop-3.1.0-full.orig/cmake/options_linux.cmake
++++ tdesktop-3.1.0-full/cmake/options_linux.cmake
+@@ -45,11 +45,6 @@
+ target_link_options(common_options INTERFACE $<IF:$<CONFIG:Debug>,,-g -flto -fuse-linker-plugin>)
+ endif()
+
+-target_link_libraries(common_options
+-INTERFACE
+- desktop-app::external_jemalloc
+-)
+-
+ if (DESKTOP_APP_USE_ALLOCATION_TRACER)
+ target_link_options(common_options
+ INTERFACE
diff --git a/net-im/telegram-desktop/telegram-desktop-3.1.0.ebuild b/net-im/telegram-desktop/telegram-desktop-3.1.0.ebuild
new file mode 100644
index 000000000000..675c8aefaa4d
--- /dev/null
+++ b/net-im/telegram-desktop/telegram-desktop-3.1.0.ebuild
@@ -0,0 +1,146 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit xdg cmake python-any-r1 flag-o-matic
+
+DESCRIPTION="Official desktop client for Telegram"
+HOMEPAGE="https://desktop.telegram.org"
+
+MY_P="tdesktop-${PV}-full"
+SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-3-with-openssl-exception LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="+dbus enchant +hunspell screencast +spell wayland webkit +X"
+REQUIRED_USE="
+ spell? (
+ ^^ ( enchant hunspell )
+ )
+ webkit? ( dbus )
+"
+
+RDEPEND="
+ !net-im/telegram-desktop-bin
+ app-arch/lz4:=
+ dev-cpp/abseil-cpp:=
+ dev-libs/jemalloc:=[-lazy-lock]
+ dev-libs/openssl:=
+ dev-libs/xxhash
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5[dbus?,jpeg,png,wayland?,X?]
+ >=dev-qt/qtimageformats-5.15:5
+ >=dev-qt/qtnetwork-5.15:5[ssl]
+ >=dev-qt/qtsvg-5.15:5
+ >=dev-qt/qtwidgets-5.15:5[png,X?]
+ media-fonts/open-sans
+ media-libs/fontconfig:=
+ ~media-libs/libtgvoip-2.4.4_p20210302
+ >=media-libs/libtgvoip-2.4.4_p20210302-r2
+ media-libs/openal
+ media-libs/opus:=
+ media-libs/rnnoise
+ ~media-libs/tg_owt-0_pre20210914[screencast=,X=]
+ media-video/ffmpeg:=[opus]
+ sys-libs/zlib:=[minizip]
+ dbus? (
+ dev-cpp/glibmm:2
+ dev-qt/qtdbus:5
+ dev-libs/libdbusmenu-qt[qt5(+)]
+ )
+ enchant? ( app-text/enchant:= )
+ hunspell? ( >=app-text/hunspell-1.7:= )
+ wayland? ( kde-frameworks/kwayland:= )
+ webkit? ( net-libs/webkit-gtk:= )
+ X? ( x11-libs/libxcb:= )
+"
+DEPEND="${RDEPEND}
+ dev-cpp/range-v3
+ =dev-cpp/ms-gsl-3*
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/cmake-3.16
+ virtual/pkgconfig
+"
+# dev-libs/jemalloc:=[-lazy-lock] -> https://bugs.gentoo.org/803233
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/tdesktop-3.1.0-jemalloc-only-telegram.patch"
+ "${FILESDIR}/tdesktop-3.1.0-fix-openssl3.patch"
+)
+
+pkg_pretend() {
+ if has ccache ${FEATURES}; then
+ ewarn
+ ewarn "ccache does not work with ${PN} out of the box"
+ ewarn "due to usage of precompiled headers"
+ ewarn "check bug https://bugs.gentoo.org/715114 for more info"
+ ewarn
+ fi
+}
+
+src_prepare() {
+ # no explicit toggle, doesn't build with the system one #752417
+ sed -i 's/DESKTOP_APP_USE_PACKAGED/NO_ONE_WILL_EVER_SET_THIS/' \
+ cmake/external/rlottie/CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # gtk is really needed for image copy-paste due to https://bugreports.qt.io/browse/QTBUG-56595
+ local mycmakeargs=(
+ -DTDESKTOP_LAUNCHER_BASENAME="${PN}"
+ -DCMAKE_DISABLE_FIND_PACKAGE_tl-expected=ON # header only lib, some git version. prevents warnings.
+
+ -DDESKTOP_APP_DISABLE_X11_INTEGRATION=$(usex X no yes)
+ -DDESKTOP_APP_DISABLE_WAYLAND_INTEGRATION=$(usex wayland no yes)
+ -DDESKTOP_APP_DISABLE_DBUS_INTEGRATION=$(usex dbus no yes)
+ -DDESKTOP_APP_DISABLE_WEBKITGTK=$(usex webkit no yes)
+ -DDESKTOP_APP_DISABLE_SPELLCHECK=$(usex spell no yes) # enables hunspell (recommended)
+ -DDESKTOP_APP_USE_ENCHANT=$(usex enchant) # enables enchant and disables hunspell
+ )
+
+ if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
+ einfo "Found custom API credentials"
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
+ -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
+ )
+ else
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+ # Building with snapcraft API credentials by default
+ # Custom API credentials can be obtained here:
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+ # After getting credentials you can export variables:
+ # export MY_TDESKTOP_API_ID="17349""
+ # export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+ # and restart the build"
+ # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+ # portage will use custom variable every build automatically
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="611335"
+ -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ if ! use X && ! use screencast; then
+ elog "both the 'X' and 'screencast' useflags are disabled, screen sharing won't work!"
+ fi
+ if has_version '<dev-qt/qtcore-5.15.2-r10'; then
+ ewarn "Versions of dev-qt/qtcore lower than 5.15.2-r10 might cause telegram"
+ ewarn "to crash when pasting big images from the clipboard."
+ fi
+}