summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-05-03 09:03:41 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-03 09:03:41 +0200
commit6e6ccb3ddae3a06b3b6e9adb7248abbe9712f0e0 (patch)
treef66170744e714d7b52f4522b162c2cefa3147a17 /net-im
parentmedia-sound/guitarix: bump to 0.44.0, dropped python3_7 from all (diff)
downloadgentoo-6e6ccb3ddae3a06b3b6e9adb7248abbe9712f0e0.tar.gz
gentoo-6e6ccb3ddae3a06b3b6e9adb7248abbe9712f0e0.tar.bz2
gentoo-6e6ccb3ddae3a06b3b6e9adb7248abbe9712f0e0.zip
net-im/profanity: fix use_with, delete .la files, respect CFLAGS
Closes: https://bugs.gentoo.org/842300 Closes: https://bugs.gentoo.org/842303 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/profanity/profanity-0.12.1-r1.ebuild (renamed from net-im/profanity/profanity-0.12.1.ebuild)11
1 files changed, 10 insertions, 1 deletions
diff --git a/net-im/profanity/profanity-0.12.1.ebuild b/net-im/profanity/profanity-0.12.1-r1.ebuild
index 17175e193d4e..4dbaba2f82a7 100644
--- a/net-im/profanity/profanity-0.12.1.ebuild
+++ b/net-im/profanity/profanity-0.12.1-r1.ebuild
@@ -54,5 +54,14 @@ src_configure() {
$(use_enable omemo) \
$(use_enable otr) \
$(use_enable gpg pgp) \
- $(with_enable xscreensaver)
+ $(use_with xscreensaver)
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
}