summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-10-07 23:39:32 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-10-07 23:39:32 +0200
commit7421df2888ed102b5b905b393301333c112403e9 (patch)
tree1bd67790de9111b4d5044e40173212ecc51c20d3 /net-im
parentdev-python/pylama: add Python 3.{8,9} support and doc, fix tests (diff)
downloadgentoo-7421df2888ed102b5b905b393301333c112403e9.tar.gz
gentoo-7421df2888ed102b5b905b393301333c112403e9.tar.bz2
gentoo-7421df2888ed102b5b905b393301333c112403e9.zip
net-im/prosody-modules: new package
Prosody can be customized extensively using modules (plugins) to change its default behaviour and to add new features and functionality. This package contains all modules, which are provided and supported by the prosody community for all prosody users. This package supports 'savedconfig', so not all modules have to be installed, it not wished. Closes: https://bugs.gentoo.org/358969 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/prosody-modules/Manifest1
-rw-r--r--net-im/prosody-modules/metadata.xml16
-rw-r--r--net-im/prosody-modules/prosody-modules-0_pre20201004.ebuild55
-rw-r--r--net-im/prosody-modules/prosody-modules-9999.ebuild55
4 files changed, 127 insertions, 0 deletions
diff --git a/net-im/prosody-modules/Manifest b/net-im/prosody-modules/Manifest
new file mode 100644
index 000000000000..18c71611ce9c
--- /dev/null
+++ b/net-im/prosody-modules/Manifest
@@ -0,0 +1 @@
+DIST prosody-modules-0_pre20201004.tar.xz 1152400 BLAKE2B 66170cbeea156d8843aad2ace62294a40b6168170cd3da3b59cf660aa9d6aab743a7bfe1a5d313e83a69336ef7165a4a45ac27da9afa239a7f97413f275883fe SHA512 b4201c108b6ba5ed2404d65efa3fbb50ca1493e204b6cfe55893c19fe22a01bcb23244fa35f2c03cf52ecabdac1354aa388740fc62b5516cb2a85fdd753e9efc
diff --git a/net-im/prosody-modules/metadata.xml b/net-im/prosody-modules/metadata.xml
new file mode 100644
index 000000000000..fdabf81a3e5f
--- /dev/null
+++ b/net-im/prosody-modules/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ Prosody can be customized extensively using modules (plugins) to change
+ its default behaviour and to add new features and functionality.
+
+ Please note that each module is in a different state of development.
+ Some are proof-of-concept, others are quite stable and ready for production use.
+ Be sure to read the documentation page of any module before installing it on your server.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-im/prosody-modules/prosody-modules-0_pre20201004.ebuild b/net-im/prosody-modules/prosody-modules-0_pre20201004.ebuild
new file mode 100644
index 000000000000..949393ac4e63
--- /dev/null
+++ b/net-im/prosody-modules/prosody-modules-0_pre20201004.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig
+
+DESCRIPTION="A collection of community-maintained modules for Prosody"
+HOMEPAGE="https://modules.prosody.im"
+SRC_URI="https://dev.gentoo.org/~conikost/distfiles/${P}.tar.xz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="net-im/prosody"
+
+src_prepare() {
+ default
+
+ # Exclude 'misc' folder from install, since it does not provide any modules.
+ echo "# Remove all modules from this list, which you don't want to install." > prosody-modules.conf || die
+ find * -maxdepth 0 -type d ! -name misc >> prosody-modules.conf || die
+
+ use savedconfig && restore_config prosody-modules.conf
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/prosody/community-modules"
+ while read prosody_module; do
+ if ! [[ "${prosody_module}" = \#* ]]; then
+ if [[ -f "${prosody_module}/README.markdown" ]]; then
+ newdoc "${prosody_module}/README.markdown" "README.${prosody_module}"
+ rm "${prosody_module}/README.markdown" || die
+ fi
+
+ doins -r "${prosody_module}"
+ fi
+ done <prosody-modules.conf
+
+ save_config prosody-modules.conf
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ savedconfig_pkg_postinst
+
+ einfo "In order to use the community modules on an existing instance, you have to add"
+ einfo "'/usr/$(get_libdir)/prosody/community-modules' into 'plugin_paths'"
+ einfo "into your prosody configuration file '/etc/jabber/prosody.cfg.lua.'"
+ einfo ""
+ einfo "Example: plugin_paths = { /usr/$(get_libdir)/prosody/community-modules };"
+}
diff --git a/net-im/prosody-modules/prosody-modules-9999.ebuild b/net-im/prosody-modules/prosody-modules-9999.ebuild
new file mode 100644
index 000000000000..5759297af384
--- /dev/null
+++ b/net-im/prosody-modules/prosody-modules-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mercurial savedconfig
+
+EHG_REPO_URI="https://hg.prosody.im/${PN}/"
+
+DESCRIPTION="A collection of community-maintained modules for Prosody"
+HOMEPAGE="https://modules.prosody.im"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="net-im/prosody"
+
+src_prepare() {
+ default
+
+ # Exclude 'misc' folder from install, since it does not provide any modules.
+ echo "# Remove all modules from this list, which you don't want to install." > prosody-modules.conf || die
+ find * -maxdepth 0 -type d ! -name misc >> prosody-modules.conf || die
+
+ use savedconfig && restore_config prosody-modules.conf
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/prosody/community-modules"
+ while read prosody_module; do
+ if ! [[ "${prosody_module}" = \#* ]]; then
+ if [[ -f "${prosody_module}/README.markdown" ]]; then
+ newdoc "${prosody_module}/README.markdown" "README.${prosody_module}"
+ rm "${prosody_module}/README.markdown" || die
+ fi
+
+ doins -r "${prosody_module}"
+ fi
+ done <prosody-modules.conf
+
+ save_config prosody-modules.conf
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ savedconfig_pkg_postinst
+
+ einfo "In order to use the community modules on an existing instance, you have to add"
+ einfo "'/usr/$(get_libdir)/prosody/community-modules' into 'plugin_paths'"
+ einfo "into your prosody configuration file '/etc/jabber/prosody.cfg.lua.'"
+ einfo ""
+ einfo "Example: plugin_paths = { /usr/$(get_libdir)/prosody/community-modules };"
+}