summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-02 11:31:34 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-02 12:18:14 +0200
commit7b9f48431a3abd556394478676031f37d90a15f1 (patch)
tree3f82a843e7aeb8c5f1235f57681d8b9970375f85 /net-im
parentdev-python/pyzotero: drop 1.5.1, 1.5.1-r1, 1.5.2 (diff)
downloadgentoo-7b9f48431a3abd556394478676031f37d90a15f1.tar.gz
gentoo-7b9f48431a3abd556394478676031f37d90a15f1.tar.bz2
gentoo-7b9f48431a3abd556394478676031f37d90a15f1.zip
net-im/rocketchat-desktop-bin: add 3.8.5
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.5.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index a5e918d87739..4b4042968676 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.8.4-linux-x86_64.rpm 62658984 BLAKE2B c4472cf13ce4d3cc7afcaee801bcbf8884acc96215b099f430c147e38be42b6f9b3a34f503c351728c3dbed3c1c4d71b3c2c9954980c89a5c2b0ba14660e91be SHA512 26594bb31e206278a22f4276c33119bc4635404c6e1d6a066576eeed9252ea5eebe3099a677377d0bd333844139397b3bd5b4e4cdf8a245924cf9a4ebaa3dcb6
+DIST rocketchat-3.8.5-linux-x86_64.rpm 62651340 BLAKE2B 7ed30c6ac674cffa1a068fbe085aac6c17d4c6dc46101ae99b4a6528da4755b5f135f1673a0bedcb24430de21b2fad2530612e574eb1189ea88f5d58fd609860 SHA512 55724082b618265b831f8eed51d8c49d3d383e3e2df3dd495619fc13ee054d278a15b4ab03ab9f5c23dcf254387cde93da883210eaaa92263d5826e954092980
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.5.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.5.ebuild
new file mode 100644
index 000000000000..258071fcfef4
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}-linux-x86_64.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/Rocket.Chat/*"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}