summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2021-07-16 17:00:57 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-07-16 17:05:52 -0700
commit7fc1afa3705d7c107e17f9a1e9402aeece0acd56 (patch)
tree8bc3599c04e4e4f209fb8ece624eab9e0bd4ef82 /net-im
parentsci-visualization/epix: cleanup (diff)
downloadgentoo-7fc1afa3705d7c107e17f9a1e9402aeece0acd56.tar.gz
gentoo-7fc1afa3705d7c107e17f9a1e9402aeece0acd56.tar.bz2
gentoo-7fc1afa3705d7c107e17f9a1e9402aeece0acd56.zip
net-im/telegram-desktop: Bump to 2.8.10
Closes: https://github.com/gentoo/gentoo/pull/21674 Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telegram-desktop/Manifest1
-rw-r--r--net-im/telegram-desktop/files/tdesktop-2.8.9-disable-jemalloc-separately.patch100
-rw-r--r--net-im/telegram-desktop/files/tdesktop-2.8.9-disable-webkit-separately.patch122
-rw-r--r--net-im/telegram-desktop/files/tdesktop-2.8.9-webview-fix-glib.patch31
-rw-r--r--net-im/telegram-desktop/telegram-desktop-2.8.10.ebuild147
5 files changed, 401 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/Manifest b/net-im/telegram-desktop/Manifest
index 96744242fc0b..e246987bf0e2 100644
--- a/net-im/telegram-desktop/Manifest
+++ b/net-im/telegram-desktop/Manifest
@@ -1,2 +1,3 @@
DIST tdesktop-2.7.4-full.tar.gz 36894673 BLAKE2B e04749fb0168f8bae69a9ad85c5bff315faf0b355ff5f3a85a34ee36e3305c6b550553284d5179aff9283bbd1a94f9ec3c41e293d0ad8c86e4d08283189e42b3 SHA512 0a796d7a8c5e5982bc60f19c41da53996a609bf794fad224e7beea5fc3816b5cf35f16b0ec2cc7279085c69996063a44085f48e1596dfe746d260a2e8f1b2d14
DIST tdesktop-2.8.1-full.tar.gz 37129127 BLAKE2B 06f2a3050f0e0f321c766c54e19faf3ea172c41088e2ffdbb5928a41ba01de1fc845a84addded17d113316857c68f265642a8ab32feb79a87beef548c739b56c SHA512 df35cc00dc47a8c65b32b62c139cc3a49333f573aa88fb70cc65197524f9b9b4756c58752866c843704ea4df5d6224eb4cba5b32953dd9a4d721b0ee0e1efc69
+DIST tdesktop-2.8.10-full.tar.gz 37105631 BLAKE2B 71a08e0d2fda90898e711dd285478e565ddf7f6bd71db8910688c7f0bb550f04136cb3ccec101d5e89860471ffdd7a868dd90a6317924e96c8ad558d4e3079f2 SHA512 910e34718a061d643937393fa105f2236549059eaecc56aab1203a0efa3a7538f7a2d9b432c8b0a9269118ef3bff56dc1edf856476629efe666d16851e68932f
diff --git a/net-im/telegram-desktop/files/tdesktop-2.8.9-disable-jemalloc-separately.patch b/net-im/telegram-desktop/files/tdesktop-2.8.9-disable-jemalloc-separately.patch
new file mode 100644
index 000000000000..dff2455d4e3d
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-2.8.9-disable-jemalloc-separately.patch
@@ -0,0 +1,100 @@
+Allow controlling the use of jemalloc
+
+Jemalloc is often controlled through USE=jemalloc in Gentoo. Removing or
+replacing it is trivial, and I'm not aware of any particular advantages that
+come with using this allocator, especially for an IM client. Benchmarks
+regarding this allocator provide a huge variety of results depending on the
+workload and system, so it's hard to establish when this allocator provides any
+tangible advantage.
+
+Considering things like Hardened Gentoo, the user might prefer to use a more
+exploit-resistant allocator, like GrapheneOS/hardened_malloc, and I've heard
+Musl is hardening their allocator as well.
+
+I trust the user can better judge if they need this in their particular setup.
+
+If a telegram dev is reading this, feel free to drop me a message (metadata.xml
+contains the maintainer's address), if you believe it should be forced due to
+usability concerns, or if you can provide me with some context I might be
+missing. Jemalloc is currently enabled by default.
+
+--- tdesktop-2.8.9-full.orig/Telegram/SourceFiles/platform/linux/specific_linux.cpp
++++ tdesktop-2.8.9-full/Telegram/SourceFiles/platform/linux/specific_linux.cpp
+@@ -48,7 +48,10 @@
+ #include <gio/gio.h>
+ #include <glibmm.h>
+ #include <giomm.h>
++
++#ifndef DESKTOP_APP_DISABLE_JEMALLOC
+ #include <jemalloc/jemalloc.h>
++#endif // !DESKTOP_APP_DISABLE_JEMALLOC
+
+ #include <sys/stat.h>
+ #include <sys/types.h>
+@@ -727,8 +730,10 @@
+ namespace Platform {
+
+ void start() {
++#ifndef DESKTOP_APP_DISABLE_JEMALLOC
+ auto backgroundThread = true;
+ mallctl("background_thread", nullptr, nullptr, &backgroundThread, sizeof(bool));
++#endif // !DESKTOP_APP_DISABLE_JEMALLOC
+
+ LOG(("Launcher filename: %1").arg(QGuiApplication::desktopFileName()));
+
+--- tdesktop-2.8.9-full.orig/cmake/external/CMakeLists.txt
++++ tdesktop-2.8.9-full/cmake/external/CMakeLists.txt
+@@ -37,7 +37,7 @@
+ add_checked_subdirectory(hunspell)
+ endif()
+ add_checked_subdirectory(iconv)
+-if (LINUX)
++if (LINUX AND NOT DESKTOP_APP_DISABLE_JEMALLOC)
+ add_checked_subdirectory(jemalloc)
+ endif()
+ add_checked_subdirectory(jpeg)
+--- tdesktop-2.8.9-full.orig/cmake/options.cmake
++++ tdesktop-2.8.9-full/cmake/options.cmake
+@@ -56,6 +56,13 @@
+ )
+ endif()
+
++if (DESKTOP_APP_DISABLE_JEMALLOC)
++ target_compile_definitions(common_options
++ INTERFACE
++ DESKTOP_APP_DISABLE_JEMALLOC
++ )
++endif()
++
+ if (DESKTOP_APP_USE_PACKAGED)
+ target_compile_definitions(common_options
+ INTERFACE
+--- tdesktop-2.8.9-full.orig/cmake/options_linux.cmake
++++ tdesktop-2.8.9-full/cmake/options_linux.cmake
+@@ -58,10 +58,12 @@
+ endif()
+ endif()
+
+-target_link_libraries(common_options
+-INTERFACE
+- desktop-app::external_jemalloc
+-)
++if (NOT DESKTOP_APP_DISABLE_JEMALLOC)
++ target_link_libraries(common_options
++ INTERFACE
++ desktop-app::external_jemalloc
++ )
++endif()
+
+ if (DESKTOP_APP_USE_PACKAGED)
+ find_library(ATOMIC_LIBRARY atomic)
+--- tdesktop-2.8.9-full.orig/cmake/variables.cmake
++++ tdesktop-2.8.9-full/cmake/variables.cmake
+@@ -38,6 +38,7 @@
+ option(DESKTOP_APP_USE_PACKAGED_FFMPEG_STATIC "Link ffmpeg statically in packaged mode." OFF)
+ option(DESKTOP_APP_DISABLE_SPELLCHECK "Disable spellcheck library." ${osx_special_target})
+ option(DESKTOP_APP_DISABLE_WEBKIT "Disable WebkitGTK library (Linux only)." OFF)
++option(DESKTOP_APP_DISABLE_JEMALLOC "Disable use of the jemalloc allocator (Linux only)." OFF)
+ option(DESKTOP_APP_DISABLE_CRASH_REPORTS "Disable crash report generation." ${no_special_target})
+ option(DESKTOP_APP_DISABLE_AUTOUPDATE "Disable autoupdate." ${disable_autoupdate})
+ option(DESKTOP_APP_USE_HUNSPELL_ONLY "Disable system spellchecker and use bundled Hunspell only. (For debugging purposes)" OFF)
diff --git a/net-im/telegram-desktop/files/tdesktop-2.8.9-disable-webkit-separately.patch b/net-im/telegram-desktop/files/tdesktop-2.8.9-disable-webkit-separately.patch
new file mode 100644
index 000000000000..388e09fa58d2
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-2.8.9-disable-webkit-separately.patch
@@ -0,0 +1,122 @@
+Allow controlling the use of webkit-gtk
+
+WebKitGTK is used to display payment pages when buying things in Telegram
+shops. This library can be disabled properly alongside the GTK integration with
+its flag. However, I reckon *most* users want the GTK integration (fixes
+pasting big images, amongst other things), but hardly anyone actually buys
+things through Telegram. Controlling these two things separately is trivial, and
+the user gets a nice dialog telling them WebKitGTK isn't available in the event
+they *do* attempt to use the related features.
+
+NOTE: GTK integration *must* be enabled for WebKitGTK to work.
+
+--- tdesktop-2.8.9-full.orig/Telegram/SourceFiles/platform/linux/linux_gtk_integration.cpp
++++ tdesktop-2.8.9-full/Telegram/SourceFiles/platform/linux/linux_gtk_integration.cpp
+@@ -587,9 +587,11 @@
+ if (const auto integration = BaseGtkIntegration::Instance()) {
+ return integration->exec(parentDBusName);
+ }
++#ifndef DESKTOP_APP_DISABLE_WEBKIT
+ } else if (type == Type::Webview) {
+ Webview::WebKit2Gtk::SetServiceName(serviceName.toStdString());
+ return Webview::WebKit2Gtk::Exec(parentDBusName.toStdString());
++#endif
+ } else if (type == Type::TDesktop) {
+ ServiceName = serviceName.toStdString();
+ if (const auto integration = Instance()) {
+@@ -602,7 +604,9 @@
+
+ void GtkIntegration::Start(Type type) {
+ if (type != Type::Base
++#ifndef DESKTOP_APP_DISABLE_WEBKIT
+ && type != Type::Webview
++#endif
+ && type != Type::TDesktop) {
+ return;
+ }
+@@ -613,11 +617,13 @@
+
+ if (type == Type::Base) {
+ BaseGtkIntegration::SetServiceName(kBaseService.utf16().arg(h));
++#ifndef DESKTOP_APP_DISABLE_WEBKIT
+ } else if (type == Type::Webview) {
+ Webview::WebKit2Gtk::SetServiceName(
+ kWebviewService.utf16().arg(h).arg("%1").toStdString());
+
+ return;
++#endif
+ } else {
+ ServiceName = kService.utf16().arg(h).toStdString();
+ }
+--- tdesktop-2.8.9-full.orig/Telegram/lib_webview/CMakeLists.txt
++++ tdesktop-2.8.9-full/Telegram/lib_webview/CMakeLists.txt
+@@ -48,7 +48,7 @@
+ nuget_add_webview(lib_webview)
+ nuget_add_winrt(lib_webview)
+ elseif (LINUX)
+- if (NOT DESKTOP_APP_DISABLE_GTK_INTEGRATION)
++ if (NOT DESKTOP_APP_DISABLE_WEBKIT)
+ find_package(PkgConfig REQUIRED)
+
+ if (DESKTOP_APP_USE_PACKAGED AND NOT DESKTOP_APP_USE_PACKAGED_LAZY)
+--- tdesktop-2.8.9-full.orig/Telegram/lib_webview/webview/platform/linux/webview_linux.cpp
++++ tdesktop-2.8.9-full/Telegram/lib_webview/webview/platform/linux/webview_linux.cpp
+@@ -11,14 +11,14 @@
+ namespace Webview {
+
+ Available Availability() {
+-#ifndef DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#ifndef DESKTOP_APP_DISABLE_WEBKIT
+ return WebKit2Gtk::Availability();
+-#else // !DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#else // !DESKTOP_APP_DISABLE_WEBKIT
+ return Available{
+ .error = Available::Error::NoGtkOrWebkit2Gtk,
+ .details = "This feature was disabled at build time.",
+ };
+-#endif // DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#endif // DESKTOP_APP_DISABLE_WEBKIT
+ }
+
+ bool SupportsEmbedAfterCreate() {
+@@ -26,11 +26,11 @@
+ }
+
+ std::unique_ptr<Interface> CreateInstance(Config config) {
+-#ifndef DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#ifndef DESKTOP_APP_DISABLE_WEBKIT
+ return WebKit2Gtk::CreateInstance(std::move(config));
+-#else // !DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#else // !DESKTOP_APP_DISABLE_WEBKIT
+ return nullptr;
+-#endif // DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#endif // DESKTOP_APP_DISABLE_WEBKIT
+ }
+
+ } // namespace Webview
+--- tdesktop-2.8.9-full.orig/cmake/options.cmake
++++ tdesktop-2.8.9-full/cmake/options.cmake
+@@ -49,6 +49,13 @@
+ )
+ endif()
+
++if (DESKTOP_APP_DISABLE_WEBKIT)
++ target_compile_definitions(common_options
++ INTERFACE
++ DESKTOP_APP_DISABLE_WEBKIT
++ )
++endif()
++
+ if (DESKTOP_APP_USE_PACKAGED)
+ target_compile_definitions(common_options
+ INTERFACE
+--- tdesktop-2.8.9-full.orig/cmake/variables.cmake
++++ tdesktop-2.8.9-full/cmake/variables.cmake
+@@ -37,6 +37,7 @@
+ option(DESKTOP_APP_USE_PACKAGED_LAZY "Bundle recommended Qt plugins for self-contained packages. (Linux only)" OFF)
+ option(DESKTOP_APP_USE_PACKAGED_FFMPEG_STATIC "Link ffmpeg statically in packaged mode." OFF)
+ option(DESKTOP_APP_DISABLE_SPELLCHECK "Disable spellcheck library." ${osx_special_target})
++option(DESKTOP_APP_DISABLE_WEBKIT "Disable WebkitGTK library (Linux only)." OFF)
+ option(DESKTOP_APP_DISABLE_CRASH_REPORTS "Disable crash report generation." ${no_special_target})
+ option(DESKTOP_APP_DISABLE_AUTOUPDATE "Disable autoupdate." ${disable_autoupdate})
+ option(DESKTOP_APP_USE_HUNSPELL_ONLY "Disable system spellchecker and use bundled Hunspell only. (For debugging purposes)" OFF)
diff --git a/net-im/telegram-desktop/files/tdesktop-2.8.9-webview-fix-glib.patch b/net-im/telegram-desktop/files/tdesktop-2.8.9-webview-fix-glib.patch
new file mode 100644
index 000000000000..02c96d28b2c1
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-2.8.9-webview-fix-glib.patch
@@ -0,0 +1,31 @@
+Fixes an issue with glib headers including a C++ header inside extern "C"
+
+This patch is a hacky workaround, proper solution doesn't seem trivial.
+
+In file included from /usr/include/glib-2.0/glib/gatomic.h:31,
+ from /usr/include/glib-2.0/glib/gthread.h:32,
+ from /usr/include/glib-2.0/glib/gasyncqueue.h:32,
+ from /usr/include/glib-2.0/glib.h:32,
+ from /usr/include/gtk-3.0/gdk/gdkconfig.h:13,
+ from /usr/include/gtk-3.0/gdk/gdk.h:30,
+ from /usr/include/gtk-3.0/gtk/gtk.h:30,
+ from /var/tmp/portage/net-im/telegram-desktop-2.8.9/work/tdesktop-2.8.9-full/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.h:11,
+ from /var/tmp/portage/net-im/telegram-desktop-2.8.9/work/tdesktop-2.8.9-full/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.cpp:7:
+/usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/include/g++-v11/type_traits:56:3: error: template with C linkage
+ 56 | template<typename _Tp, _Tp __v>
+ | ^~~~~~~~
+In file included from /var/tmp/portage/net-im/telegram-desktop-2.8.9/work/tdesktop-2.8.9-full/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.cpp:7:
+/var/tmp/portage/net-im/telegram-desktop-2.8.9/work/tdesktop-2.8.9-full/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.h:9:1: note: extern "C" linkage started here
+ 9 | extern "C" {
+ | ^~~~~~~~~~
+
+--- tdesktop-2.8.9-full.orig/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.h
++++ tdesktop-2.8.9-full/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.h
+@@ -6,6 +6,7 @@
+ //
+ #pragma once
+
++#include <type_traits> // Required for glib/gatomic.h
+ extern "C" {
+ #include <JavaScriptCore/JavaScript.h>
+ #include <gtk/gtk.h>
diff --git a/net-im/telegram-desktop/telegram-desktop-2.8.10.ebuild b/net-im/telegram-desktop/telegram-desktop-2.8.10.ebuild
new file mode 100644
index 000000000000..375320d45838
--- /dev/null
+++ b/net-im/telegram-desktop/telegram-desktop-2.8.10.ebuild
@@ -0,0 +1,147 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit xdg cmake python-any-r1 flag-o-matic
+
+DESCRIPTION="Official desktop client for Telegram"
+HOMEPAGE="https://desktop.telegram.org"
+
+MY_P="tdesktop-${PV}-full"
+SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-3-with-openssl-exception LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+dbus enchant +gtk +hunspell +jemalloc +spell wayland webkit +X"
+REQUIRED_USE="
+ spell? (
+ ^^ ( enchant hunspell )
+ )
+ webkit? ( gtk )
+ gtk? ( dbus )
+"
+
+RDEPEND="
+ !net-im/telegram-desktop-bin
+ app-arch/lz4:=
+ dev-cpp/glibmm:2
+ dev-libs/xxhash
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5[dbus?,jpeg,png,wayland?,X(-)?]
+ >=dev-qt/qtimageformats-5.15:5
+ >=dev-qt/qtnetwork-5.15:5[ssl]
+ >=dev-qt/qtsvg-5.15:5
+ >=dev-qt/qtwidgets-5.15:5[png,X(-)?]
+ media-fonts/open-sans
+ media-libs/fontconfig:=
+ ~media-libs/libtgvoip-2.4.4_p20210302
+ >=media-libs/libtgvoip-2.4.4_p20210302-r2
+ media-libs/openal
+ media-libs/opus:=
+ media-libs/rnnoise
+ ~media-libs/tg_owt-0_pre20210626
+ media-video/ffmpeg:=[opus]
+ sys-libs/zlib:=[minizip]
+ dbus? (
+ dev-qt/qtdbus:5
+ dev-libs/libdbusmenu-qt[qt5(+)]
+ )
+ enchant? ( app-text/enchant:= )
+ gtk? ( x11-libs/gtk+:3[X?,wayland?] )
+ hunspell? ( >=app-text/hunspell-1.7:= )
+ jemalloc? ( dev-libs/jemalloc:= )
+ wayland? ( kde-frameworks/kwayland:= )
+ webkit? ( net-libs/webkit-gtk:= )
+ X? ( x11-libs/libxcb:= )
+"
+DEPEND="${RDEPEND}
+ dev-cpp/range-v3
+ =dev-cpp/ms-gsl-3*
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/cmake-3.16
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ # https://github.com/desktop-app/cmake_helpers/pull/91
+ # https://github.com/desktop-app/lib_webview/pull/2
+ "${FILESDIR}/tdesktop-2.8.9-disable-webkit-separately.patch"
+ # Not going to attempt upstreaming this after the reaction to
+ # "disable-webkit-separately"
+ "${FILESDIR}/tdesktop-2.8.9-disable-jemalloc-separately.patch"
+ # Not a proper fix, not upstreamed
+ "${FILESDIR}/tdesktop-2.8.9-webview-fix-glib.patch"
+)
+
+pkg_pretend() {
+ if has ccache ${FEATURES}; then
+ ewarn
+ ewarn "ccache does not work with ${PN} out of the box"
+ ewarn "due to usage of precompiled headers"
+ ewarn "check bug https://bugs.gentoo.org/715114 for more info"
+ ewarn
+ fi
+}
+
+src_prepare() {
+ # no explicit toggle, doesn't build with the system one #752417
+ sed -i 's/DESKTOP_APP_USE_PACKAGED/NO_ONE_WILL_EVER_SET_THIS/' \
+ cmake/external/rlottie/CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # gtk is really needed for image copy-paste due to https://bugreports.qt.io/browse/QTBUG-56595
+ local mycmakeargs=(
+ -DTDESKTOP_LAUNCHER_BASENAME="${PN}"
+ -DCMAKE_DISABLE_FIND_PACKAGE_tl-expected=ON # header only lib, some git version. prevents warnings.
+
+ -DDESKTOP_APP_DISABLE_X11_INTEGRATION=$(usex X OFF ON)
+ -DDESKTOP_APP_DISABLE_WAYLAND_INTEGRATION=$(usex wayland OFF ON)
+ -DDESKTOP_APP_DISABLE_DBUS_INTEGRATION=$(usex dbus OFF ON)
+ -DDESKTOP_APP_DISABLE_GTK_INTEGRATION=$(usex gtk OFF ON)
+ -DDESKTOP_APP_DISABLE_WEBKIT=$(usex webkit OFF ON)
+ -DDESKTOP_APP_DISABLE_JEMALLOC=$(usex jemalloc OFF ON)
+ -DDESKTOP_APP_DISABLE_SPELLCHECK=$(usex spell OFF ON) # enables hunspell (recommended)
+ -DDESKTOP_APP_USE_ENCHANT=$(usex enchant ON OFF) # enables enchant and disables hunspell
+ )
+
+ if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
+ einfo "Found custom API credentials"
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
+ -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
+ )
+ else
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+ # Building with snapcraft API credentials by default
+ # Custom API credentials can be obtained here:
+ # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+ # After getting credentials you can export variables:
+ # export MY_TDESKTOP_API_ID="17349""
+ # export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+ # and restart the build"
+ # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+ # portage will use custom variable every build automatically
+ mycmakeargs+=(
+ -DTDESKTOP_API_ID="611335"
+ -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ use gtk || elog "enable 'gtk' useflag if you have image copy-paste problems"
+}