summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-26 15:38:34 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-26 15:40:07 +0200
commit86212933941406eb85c6ed76525f4a134a136050 (patch)
tree16218d4a9af14f234374c57a8ec226f63be5e4ba /net-im
parentapp-misc/radeontop: fit for gentoo prefix (diff)
downloadgentoo-86212933941406eb85c6ed76525f4a134a136050.tar.gz
gentoo-86212933941406eb85c6ed76525f4a134a136050.tar.bz2
gentoo-86212933941406eb85c6ed76525f4a134a136050.zip
net-im/rocketchat-desktop-bin: add version 3.4.0
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.4.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 66c5388bfd4d..0e1f5cd037da 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1,2 +1,3 @@
DIST rocketchat-3.2.3.x86_64.rpm 55375960 BLAKE2B e72e0f29662bc9667c782866c42d334239fbe39b20a7ca232aeafe5f16244248ee940f301b0a0f4d2101150746e48d0ff47bdf55d99371a06226937876dd9765 SHA512 ced1fce3b7f12ceda10a1879612065a0e65dc6ccc4cb3a3a282cae578267a03468ea85820a6a765af3d1d72dbde9a04a0d5199a150ce257dd4d44151e4d6ca06
DIST rocketchat-3.3.0.x86_64.rpm 56322356 BLAKE2B 9d1caaceb16fa68fdfb11d41dae4a7d464e7bb9f92fa3f734f273447228faee53e958e0e87934e9cc5c4b1a133e18ebe610dcf429b780993a20e9a44251d7480 SHA512 e3bda69d0395823a40c56909ef4ae6faee1dcc733eee20ef3067cd7bf57066056505efa2a3817d2640ea7bee0cc0920cdf187dddd53320c224cbe2c3efc21088
+DIST rocketchat-3.4.0.x86_64.rpm 58636916 BLAKE2B d78af6b205ec58938a8e12767fb8e1ca8e6ad2ed2b44c2be6257384ee330bbb0175b16be27c2bcde08a26d3b3cc339f3713c69bede99e4c55f71b30c37b56176 SHA512 6bbb3cbbbe49270428fae18a9c2028f50f45bc83192a4c8d322ae8a8e04d17454c1cf529984f74a670243949a20efd82c56525c6ae4aa9c9f718d78165a08519
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.4.0.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.4.0.ebuild
new file mode 100644
index 000000000000..d39837616a97
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ cp -a "${S}"/* "${ED}" || die
+}