summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-21 15:35:39 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-21 15:35:39 +0200
commita66d5ced8a41fba520b7586c76376fd4e99f8d91 (patch)
tree7be3080ebbb4e696c316878853d59e69e1855f80 /net-im
parentdev-python/rdflib: add 6.0.1, enable py3.10 (diff)
downloadgentoo-a66d5ced8a41fba520b7586c76376fd4e99f8d91.tar.gz
gentoo-a66d5ced8a41fba520b7586c76376fd4e99f8d91.tar.bz2
gentoo-a66d5ced8a41fba520b7586c76376fd4e99f8d91.zip
net-im/rocketchat-desktop-bin: add version 3.5.5
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.5.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index df4f6640130c..67f84635239d 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.5.4.x86_64.rpm 58601052 BLAKE2B 72ab756661822e50f44b68cd5e1138f0d73fd7b3000375716a06306b034c9ab62c8d2a38ec8389cbc27a1f63b2483deccf02a481cbd28902e2bba8596cf81da9 SHA512 3c46905410d60ac380e8a0addf3cdf942de13dfc72e781e73b300f7a6e4ade96b4835fad13a21efea044b7d910f20584d3bc58958f3d117afe2ebb33bc3bf3c6
+DIST rocketchat-3.5.5.x86_64.rpm 58601332 BLAKE2B 7f54c2c3d75925a485e6f23c8d933977571b3d90e22c61bcde19be050ed4c7b12d090bcdd314bc8dca963c7ae860f87c57bca7d1421bc71b72a707deca996a7b SHA512 230c532096abfee0877b381b89663adee99b42043b3cd1a1ee0491d6b77eff170a8ac5f3e9385aa279ff16c1cc3839c86621e444eb1a9954e00783981161ae9e
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.5.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.5.ebuild
new file mode 100644
index 000000000000..46fc3d26d958
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}