summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-16 19:43:16 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-16 19:43:16 +0200
commitb1963f9809dddbf6fe71873ea2e0f2180a9f9c20 (patch)
tree8536131567bc1122d632d609d8004b2fdd7a827f /net-im
parentnet-libs/nodejs: add 16.9.1, drop 16.6.2-r1 (diff)
downloadgentoo-b1963f9809dddbf6fe71873ea2e0f2180a9f9c20.tar.gz
gentoo-b1963f9809dddbf6fe71873ea2e0f2180a9f9c20.tar.bz2
gentoo-b1963f9809dddbf6fe71873ea2e0f2180a9f9c20.zip
net-im/rocketchat-desktop-bin: add version 3.5.4
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 4390ea9a9568..02190cf6a997 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.5.3.x86_64.rpm 58606036 BLAKE2B 22a13b9f5410e24c54b9426ee1d9c5d13affdee450d45c7a933e5f8bacb008de1e18c0af2ad31d89dad0c54e1212b93362fece21d724218275d38140180407ea SHA512 84ccdd4b99c257a1f4b0bdf4fb2b10b30f6b1acc5c6e1d92a03912f711cf56d9f423e7984431cfd74de9a805c181f4fe83c8893e7dff8fd50fa548ac4892b1fc
+DIST rocketchat-3.5.4.x86_64.rpm 58601052 BLAKE2B 72ab756661822e50f44b68cd5e1138f0d73fd7b3000375716a06306b034c9ab62c8d2a38ec8389cbc27a1f63b2483deccf02a481cbd28902e2bba8596cf81da9 SHA512 3c46905410d60ac380e8a0addf3cdf942de13dfc72e781e73b300f7a6e4ade96b4835fad13a21efea044b7d910f20584d3bc58958f3d117afe2ebb33bc3bf3c6
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.4.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.4.ebuild
new file mode 100644
index 000000000000..46fc3d26d958
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.5.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}