summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRaymond Jennings <shentino@gmail.com>2016-10-11 02:07:58 -0700
committerDavid Seifert <soap@gentoo.org>2016-10-12 09:36:36 +0200
commitb9159d99f45205fa3d431c61b6090ffaab9b575c (patch)
tree18771a6a3a3539f10e1ce9e97dc939ae77879677 /net-im
parentmedia-gfx/eog: version bump 3.20.4 → 3.20.5 (diff)
downloadgentoo-b9159d99f45205fa3d431c61b6090ffaab9b575c.tar.gz
gentoo-b9159d99f45205fa3d431c61b6090ffaab9b575c.tar.bz2
gentoo-b9159d99f45205fa3d431c61b6090ffaab9b575c.zip
net-im/skypeforlinux: Version bump to 1.10.0.1
Closes: https://github.com/gentoo/gentoo/pull/2530 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/skypeforlinux/Manifest1
-rw-r--r--net-im/skypeforlinux/skypeforlinux-1.10.0.1.ebuild125
2 files changed, 126 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index ca5e07d71aa0..65fbe410ded3 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -1 +1,2 @@
+DIST skypeforlinux_1.10.0.1-1.x86_64.rpm 62779116 SHA256 24e83f598b0729649e9562f0265ca12236cc53775d7bc1bc9e14cf5de48848ff SHA512 f3e9947588bab83fcc3cdedf455e18d93da9ae1098cb55acb7494552b1f8f97508abac6cdf987f67db779fa5f2786c1fd8e22032936f6100258260c5fb399272 WHIRLPOOL ad5078392d8f49c33a1810afc653175e9ad36e2ece118f92818c3c1cc2a1b6ed0328f9f623958aefd635048ba586ec6f2b502aed6a4ef76bb970e1f25528eab2
DIST skypeforlinux_1.9.0.2-1.x86_64.rpm 62767691 SHA256 9b838d5c0aa72287a96a5a11b150dbf647c50fe65aa2a386be8af7002e477e61 SHA512 9390c60f0cd7e643e8806596b6a1cdadffb45086fc456218f59361ffe74adb2adfbba4893d3276b59f1435067146d90becd1c644008932c6efcc978bd4288c8c WHIRLPOOL 631b471593e590aa7f2642e410c58971b07dd42f6c1bd8447c070c9b29dd18514f4d38f73c63e296d3e449d8a12ac5fb088f38ecdd6e81d922fd0b173c969d42
diff --git a/net-im/skypeforlinux/skypeforlinux-1.10.0.1.ebuild b/net-im/skypeforlinux/skypeforlinux-1.10.0.1.ebuild
new file mode 100644
index 000000000000..106a1e5e078f
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-1.10.0.1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+#inherit eutils rpm pax-utils
+inherit eutils rpm
+
+DESCRIPTION="P2P Internet Telephony (VoiceIP) client"
+HOMEPAGE="http://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS no-source-code"
+SLOT="0"
+KEYWORDS="~amd64"
+#IUSE="pax_kernel selinux"
+IUSE=""
+
+S="${WORKDIR}"
+QA_PREBUILT=opt/skypeforlinux/skypeforlinux
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="virtual/ttf-fonts
+ !net-im/skype:1
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gconf:2
+ gnome-base/libgnome-keyring
+ media-libs/alsa-lib
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/pango"
+# selinux? ( sec-policy/selinux-skype )"
+
+src_unpack () {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EROOT%/}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Exec=.*!Exec=${EROOT%/}/opt/bin/skypeforlinux!" \
+ -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ insinto /opt/skypeforlinux/locales
+ doins usr/share/skypeforlinux/locales/*.pak
+
+ insinto /opt/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release
+ doins usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release/keytar.node
+
+ insinto /opt/skypeforlinux/resources
+ doins usr/share/skypeforlinux/resources/*.asar
+
+ insinto /opt/skypeforlinux
+ doins usr/share/skypeforlinux/*.pak
+ doins usr/share/skypeforlinux/*.bin
+ doins usr/share/skypeforlinux/*.dat
+ doins usr/share/skypeforlinux/version
+ exeinto /opt/skypeforlinux
+ doexe usr/share/skypeforlinux/*.so
+ doexe usr/share/skypeforlinux/skypeforlinux
+
+ into /opt
+ dobin usr/bin/skypeforlinux
+ fowners root:audio /opt/bin/skypeforlinux /opt/skypeforlinux/skypeforlinux
+
+# insinto /etc/dbus-1/system.d
+# doins ${PN}.conf
+
+ dodoc -r usr/share/doc/skypeforlinux/.
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+# if use pax_kernel; then
+# if use apulse; then
+# pax-mark Cm "${ED}"/opt/bin/${PN}-bin || die
+# else
+# pax-mark Cm "${ED}"/opt/bin/${PN} || die
+# fi
+# eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+# eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+# eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+# eqawarn "you suspect that ${PN} is being broken by this modification,"
+# eqawarn "please open a bug."
+# fi
+
+# echo PRELINK_PATH_MASK=/opt/bin/${PN} > ${T}/99${PN}
+# doenvd "${T}"/99${PN} #430142
+}
+
+pkg_postinst() {
+ einfo "See https://support.skype.com/en/faq/FA34656"
+ einfo "for more information about Skype for Linux Alpha."
+}