summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-12-04 01:02:03 +0000
committerYixun Lan <dlan@gentoo.org>2023-12-04 01:02:03 +0000
commitdf6782e32c0bde31187e7d785bba28800bc72126 (patch)
treec147f5a7baa79c2515c2cac18091eff7ed042320 /net-im
parentapp-backup/snapper: add 0.10.7 (diff)
downloadgentoo-df6782e32c0bde31187e7d785bba28800bc72126.tar.gz
gentoo-df6782e32c0bde31187e7d785bba28800bc72126.tar.bz2
gentoo-df6782e32c0bde31187e7d785bba28800bc72126.zip
net-im/slack: add 4.35.131
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/slack/Manifest1
-rw-r--r--net-im/slack/slack-4.35.131.ebuild114
2 files changed, 115 insertions, 0 deletions
diff --git a/net-im/slack/Manifest b/net-im/slack/Manifest
index 46dfc6bd828f..fc5f8c3fe606 100644
--- a/net-im/slack/Manifest
+++ b/net-im/slack/Manifest
@@ -1,2 +1,3 @@
DIST slack-desktop-4.35.121-amd64.deb 78549434 BLAKE2B a2e75806f43bfbd7e052c554ea42b409c0648b9fcfad144023268d5a865e587448e19524d0c35997421a528ca514633025f982f88680c9da79f17f6da8493ae0 SHA512 94cb4cbd9c7d0317bc7b8b8515e8d4b0e766d0f6fb06e673bbec72cfb6d8c7834e3a8e60f451b955e0fd5f1ae40c9bfb765907648fa7058c804be3e639f2d61d
DIST slack-desktop-4.35.126-amd64.deb 78399722 BLAKE2B 0cee9b9f33654a14b468071ea85cdba0391effc623f9d4896ca653b82e5c55eda0d46616185c8bc759ad79f8de16f0c53c27c60885fe04b53656c9c23efa0ff0 SHA512 64991f84ad2693d33e22a269e67fec0450dfc3e631a15dc4a4dfc708c0d0926f90555d18a79960e3af603a5ca53f0b60189b64eea59a13d0e601a25bc9e1ba9d
+DIST slack-desktop-4.35.131-amd64.deb 78415154 BLAKE2B 9527c7ee4ac8f88dc6b38a30e3d0fc4759a9e57ef6966ee5059988bb8f0462e769a36efa90d4ad56725f5e0aeb5d0c4cd238d36b6913503877a40ac89d25f9b4 SHA512 696fe940be93673954faa3384c69d57be0089048216628cabae3d6972aebba60e2207f8388e9c4b0f97c4cd9687b3bead6d3420a9ea20a233d88c409daeb522d
diff --git a/net-im/slack/slack-4.35.131.ebuild b/net-im/slack/slack-4.35.131.ebuild
new file mode 100644
index 000000000000..f0291e2700fa
--- /dev/null
+++ b/net-im/slack/slack-4.35.131.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit desktop multilib-build optfeature pax-utils unpacker xdg
+
+DESCRIPTION="Team collaboration tool"
+HOMEPAGE="https://slack.com"
+SRC_URI="https://downloads.slack-edge.com/releases/linux/${PV}/prod/x64/${PN}-desktop-${PV}-amd64.deb"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="appindicator +seccomp suid wayland"
+RESTRICT="bindist mirror"
+
+RDEPEND="app-accessibility/at-spi2-core:2[${MULTILIB_USEDEP}]
+ dev-libs/expat:0[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr:0[${MULTILIB_USEDEP}]
+ dev-libs/nss:0[${MULTILIB_USEDEP}]
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib:0[${MULTILIB_USEDEP}]
+ media-libs/mesa:0[${MULTILIB_USEDEP}]
+ net-print/cups:0[${MULTILIB_USEDEP}]
+ sys-apps/dbus:0[${MULTILIB_USEDEP}]
+ x11-libs/cairo:0[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libdrm:0[${MULTILIB_USEDEP}]
+ x11-libs/libX11:0[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:0/1.12[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite:0[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage:0[${MULTILIB_USEDEP}]
+ x11-libs/libXext:0[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes:0[${MULTILIB_USEDEP}]
+ x11-libs/libxkbcommon:0[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:0[${MULTILIB_USEDEP}]
+ x11-libs/pango:0[${MULTILIB_USEDEP}]
+ appindicator? ( dev-libs/libayatana-appindicator )"
+
+QA_PREBUILT="opt/slack/chrome-sandbox
+ opt/slack/chrome_crashpad_handler
+ opt/slack/libEGL.so
+ opt/slack/libGLESv2.so
+ opt/slack/libffmpeg.so
+ opt/slack/libvk_swiftshader.so
+ opt/slack/libvulkan.so.1
+ opt/slack/resources/app.asar.unpacked/node_modules/*
+ opt/slack/slack
+ opt/slack/swiftshader/libEGL.so
+ opt/slack/swiftshader/libGLESv2.so"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # remove hardcoded path, logging noise (wrt 694058, 711494)
+ sed -i -e '/Icon/s|/usr/share/pixmaps/slack.png|slack|' \
+ -e '/Exec/s|slack|slack -s|' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed in Icon for slack.desktop"
+
+ if use appindicator ; then
+ sed -i '/Exec/s|=|=env XDG_CURRENT_DESKTOP=Unity |' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed for appindicator"
+ fi
+
+ if ! use seccomp ; then
+ sed -i '/Exec/s/%U/%U --disable-seccomp-filter-sandbox/' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed for seccomp"
+ fi
+
+ if use wayland ; then
+ sed -i '/Exec/s/%U/%U --enable-features=WebRTCPipeWireCapturer/' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed for wayland"
+ fi
+
+ rm usr/lib/slack/LICENSE{,S-linux.json} \
+ || die "rm licenses failed"
+}
+
+src_install() {
+ doicon usr/share/pixmaps/slack.png
+ doicon -s 512 usr/share/pixmaps/slack.png
+ domenu usr/share/applications/slack.desktop
+
+ insinto /opt # wrt 720134
+ cp -a usr/lib/slack "${ED}"/opt || die "cp failed"
+
+ use suid && fperms u+s /opt/slack/chrome-sandbox # wrt 713094
+ dosym ../../opt/slack/slack usr/bin/slack
+
+ pax-mark -m "${ED}"/opt/slack/slack
+
+ # https://bugs.gentoo.org/898912
+ if use appindicator; then
+ dosym ../../usr/lib64/libayatana-appindicator3.so /opt/slack/libappindicator3.so
+ fi
+}
+
+pkg_postinst() {
+ optfeature "storing passwords via gnome-keyring" app-crypt/libsecret
+
+ xdg_pkg_postinst
+}