summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-15 13:23:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-28 16:29:22 +0200
commitfe5389275a22171e813d9549e678d57419372eca (patch)
tree66ac909d6ba9662217eb868a3b128c5aae9952ef /net-im
parentmedia-video/ffdiaporama: EAPI-7 bump, drop gnome2-utils (diff)
downloadgentoo-fe5389275a22171e813d9549e678d57419372eca.tar.gz
gentoo-fe5389275a22171e813d9549e678d57419372eca.tar.bz2
gentoo-fe5389275a22171e813d9549e678d57419372eca.zip
net-im/ricochet: EAPI-7 bump, use xdg-utils.eclass
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ricochet/ricochet-1.1.4.ebuild15
-rw-r--r--net-im/ricochet/ricochet-9999.ebuild17
2 files changed, 17 insertions, 15 deletions
diff --git a/net-im/ricochet/ricochet-1.1.4.ebuild b/net-im/ricochet/ricochet-1.1.4.ebuild
index b26be1ac4f28..44bcd7daf218 100644
--- a/net-im/ricochet/ricochet-1.1.4.ebuild
+++ b/net-im/ricochet/ricochet-1.1.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit gnome2-utils qmake-utils
+inherit qmake-utils xdg-utils
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ricochet-im/ricochet"
else
@@ -31,7 +31,8 @@ RDEPEND="
dev-qt/qtquickcontrols:5
dev-qt/qtwidgets:5
net-vpn/tor"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-qt/linguist-tools:5
virtual/pkgconfig"
@@ -48,9 +49,9 @@ src_install() {
}
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
diff --git a/net-im/ricochet/ricochet-9999.ebuild b/net-im/ricochet/ricochet-9999.ebuild
index b770332effdf..2caa9d50609c 100644
--- a/net-im/ricochet/ricochet-9999.ebuild
+++ b/net-im/ricochet/ricochet-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit gnome2-utils qmake-utils
+inherit qmake-utils xdg-utils
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ricochet-im/ricochet"
else
@@ -31,12 +31,13 @@ RDEPEND="
dev-qt/qtquickcontrols:5
dev-qt/qtwidgets:5
net-vpn/tor"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-qt/linguist-tools:5
virtual/pkgconfig"
src_prepare() {
- eapply_user
+ default
# workaround bug https://github.com/ricochet-im/ricochet/issues/582
cp contrib/usr.bin.ricochet-apparmor contrib/usr.bin.ricochet
@@ -56,9 +57,9 @@ src_install() {
}
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}