summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/asuka
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/asuka')
-rw-r--r--net-irc/asuka/Manifest1
-rw-r--r--net-irc/asuka/asuka-1.2.1.ebuild56
-rw-r--r--net-irc/asuka/files/asuka.conf.d7
-rw-r--r--net-irc/asuka/files/asuka.init.d20
-rw-r--r--net-irc/asuka/metadata.xml5
5 files changed, 89 insertions, 0 deletions
diff --git a/net-irc/asuka/Manifest b/net-irc/asuka/Manifest
new file mode 100644
index 000000000000..678ff3d26c7f
--- /dev/null
+++ b/net-irc/asuka/Manifest
@@ -0,0 +1 @@
+DIST asuka-1.2.1.tar.bz2 705316 SHA256 4714f0786a39e7a4a39e795919dc3386797d27439d3bdbc61d7ae11d00543fb3 SHA512 6509be1356a7e7ad5105cade0284d0b2a4cecc9047cb39d350cdf8f6830bb279ad36cba949544444a5cb773570324e63a738ad7eea7ea645c877ca0ecfe14b49 WHIRLPOOL 4e46e7f2d02228bd4267bf2538ce92832ab82410218fa5b8f159887db82b8bdbdb7bb03d740edc932b07daef0b4442b9598b5e23f5171ce80d47c3cefa05cec5
diff --git a/net-irc/asuka/asuka-1.2.1.ebuild b/net-irc/asuka/asuka-1.2.1.ebuild
new file mode 100644
index 000000000000..4c9505dc2f95
--- /dev/null
+++ b/net-irc/asuka/asuka-1.2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic user
+
+DESCRIPTION="The QuakeNet IRC Server"
+HOMEPAGE="http://dev-com.quakenet.org/"
+SRC_URI="http://dev-com.quakenet.org/releases/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="x86 sparc"
+
+IUSE="debug"
+
+src_compile() {
+ # configure fails with this flag, bug 171780
+ filter-flags -ggdb
+
+ econf \
+ --with-symlink=asuka-ircd \
+ --with-dpath=/etc/asuka \
+ --with-cpath=/etc/asuka/ircd.conf \
+ --with-lpath=/var/log/asuka/asuka.log \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ newbin ircd/ircd asuka-ircd || die "newbin failed"
+ newman doc/ircd.8 asuka-ircd.8 || die "newman failed"
+
+ insinto /etc/asuka
+ doins doc/ircd.conf.sample || die "doins failed"
+
+ newinitd ${FILESDIR}/asuka.init.d asuka || die "newinitd failed"
+ newconfd ${FILESDIR}/asuka.conf.d asuka || die "newconfd failed"
+
+ keepdir /var/log/asuka
+
+ dodoc \
+ INSTALL* LICENSE README* RELEASE.NOTES TODO* \
+ doc/readme.* doc/p10.html doc/features.txt doc/Authors \
+ || die "dodoc failed"
+}
+
+pkg_postinst() {
+ enewuser asuka
+ chown asuka ${ROOT}/var/log/asuka
+
+ elog
+ elog "A sample config file can be found at /etc/asuka/ircd.conf.sample"
+ elog
+}
diff --git a/net-irc/asuka/files/asuka.conf.d b/net-irc/asuka/files/asuka.conf.d
new file mode 100644
index 000000000000..c68a8227318a
--- /dev/null
+++ b/net-irc/asuka/files/asuka.conf.d
@@ -0,0 +1,7 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Config file for /etc/init.d/asuka
+
+ASUKA_UID="asuka"
diff --git a/net-irc/asuka/files/asuka.init.d b/net-irc/asuka/files/asuka.init.d
new file mode 100644
index 000000000000..510b8e97a1ad
--- /dev/null
+++ b/net-irc/asuka/files/asuka.init.d
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting asuka-ircd"
+ start-stop-daemon --start --quiet --chuid ${ASUKA_UID} --exec /usr/bin/asuka-ircd
+ eend $? "Failed to start asuka-ircd"
+}
+
+stop() {
+ ebegin "Stopping asuka-ircd"
+ start-stop-daemon --stop --quiet --exec /usr/bin/asuka-ircd
+ eend $? "Failed to stop asuka-ircd"
+}
diff --git a/net-irc/asuka/metadata.xml b/net-irc/asuka/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/asuka/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>