summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild')
-rw-r--r--net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild108
1 files changed, 108 insertions, 0 deletions
diff --git a/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild b/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild
new file mode 100644
index 000000000000..8cd1f2702f94
--- /dev/null
+++ b/net-irc/eggdrop/eggdrop-1.6.21-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+MY_P="eggdrop${PV}"
+PATCHSET_V="1.0"
+
+DESCRIPTION="An IRC bot extensible with C or TCL"
+HOMEPAGE="http://www.eggheads.org/"
+SRC_URI="
+ ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~binki/distfiles/${CATEGORY}/${PN}/${P}-patches-${PATCHSET_V}.tar.bz2"
+
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug mysql postgres ssl static vanilla"
+
+REQUIRED_USE="vanilla? ( !mysql !postgres !ssl )"
+
+DEPEND="
+ dev-lang/tcl:0
+ sys-apps/gentoo-functions
+ !vanilla? (
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql[server] )
+ ssl? ( dev-libs/openssl )
+ )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if use vanilla; then
+ rm -f "${WORKDIR}"/patch/[1-6]*.patch || die
+ fi
+
+ EPATCH_SUFFIX="patch" epatch
+
+ # fix bug #335230
+ sed -i \
+ -e '/\$(LD)/s/-o/$(CFLAGS) $(LDFLAGS) &/' \
+ src/mod/*.mod/Makefile* src/Makefile.in || die
+}
+
+src_configure() {
+ use mysql || ( echo mysql ; echo mystats ) >>disabled_modules
+ use postgres || echo pgstats >>disabled_modules
+ use static && ( echo rijndael ; echo twofish ) >>disabled_modules
+
+ econf $(use_with ssl)
+
+ emake config
+}
+
+src_compile() {
+ local target=""
+
+ if use static && use debug; then
+ target="sdebug"
+ elif use static; then
+ target="static"
+ elif use debug; then
+ target="debug"
+ fi
+
+ emake ${target}
+}
+
+src_install() {
+ local a b
+ emake DEST="${D}"/opt/eggdrop install
+
+ for a in doc/*; do
+ [ -f ${a} ] && dodoc ${a}
+ done
+
+ for a in src/mod/*.mod; do
+ for b in README UPDATES INSTALL TODO CONTENTS; do
+ [[ -f ${a}/${b} ]] && newdoc ${a}/${b} ${b}.${a##*/}
+ done
+ done
+
+ dodoc text/motd.*
+
+ use vanilla || dodoc \
+ src/mod/botnetop.mod/botnetop.conf \
+ src/mod/gseen.mod/gseen.conf \
+ src/mod/mc_greet.mod/mc_greet.conf \
+ src/mod/stats.mod/stats.conf \
+ src/mod/away.mod/away.doc \
+ src/mod/rcon.mod/matchbot.tcl \
+ src/mod/mystats.mod/tools/mystats.{conf,sql} \
+ src/mod/pgstats.mod/tools/{pgstats.conf,setup.sql}
+
+ dohtml doc/html/*.html
+
+ dobin "${FILESDIR}"/eggdrop-installer
+ doman doc/man1/eggdrop.1
+}
+
+pkg_postinst() {
+ elog "Please run /usr/bin/eggdrop-installer to install your eggdrop bot."
+}