summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/epic4
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/epic4')
-rw-r--r--net-irc/epic4/Manifest3
-rw-r--r--net-irc/epic4/epic4-2.10.1.ebuild97
-rw-r--r--net-irc/epic4/files/epic-defaultserver.patch12
-rw-r--r--net-irc/epic4/files/epic4-2.10.1-make-recursion.patch10
-rw-r--r--net-irc/epic4/files/epic4-2.10.1-perl.patch54
-rw-r--r--net-irc/epic4/metadata.xml5
6 files changed, 181 insertions, 0 deletions
diff --git a/net-irc/epic4/Manifest b/net-irc/epic4/Manifest
new file mode 100644
index 000000000000..e7a5f6f51374
--- /dev/null
+++ b/net-irc/epic4/Manifest
@@ -0,0 +1,3 @@
+DIST epic4-2.10.1.tar.bz2 629722 SHA256 7eb6294c0a1a5aee8bc47f9c6904b2240bf7163e4e07d295296f6b2e214e9935 SHA512 382a0ad6d2778aba037ee1cf065ec7d2ea3827957010f9eea36072fbb8bf14cdba5baffa9a3ce7888305a2451ae61a4b5b5823336fc80b73997fe0d609918656 WHIRLPOOL 0d7ccf95886124ccc0cefe5674990fd778eaa84c836404ab1b74cde090e89e91b59950a3c7ce3eecd33e83a8abaa00bfbf7d192d16c69dd4bf94fcfca37c0c79
+DIST epic4-help-20050315.tar.gz 332502 SHA256 714afd07348731e6ac82e1f6548acc12e84539b3106ab27fa5d00ed5696256f7 SHA512 f59339d4f2c339cb4c3cbc0cce7db8fadbfe469884c16ab9add42e98eb318851e48ce8a04b4920d33c42afff8b39ec41186744eda0460af544c43fe14658e7e6 WHIRLPOOL c2d3783d99692c562490707f68e6b2f2c50c11ef3053e7574c8f049e01504f171f8d86e189e8849e30bb0f3097dc5c7ebb61db9f869b22345ebbfdcdb2daaf38
+DIST epic4-local.bz2 6530 SHA256 4509ac8e491ac0b75dc5ddcef845b02b3610804dd98de9b5b98d58630be322cd SHA512 2f4bb0aee284ddedd95dd97b17bd1756fcc700ec07b2814d84f3185e215134600fdd0fadf7ecb1d490ebb449f5e9530fcb207ebfaec27cfce1f9570e73103cc1 WHIRLPOOL 437ab54779f6579a77870b792bf1f763f94c2faf29ca3adfa0d465385dd67b8bf3fc315130761ba8a305c3c01f01e46fe3c1f708110b3ee5a79221a17fb32ab1
diff --git a/net-irc/epic4/epic4-2.10.1.ebuild b/net-irc/epic4/epic4-2.10.1.ebuild
new file mode 100644
index 000000000000..340e9acf7e48
--- /dev/null
+++ b/net-irc/epic4/epic4-2.10.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic toolchain-funcs
+
+HELP_V="20050315"
+
+DESCRIPTION="Epic4 IRC Client"
+HOMEPAGE="http://epicsol.org/"
+SRC_URI="
+ ftp://ftp.epicsol.org/pub/epic/EPIC4-PRODUCTION/${P}.tar.bz2
+ ftp://prbh.org/pub/epic/EPIC4-PRODUCTION/epic4-help-${HELP_V}.tar.gz
+ mirror://gentoo/epic4-local.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="ipv6 perl ssl"
+
+DEPEND="
+ >=sys-libs/ncurses-5.2
+ perl? ( dev-lang/perl )
+ ssl? ( >=dev-libs/openssl-0.9.5:0 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/epic-defaultserver.patch \
+ "${FILESDIR}"/${P}-make-recursion.patch \
+ "${FILESDIR}"/${P}-perl.patch
+
+ eautoconf
+
+ rm -f "${WORKDIR}"/help/Makefile || die
+ ecvs_clean
+}
+
+src_configure() {
+ replace-flags "-O?" "-O"
+
+ # copied from alt overlay
+ [[ ${CHOST} == *-interix* ]] && export ac_cv_func_getpgrp_void=yes
+
+ econf \
+ --libexecdir="${EPREFIX}"/usr/libexec/${PN} \
+ $(use_with ipv6) \
+ $(use_with perl) \
+ $(use_with ssl)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ einstall \
+ sharedir="${ED}"/usr/share \
+ libexecdir="${ED}"/usr/libexec/${PN}
+
+ dodoc BUG_FORM README KNOWNBUGS VOTES
+
+ cd "${S}"/doc || die
+ docinto doc
+ dodoc \
+ *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load \
+ nicknames outputhelp SILLINESS TS4
+
+ insinto /usr/share/epic
+ doins -r "${WORKDIR}"/help
+}
+
+pkg_postinst() {
+ if [ ! -f "${EROOT}"/usr/share/epic/script/local ]; then
+ elog "/usr/share/epic/script/local does not exist, I will now"
+ elog "create it. If you do not like the look/feel of this file, or"
+ elog "if you'd prefer to use your own script, simply remove this"
+ elog "file. If you want to prevent this file from being installed"
+ elog "in the future, simply create an empty file with this name."
+ cp "${WORKDIR}"/epic4-local "${EROOT}"/usr/share/epic/script/local
+ elog
+ elog "This provided local startup script adds a number of nifty"
+ elog "features to Epic including tab completion, a comprehensive set"
+ elog "of aliases, and channel-by-channel logging. To prevent"
+ elog "unintentional conflicts with your own scripting, if either the"
+ elog "~/.ircrc or ~/.epicrc script files exist, then the local script"
+ elog "is *not* run. If you like the script but want to make careful"
+ elog "additions (such as selecting your usual servers or setting your"
+ elog "nickname), simply copy /usr/share/epic/script/local to ~/.ircrc"
+ elog "and then add your additions to the copy."
+ fi
+
+ # Fix for bug 59075
+ chmod 755 "${EROOT}"/usr/share/epic/help
+}
diff --git a/net-irc/epic4/files/epic-defaultserver.patch b/net-irc/epic4/files/epic-defaultserver.patch
new file mode 100644
index 000000000000..1dbc2087cce9
--- /dev/null
+++ b/net-irc/epic4/files/epic-defaultserver.patch
@@ -0,0 +1,12 @@
+diff -Naur epic4-1.1.14.orig/include/config.h epic4-1.1.14/include/config.h
+--- epic4-1.1.14.orig/include/config.h 2003-10-28 05:53:57.000000000 +0000
++++ epic4-1.1.14/include/config.h 2004-01-03 13:49:53.083473288 +0000
+@@ -42,7 +42,7 @@
+ * the client will NOT compile and work properly! Use the default here if
+ * you dont have other servers to use.
+ */
+-#define DEFAULT_SERVER "localhost irc.efnet.net irc.undernet.org irc.dal.net"
++#define DEFAULT_SERVER "localhost irc.freenode.net irc.efnet.net irc.undernet.org irc.dal.net"
+
+ /*
+ * The left and right brace characters ('{', '}') are special characters in
diff --git a/net-irc/epic4/files/epic4-2.10.1-make-recursion.patch b/net-irc/epic4/files/epic4-2.10.1-make-recursion.patch
new file mode 100644
index 000000000000..68d7e4c460b6
--- /dev/null
+++ b/net-irc/epic4/files/epic4-2.10.1-make-recursion.patch
@@ -0,0 +1,10 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -210,6 +210,6 @@
+ $(RM) Makefile source/Makefile include/sig.inc config.status config.cache config.log include/defs.h source/info.c.sh
+
+ depend:
+- (cd source;make depend)
++ (cd source;$(MAKE) depend)
+
+ # This is the end of the file.
diff --git a/net-irc/epic4/files/epic4-2.10.1-perl.patch b/net-irc/epic4/files/epic4-2.10.1-perl.patch
new file mode 100644
index 000000000000..ce41d153abc6
--- /dev/null
+++ b/net-irc/epic4/files/epic4-2.10.1-perl.patch
@@ -0,0 +1,54 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Fix broken perl detection somewhat.
+
+--- a/configure.in
++++ b/configure.in
+@@ -636,25 +636,27 @@
+ dnl
+
+ AC_MSG_CHECKING(whether to support Perl)
+-AC_ARG_WITH(perl,
+-[ --with-perl[=PATH] Compile with perl support.],
+-[ test -z "$withval" && withval=yes ],
+-)
+-test "xno" != "x$withval" && for base in $withval /usr/local /usr /
+-do
+- FOUND=
+- for ext in so a dll ; do
+- test -r $base/lib/libperl.$ext && FOUND=1
+- test -r $base/libperl.$ext && FOUND=1
+- done
+- test -n "$FOUND" || continue
+- AC_MSG_RESULT(yes)
+- LIBS="$LIBS `perl -MExtUtils::Embed -e ldopts`"
+- PERLDOTOH="perl.o"
+- AC_DEFINE(PERL)
+- break
+-done
+-test -z "$PERLDOTOH" && AC_MSG_RESULT(no)
++AC_ARG_WITH([perl],
++ [AS_HELP_STRING([--with-perl[=PATH]], [Compile with perl support.])],
++ [],
++ [with_perl=maybe])
++AS_IF([test "xno" != "x$with_perl"],
++ [
++ PERL_LIBS="`perl -MExtUtils::Embed -e ldopts`"
++ AS_IF([test -n "$PERL_LIBS"],
++ [
++ AC_MSG_RESULT([yes])
++ LIBS="$LIBS $PERL_LIBS"
++ AC_DEFINE([PERL], [], [Define if perl support should be compiled])
++ PERLDOTOH="perl.o"
++ ],
++ [
++ AC_MSG_RESULT([no])
++ AS_IF([test "x$with_perl" != "xmaybe"],
++ [AC_MSG_ERROR([You specified --with-perl, but I was unable to find libperl])])
++ ])
++ ])
++
+ withval=''
+
+ dnl ----------------------------------------------------------
+
+Diff finished. Thu Jun 30 22:15:26 2011
diff --git a/net-irc/epic4/metadata.xml b/net-irc/epic4/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/epic4/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>