summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSpencer M.P <smp@nandre.com>2022-10-23 18:22:35 -0500
committerFlorian Schmaus <flow@gentoo.org>2022-10-28 15:35:30 +0200
commit1b5d7206638b90c111e84cdb21f93183389ca766 (patch)
tree090c0b2973f796734e2e0e40da8fc6f83f14f38f /net-irc/ii
parentdev-python/klein: enable py3.11 (diff)
downloadgentoo-1b5d7206638b90c111e84cdb21f93183389ca766.tar.gz
gentoo-1b5d7206638b90c111e84cdb21f93183389ca766.tar.bz2
gentoo-1b5d7206638b90c111e84cdb21f93183389ca766.zip
net-irc/ii: add 2.0
Signed-off-by: Spencer M.P <smp@nandre.com> Closes: https://github.com/gentoo/gentoo/pull/27923 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-irc/ii')
-rw-r--r--net-irc/ii/Manifest1
-rw-r--r--net-irc/ii/ii-2.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/net-irc/ii/Manifest b/net-irc/ii/Manifest
index 087a679b701a..4ddd4fef37d4 100644
--- a/net-irc/ii/Manifest
+++ b/net-irc/ii/Manifest
@@ -1,2 +1,3 @@
DIST ii-1.8.tar.gz 12326 BLAKE2B 7ae90d788aaec0a359ce46370f27c0ce62c6f77e8cda61d9d168d0ebd7de927a478b42a591631f2c193f3816b2a1b39cf79607326b073bcbeefe4291e0fb95f6 SHA512 2b41a0611ac76612c9333e8490709ee22d17506f0c5d7e680a0d8f3f8b511bd5b279555cf609c1543aba71948819369a3c306b1168086890aa49c145b7860e17
DIST ii-1.9.tar.gz 12672 BLAKE2B 95da596de00fb311a69b907ab25c0089aafa512085b25fe5753206cdeaa0fec3d9a16eb38d60c68542f7002efd1052e69e1f5542f535363d38760cab508b3d99 SHA512 a665a6d1e1ffe56e370da2d703e677436ef4e18e763bb3cadbbf55e01812454ce4b79e8a20eda23846fdbe5a441ec8c534c9394995b3441472ce8a74c9035279
+DIST ii-2.0.tar.gz 11129 BLAKE2B ee8b4e1169f1f59a9f09fa2a96fc898b0c48a337708a19a208fd344453f620bb3a832e25c26a20f7d14e2e5a7924d8a1d97efabdbb269125c2117f453d5f737f SHA512 ab8102b5669495b7bc6a3311245f3eb49d2add1e387290e41deb51e121f4c7c98a09d117052c345d8b896149276a83790c0b78efe3ed19fc52bc00575bf8e44a
diff --git a/net-irc/ii/ii-2.0.ebuild b/net-irc/ii/ii-2.0.ebuild
new file mode 100644
index 000000000000..e932246b3013
--- /dev/null
+++ b/net-irc/ii/ii-2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A minimalist FIFO and filesystem-based IRC client"
+HOMEPAGE="https://tools.suckless.org/ii/"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ DOCPREFIX="${EPREFIX}/usr/share/doc/${PF}" \
+ install
+}