summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-01-19 10:19:44 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-01-19 10:20:09 +0100
commita09071ee6ce901d6d4e39f3064bb5bec39abe2f4 (patch)
tree9ff2355c9869e4874c49204a9c25dfc04c4a062c /net-irc/irker/irker-2.15.ebuild
parentmail-mta/exim: add support for DANE by Michael Scholl, bug #572298 (diff)
downloadgentoo-a09071ee6ce901d6d4e39f3064bb5bec39abe2f4.tar.gz
gentoo-a09071ee6ce901d6d4e39f3064bb5bec39abe2f4.tar.bz2
gentoo-a09071ee6ce901d6d4e39f3064bb5bec39abe2f4.zip
net-irc/irker: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-irc/irker/irker-2.15.ebuild')
-rw-r--r--net-irc/irker/irker-2.15.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-irc/irker/irker-2.15.ebuild b/net-irc/irker/irker-2.15.ebuild
new file mode 100644
index 000000000000..6dd3a2b12f2f
--- /dev/null
+++ b/net-irc/irker/irker-2.15.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="ssl"
+
+inherit python-single-r1 eutils
+
+DESCRIPTION="Submission tools for IRC notifications"
+HOMEPAGE="http://www.catb.org/esr/irker/"
+SRC_URI="http://www.catb.org/esr/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto"
+
+src_prepare() {
+ # https://gitorious.org/irker/irker/merge_requests/25
+ epatch "${FILESDIR}/2.7-Register-author_name-as-author-instead-of-email-user.patch"
+
+ epatch "${FILESDIR}/2.7-irkerhook-Remove-file-listing.patch"
+
+ # Prefix support
+ sed -i -e "/^ExecStart=/ s:=/:=${EROOT}:" irkerd.service
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ python_doscript "${ED}/usr/bin/irkerd"
+ # Not installed with the default Makefile
+ python_doscript irk irkerhook.py
+
+ newinitd "${FILESDIR}/irkerd.initd" irkerd
+ newconfd "${FILESDIR}/irkerd.confd" irkerd
+
+ dodoc NEWS README hacking.txt security.txt
+ dohtml irkerd.html irkerhook.html
+
+ docinto examples
+ dodoc filter-example.py filter-test.py
+}