summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-10-22 17:56:31 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-10-22 17:56:31 +0300
commit8604a85880a0776792b947faaeca48a345274209 (patch)
tree17ffa8449006363876e1d26359ff06190d30db03 /net-irc/irssi
parentapp-emulation/qemu-9999: Drop sdl-1.2 support (diff)
downloadgentoo-8604a85880a0776792b947faaeca48a345274209.tar.gz
gentoo-8604a85880a0776792b947faaeca48a345274209.tar.bz2
gentoo-8604a85880a0776792b947faaeca48a345274209.zip
net-irc/irssi: revbump to fix libressl-2.7/2.8 bulding
Closes: https://bugs.gentoo.org/668748 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'net-irc/irssi')
-rw-r--r--net-irc/irssi/files/libressl.patch33
-rw-r--r--net-irc/irssi/irssi-1.1.1-r2.ebuild63
2 files changed, 96 insertions, 0 deletions
diff --git a/net-irc/irssi/files/libressl.patch b/net-irc/irssi/files/libressl.patch
new file mode 100644
index 000000000000..644c73be32ff
--- /dev/null
+++ b/net-irc/irssi/files/libressl.patch
@@ -0,0 +1,33 @@
+From 25a44dacf4114f33f3a887f358c02f4fd9938427 Mon Sep 17 00:00:00 2001
+From: Dorian Harmans <dorian@woohooyeah.nl>
+Date: Fri, 23 Mar 2018 21:35:35 +0100
+Subject: [PATCH] fix build with LibreSSL 2.7.0
+
+---
+ src/core/network-openssl.c | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/core/network-openssl.c b/src/core/network-openssl.c
+index 9fddf073e..692c7e716 100644
+--- a/src/core/network-openssl.c
++++ b/src/core/network-openssl.c
+@@ -35,7 +35,8 @@
+ #include <openssl/err.h>
+
+ /* OpenSSL 1.1.0 introduced some backward-incompatible changes to the api */
+-#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
++#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && \
++ (!defined(LIBRESSL_VERSION_NUMBER) || LIBRESSL_VERSION_NUMBER < 0x2070000fL)
+ /* The two functions below could be already defined if OPENSSL_API_COMPAT is
+ * below the 1.1.0 version so let's do a clean start */
+ #undef X509_get_notBefore
+@@ -47,7 +48,8 @@
+
+ /* OpenSSL 1.1.0 also introduced some useful additions to the api */
+ #if (OPENSSL_VERSION_NUMBER >= 0x10002000L)
+-#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined (LIBRESSL_VERSION_NUMBER)
++#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || \
++ (defined (LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL)
+ static int X509_STORE_up_ref(X509_STORE *vfy)
+ {
+ int n;
diff --git a/net-irc/irssi/irssi-1.1.1-r2.ebuild b/net-irc/irssi/irssi-1.1.1-r2.ebuild
new file mode 100644
index 000000000000..3c854ec36794
--- /dev/null
+++ b/net-irc/irssi/irssi-1.1.1-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GENTOO_DEPEND_ON_PERL="no"
+
+inherit ltprune perl-module
+
+# Keep for _rc compability
+MY_P="${P/_/-}"
+
+DESCRIPTION="A modular textUI IRC client with IPv6 support"
+HOMEPAGE="https://irssi.org/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV/_/-}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+perl selinux socks5 +proxy libressl"
+
+COMMON_DEPEND="
+ sys-libs/ncurses:0=
+ >=dev-libs/glib-2.6.0
+ !libressl? ( dev-libs/openssl:= )
+ libressl? ( dev-libs/libressl:= )
+ perl? ( dev-lang/perl:= )
+ socks5? ( >=net-proxy/dante-1.1.18 )"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-irc )
+ perl? ( !net-im/silc-client )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ if has_version '>=dev-libs/libressl-2.7.3'; then
+ eapply ${FILESDIR}/libressl.patch
+ fi
+}
+
+src_configure() {
+ econf \
+ --with-perl-lib=vendor \
+ --enable-true-color \
+ $(use_with proxy) \
+ $(use_with perl) \
+ $(use_with socks5 socks)
+}
+
+src_install() {
+ default
+ use perl && perl_delete_localpod
+ prune_libtool_files --modules
+}