summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2021-07-04 11:44:50 +1000
committerSam Jorna <wraeth@gentoo.org>2021-07-04 11:53:12 +1000
commit26b89523dc8f83866d3c04b4579ed3ec2ce8c044 (patch)
tree429cfba8e7b0ba2f969ba09e1a1b51caed04c05a /net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210703.ebuild
parentnet-irc/limnoria-plugins-chantracker: remove old (diff)
downloadgentoo-26b89523dc8f83866d3c04b4579ed3ec2ce8c044.tar.gz
gentoo-26b89523dc8f83866d3c04b4579ed3ec2ce8c044.tar.bz2
gentoo-26b89523dc8f83866d3c04b4579ed3ec2ce8c044.zip
net-irc/limnoria-plugins-jlu5: bump to 20200105_p20210703
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam Jorna <wraeth@gentoo.org>
Diffstat (limited to 'net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210703.ebuild')
-rw-r--r--net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210703.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210703.ebuild b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210703.ebuild
new file mode 100644
index 000000000000..7130f90270df
--- /dev/null
+++ b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20200105_p20210703.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+COMMIT="7e959b9f24632d0fa9f587da6e1cde951397ae97"
+
+DESCRIPTION="A collection of plugins for the Limnoria IRC bot."
+HOMEPAGE="https://github.com/jlu5/SupyPlugins"
+SRC_URI="https://github.com/jlu5/SupyPlugins/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+
+RDEPEND="
+ net-irc/limnoria
+ dev-python/beautifulsoup
+"
+
+DOCS=(
+ "README.md"
+ "requirements.txt"
+)
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/jlu5
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before these plugins can be used, your bot will need to be told where to"
+ elog "load them from. To do this, add /usr/share/limnoria-extra-plugins/jlu5 when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/jlu5"
+}