summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2022-02-11 18:33:11 +1100
committerSam Jorna <wraeth@gentoo.org>2022-02-11 18:33:11 +1100
commit7dc50f1f4f63eb92d5318494ce6d7f3606c0a3a9 (patch)
treecf794c710b5685779453513e94747079c39fcb32 /net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20220201.ebuild
parentnet-irc/limnoria: remove old (diff)
downloadgentoo-7dc50f1f4f63eb92d5318494ce6d7f3606c0a3a9.tar.gz
gentoo-7dc50f1f4f63eb92d5318494ce6d7f3606c0a3a9.tar.bz2
gentoo-7dc50f1f4f63eb92d5318494ce6d7f3606c0a3a9.zip
net-irc/limnoria-plugins-jlu5: bump to 2022-02-01
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Sam Jorna <wraeth@gentoo.org>
Diffstat (limited to 'net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20220201.ebuild')
-rw-r--r--net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20220201.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20220201.ebuild b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20220201.ebuild
new file mode 100644
index 000000000000..b5f393a796e5
--- /dev/null
+++ b/net-irc/limnoria-plugins-jlu5/limnoria-plugins-jlu5-20220201.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+MY_PV="${PV:0:4}.${PV:4:2}.${PV:6:2}"
+
+DESCRIPTION="A collection of plugins for the Limnoria IRC bot"
+HOMEPAGE="https://github.com/jlu5/SupyPlugins"
+SRC_URI="https://github.com/jlu5/SupyPlugins/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+KEYWORDS="~amd64 ~riscv ~x86"
+SLOT=0
+
+RDEPEND="
+ net-irc/limnoria
+ dev-python/beautifulsoup4
+"
+
+DOCS=(
+ "README.md"
+ "requirements.txt"
+)
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/jlu5
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before these plugins can be used, your bot will need to be told where to"
+ elog "load them from. To do this, add /usr/share/limnoria-extra-plugins/jlu5 when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/jlu5"
+}