summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/ptlink-ircd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/ptlink-ircd')
-rw-r--r--net-irc/ptlink-ircd/Manifest1
-rw-r--r--net-irc/ptlink-ircd/files/ptlink-ircd.confd6
-rw-r--r--net-irc/ptlink-ircd/files/ptlink-ircd.initd24
-rw-r--r--net-irc/ptlink-ircd/metadata.xml5
-rw-r--r--net-irc/ptlink-ircd/ptlink-ircd-6.19.6-r2.ebuild93
5 files changed, 129 insertions, 0 deletions
diff --git a/net-irc/ptlink-ircd/Manifest b/net-irc/ptlink-ircd/Manifest
new file mode 100644
index 000000000000..6133f2dc0934
--- /dev/null
+++ b/net-irc/ptlink-ircd/Manifest
@@ -0,0 +1 @@
+DIST PTlink6.19.6.tar.gz 799388 SHA256 80a9100b0f0c41c914dda6c576207721fa05bb4a0ccf77c6337d6740d1ce0131 SHA512 5036efc429d8c5dbb5076cc690221b9409990bfe71a710bf6f8ce60e8779ff8f55e695c1fc1ca56435928d416bc1907c91105cf533538dafeea4344cd038d4d5 WHIRLPOOL 7328e2c550592422beb29ae0895a80b98541ae91932963df9338983bf86053886ba309f7a775d2cfb0dce12ff91ee08d1148dec32f0788304150ec90d556d4f9
diff --git a/net-irc/ptlink-ircd/files/ptlink-ircd.confd b/net-irc/ptlink-ircd/files/ptlink-ircd.confd
new file mode 100644
index 000000000000..29e2300f5ebe
--- /dev/null
+++ b/net-irc/ptlink-ircd/files/ptlink-ircd.confd
@@ -0,0 +1,6 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# User to run ptlink-ircd as
+PTLINKIRCD_USER="ptlink-ircd"
diff --git a/net-irc/ptlink-ircd/files/ptlink-ircd.initd b/net-irc/ptlink-ircd/files/ptlink-ircd.initd
new file mode 100644
index 000000000000..6822cd69eee7
--- /dev/null
+++ b/net-irc/ptlink-ircd/files/ptlink-ircd.initd
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+ use dns
+ provide ircd
+}
+
+start() {
+ ebegin "Starting ptlink-ircd"
+ start-stop-daemon --start --quiet --exec /usr/bin/ptlink-ircd \
+ --chuid ${PTLINKIRCD_USER} -- -l /var/lib/ptlink-ircd \
+ -e /etc/ptlink-ircd >/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Shutting down ptlink-ircd"
+ start-stop-daemon --stop --pidfile /var/lib/ptlink-ircd/ircd.pid
+ eend $?
+}
diff --git a/net-irc/ptlink-ircd/metadata.xml b/net-irc/ptlink-ircd/metadata.xml
new file mode 100644
index 000000000000..c519652bdf0d
--- /dev/null
+++ b/net-irc/ptlink-ircd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+</pkgmetadata>
diff --git a/net-irc/ptlink-ircd/ptlink-ircd-6.19.6-r2.ebuild b/net-irc/ptlink-ircd/ptlink-ircd-6.19.6-r2.ebuild
new file mode 100644
index 000000000000..f21eeabfe512
--- /dev/null
+++ b/net-irc/ptlink-ircd/ptlink-ircd-6.19.6-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils ssl-cert user
+
+MY_P="PTlink${PV}"
+
+DESCRIPTION="Secure IRC daemon with many advanced features"
+HOMEPAGE="http://www.ptlink.net/"
+SRC_URI="ftp://ftp.sunsite.dk/projects/ptlink/ircd/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE="ssl"
+
+DEPEND="
+ sys-libs/zlib
+ ssl? ( dev-libs/openssl:0= )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ ecvs_clean
+}
+
+src_configure() {
+ econf \
+ --disable-ipv6 \
+ $(use_with ssl ssl openssl)
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ newbin src/ircd ptlink-ircd
+ newbin tools/fixklines ptlink-ircd-fixklines
+ newbin tools/mkpasswd ptlink-ircd-mkpasswd
+
+ insinto /etc/ptlink-ircd
+ fperms 700 /etc/ptlink-ircd
+ doins samples/{kline.conf,{opers,ptlink}.motd,help.{admin,oper,user}}
+ newins samples/example.conf.short ircd.conf
+ newins samples/example.conf.trillian ircd.conf.trillian
+ newins samples/main.dconf.sample main.dconf
+ newins samples/network.dconf.sample network.dconf
+
+ insinto /usr/share/ptlink-ircd/codepage
+ doins src/codepage/*.enc
+ dosym /usr/share/ptlink-ircd/codepage /etc/ptlink-ircd/codepage
+
+ rm -rf doc/old
+ dodoc doc/* doc_hybrid6/* ircdcron/* CHANGES README
+
+ keepdir /var/log/ptlink-ircd /var/lib/ptlink-ircd
+ dosym /var/log/ptlink-ircd /var/lib/ptlink-ircd/log
+
+ newinitd "${FILESDIR}/ptlink-ircd.initd" ptlink-ircd
+ newconfd "${FILESDIR}/ptlink-ircd.confd" ptlink-ircd
+}
+
+pkg_postinst() {
+ # Move docert from src_install() to install_cert for bug #201678
+ use ssl && (
+ if [[ ! -f "${ROOT}"/etc/ptlink-ircd/server.key.pem ]]; then
+ install_cert /etc/ptlink-ircd/server || die "install_cert failed"
+ mv "${ROOT}"/etc/ptlink-ircd/server.{crt,cert.pem}
+ mv "${ROOT}"/etc/ptlink-ircd/server.{csr,req.pem}
+ mv "${ROOT}"/etc/ptlink-ircd/server.key{,.pem}
+ fi
+ )
+
+ enewuser ptlink-ircd
+
+ chown ptlink-ircd \
+ "${ROOT}"/{etc,var/{log,lib}}/ptlink-ircd \
+ "${ROOT}"/etc/ptlink-ircd/server.key.pem
+
+ echo
+ elog "PTlink IRCd will run without configuration, although this is strongly"
+ elog "advised against."
+ echo
+ elog "You can find example cron script ircd.cron here:"
+ elog " /usr/share/doc/${PF}"
+ echo
+ elog "You can also use /etc/init.d/ptlink-ircd to start at boot"
+ echo
+}