summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-07 12:20:11 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-07 12:20:40 +0100
commit77d6212dcb6dc56546ebd37944bff21bbfc56420 (patch)
treee97ad8699e7d0d16a69035a2a19a812851fbec00 /net-irc/rbot
parentapp-misc/emelfm2: Test LINGUAS rather than linguas_* USE flags. (diff)
downloadgentoo-77d6212dcb6dc56546ebd37944bff21bbfc56420.tar.gz
gentoo-77d6212dcb6dc56546ebd37944bff21bbfc56420.tar.bz2
gentoo-77d6212dcb6dc56546ebd37944bff21bbfc56420.zip
net-irc/rbot: Test LINGUAS rather than linguas_* USE flags.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-irc/rbot')
-rw-r--r--net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild10
-rw-r--r--net-irc/rbot/rbot-0.9.15_p20160325.ebuild10
2 files changed, 6 insertions, 14 deletions
diff --git a/net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild b/net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild
index 9d5251d93d3f..c176e4cd985f 100644
--- a/net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild
+++ b/net-irc/rbot/rbot-0.9.15_p20160325-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,10 +19,6 @@ IUSE="spell aspell timezone translator shorturl nls figlet
ILINGUAS="zh_CN zh_TW ru nl de fi fr it ja"
RUBY_S="${PN}-${GITHUB_COMMIT}"
-for lang in $ILINGUAS; do
- IUSE="${IUSE} linguas_${lang}"
-done
-
RUBY_PATCHES=( rbot-rakefile-gettext.patch )
RDEPEND+="
@@ -128,7 +124,7 @@ all_ruby_compile() {
# need to add them later.
if use nls; then
strip-linguas ${ILINGUAS}
- if [[ -n ${LINGUAS} ]]; then
+ if [[ -n ${LINGUAS+set} ]]; then
# As the the language name used by the rbot data files does
# not correspond to the ISO codes we usually use for LINGUAS,
# the following list of local varables will work as a
@@ -143,7 +139,7 @@ all_ruby_compile() {
local lang_rbot_ja="japanese"
for lang in ${ILINGUAS}; do
- use linguas_${lang} && continue
+ has ${lang} ${LINGUAS} && continue
lang_varname="lang_rbot_${lang}"
lang_rbot=${!lang_varname}
diff --git a/net-irc/rbot/rbot-0.9.15_p20160325.ebuild b/net-irc/rbot/rbot-0.9.15_p20160325.ebuild
index 48af140afb3e..ee7d5458ae7e 100644
--- a/net-irc/rbot/rbot-0.9.15_p20160325.ebuild
+++ b/net-irc/rbot/rbot-0.9.15_p20160325.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,10 +19,6 @@ IUSE="spell aspell timezone translator shorturl nls figlet
ILINGUAS="zh_CN zh_TW ru nl de fi fr it ja"
RUBY_S="${PN}-${GITHUB_COMMIT}"
-for lang in $ILINGUAS; do
- IUSE="${IUSE} linguas_${lang}"
-done
-
RUBY_PATCHES=( rbot-rakefile-gettext.patch )
RDEPEND+="
@@ -118,7 +114,7 @@ all_ruby_compile() {
# need to add them later.
if use nls; then
strip-linguas ${ILINGUAS}
- if [[ -n ${LINGUAS} ]]; then
+ if [[ -n ${LINGUAS+set} ]]; then
# As the the language name used by the rbot data files does
# not correspond to the ISO codes we usually use for LINGUAS,
# the following list of local varables will work as a
@@ -133,7 +129,7 @@ all_ruby_compile() {
local lang_rbot_ja="japanese"
for lang in ${ILINGUAS}; do
- use linguas_${lang} && continue
+ has ${lang} ${LINGUAS} && continue
lang_varname="lang_rbot_${lang}"
lang_rbot=${!lang_varname}