summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Persson Forsberg <cat@catcream.org>2023-06-07 04:16:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-06-11 11:44:29 +0300
commit22d04d652dc28427a492a108a6a849e2d060ea1f (patch)
treead7b3d6125abd65b4985a2cee1c85517b3fdf5eb /net-irc/soju/soju-0.6.0.ebuild
parentnet-irc/soju: add 0.6.2 (diff)
downloadgentoo-22d04d652dc28427a492a108a6a849e2d060ea1f.tar.gz
gentoo-22d04d652dc28427a492a108a6a849e2d060ea1f.tar.bz2
gentoo-22d04d652dc28427a492a108a6a849e2d060ea1f.zip
net-irc/soju: drop 0.6.0, 0.6.0-r1
Signed-off-by: Alfred Persson Forsberg <cat@catcream.org> Closes: https://github.com/gentoo/gentoo/pull/31336 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-irc/soju/soju-0.6.0.ebuild')
-rw-r--r--net-irc/soju/soju-0.6.0.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/net-irc/soju/soju-0.6.0.ebuild b/net-irc/soju/soju-0.6.0.ebuild
deleted file mode 100644
index a233f27ef458..000000000000
--- a/net-irc/soju/soju-0.6.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module systemd
-
-DESCRIPTION="soju is a user-friendly IRC bouncer"
-HOMEPAGE="https://soju.im/"
-SRC_URI="https://git.sr.ht/~emersion/${PN}/refs/download/v${PV}/${P}.tar.gz"
-SRC_URI+=" https://github.com/alfredfo/${PN}-deps/raw/master/${P}-deps.tar.xz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv"
-IUSE="pam"
-
-BDEPEND="
- app-text/scdoc
-"
-RDEPEND="
- acct-user/soju
- acct-group/soju
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.6.0-fix-dup-upstream-connections.patch
-)
-
-src_compile() {
- GOFLAGS+=" -tags=moderncsqlite"
- use pam && GOFLAGS+=" -tags=pam"
-
- ego build ${GOFLAGS} ./cmd/soju
- ego build ${GOFLAGS} ./cmd/sojudb
- ego build ${GOFLAGS} ./cmd/sojuctl
-
- scdoc <doc/soju.1.scd >doc/soju.1 || die
-}
-
-src_install() {
- dobin soju
- dobin sojudb
- dobin sojuctl
-
- doman doc/soju.1
- systemd_dounit contrib/soju.service
- keepdir /etc/soju
- insinto /etc/soju
- newins config.in config
- newinitd "${FILESDIR}"/soju.initd soju
- einstalldocs
-}
-
-pkg_postinst() {
- elog "${PN} requires a user database for authenticating clients."
- elog "As the soju user, create a database using:"
- elog "$ sojudb -config ${EROOT}/etc/soju/config create-user <username> [-admin]"
-}