summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-13 12:13:45 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-13 13:08:11 -0500
commit3dc3de295219f98d357993b35c85d39bfad47e7e (patch)
treee017a9fc7f7dc215adb88c006ea7f9fbfb1df4a6 /net-irc/telepathy-idle/telepathy-idle-0.2.2.ebuild
parentnet-im/telepathy-mission-control: Version bump to 5.16.6 (diff)
downloadgentoo-3dc3de295219f98d357993b35c85d39bfad47e7e.tar.gz
gentoo-3dc3de295219f98d357993b35c85d39bfad47e7e.tar.bz2
gentoo-3dc3de295219f98d357993b35c85d39bfad47e7e.zip
net-irc/telepathy-idle: Version bump to 0.2.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-irc/telepathy-idle/telepathy-idle-0.2.2.ebuild')
-rw-r--r--net-irc/telepathy-idle/telepathy-idle-0.2.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-irc/telepathy-idle/telepathy-idle-0.2.2.ebuild b/net-irc/telepathy-idle/telepathy-idle-0.2.2.ebuild
new file mode 100644
index 000000000000..93299731defc
--- /dev/null
+++ b/net-irc/telepathy-idle/telepathy-idle-0.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit python-single-r1
+
+DESCRIPTION="Full-featured IRC connection manager for Telepathy"
+HOMEPAGE="https://gitlab.freedesktop.org/telepathy/telepathy-idle"
+SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=dev-libs/dbus-glib-0.51
+ >=dev-libs/glib-2.32:2
+ >=net-libs/telepathy-glib-0.21
+ sys-apps/dbus
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"