summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-11 12:09:27 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-11-11 12:15:52 -0800
commitb968feb25a21c74f3136ba6df3b1f7ab47bd56ac (patch)
tree479ddc12bfac457bd73a51e8a522d95c27405d72 /net-irc/weechat
parentnet-irc/weechat: add py3.9, make tests verbose, unrestrict tests (diff)
downloadgentoo-b968feb25a21c74f3136ba6df3b1f7ab47bd56ac.tar.gz
gentoo-b968feb25a21c74f3136ba6df3b1f7ab47bd56ac.tar.bz2
gentoo-b968feb25a21c74f3136ba6df3b1f7ab47bd56ac.zip
net-irc/weechat: sync live ebuild
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-irc/weechat')
-rw-r--r--net-irc/weechat/weechat-9999.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index de9e048a74ce..e1f5520395b0 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit cmake python-single-r1 xdg-utils
@@ -12,7 +12,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/weechat/weechat.git"
else
SRC_URI="https://weechat.org/files/src/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x64-macos"
fi
DESCRIPTION="Portable and multi-interface IRC client"
@@ -27,7 +27,11 @@ PLUGINS="+alias +buflist +charset +exec +fifo +fset +logger +relay +scripts +spe
SCRIPT_LANGS="guile lua +perl php +python ruby tcl"
LANGS=" cs de es fr it ja pl ru"
IUSE="doc man nls test ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( nls )
+"
RDEPEND="
dev-libs/libgcrypt:0=
@@ -46,6 +50,7 @@ RDEPEND="
spell? ( app-text/aspell )
tcl? ( >=dev-lang/tcl-8.4.15:0= )
"
+
DEPEND="${RDEPEND}
test? ( dev-util/cpputest )
"
@@ -59,8 +64,7 @@ BDEPEND="
DOCS="AUTHORS.adoc ChangeLog.adoc Contributing.adoc ReleaseNotes.adoc README.adoc"
-# tests need to be fixed to not use system plugins if weechat is already installed
-RESTRICT="test"
+RESTRICT="!test? ( test )"
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -137,6 +141,10 @@ src_configure() {
cmake_src_configure
}
+src_test() {
+ cmake_src_test -V
+}
+
pkg_postinst() {
xdg_desktop_database_update
xdg_icon_cache_update