summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-30 18:59:20 -0400
committerMatt Turner <mattst88@gentoo.org>2022-05-30 19:33:21 -0400
commit16c5fb043587a1c046c44554a125de07ad74eec3 (patch)
tree2a8851a84cc8024adb247c1a208fbb981d2659ae /net-irc
parentsys-boot/systemd-boot: drop 249.6 (diff)
downloadgentoo-16c5fb043587a1c046c44554a125de07ad74eec3.tar.gz
gentoo-16c5fb043587a1c046c44554a125de07ad74eec3.tar.bz2
gentoo-16c5fb043587a1c046c44554a125de07ad74eec3.zip
net-irc/polari: Version bump to 42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/polari/Manifest1
-rw-r--r--net-irc/polari/polari-42.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-irc/polari/Manifest b/net-irc/polari/Manifest
index 210d0728c1bb..7eb1fcdab30e 100644
--- a/net-irc/polari/Manifest
+++ b/net-irc/polari/Manifest
@@ -1 +1,2 @@
DIST polari-40.0.tar.xz 1051416 BLAKE2B ea6aea087ff3ba74e2cf16e848c228c0984eb7e5b7cc16579bbe8ceeb3655babb5dfbf3adbe245b66b590999c5b7e0077630b659d0db00e2da6ce0ac8b0281da SHA512 267eb904286f33e6ac510357de072285889d1c72ca832eb6a8520a20b1c2487708eaa0187d4c91b46b3b8019866f37a9ac036a71dee9cd9c9ad83443df0f146c
+DIST polari-42.0.tar.xz 1125160 BLAKE2B e4edeb2023c2df2e1ad855ceea4dc9e646eca18da61643698410724d1fbe031ee609a30e139b2ab2ad6ddf22d1a4ea0b408b4b93d7ac8874c35c9d49f96f16bd SHA512 a64e1841d91809389af4b1f7eebd1b1e187f9e5f7058a84ab3b50bbbdc3786a7ec89bd4ccc4935473d1de1c40f6dbd6daf30b6bff48dd132e28a4be3e8bfb114
diff --git a/net-irc/polari/polari-42.0.ebuild b/net-irc/polari/polari-42.0.ebuild
new file mode 100644
index 000000000000..2661d7d6748c
--- /dev/null
+++ b/net-irc/polari/polari-42.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="An IRC client for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Polari https://gitlab.gnome.org/GNOME/polari"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.43.4:2
+ net-libs/telepathy-glib[introspection]
+ >=dev-libs/gobject-introspection-1.50:=
+ >=dev-libs/gjs-1.69.2
+
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=app-text/gspell-1.4.0[introspection]
+ x11-libs/pango[introspection]
+ app-crypt/libsecret[introspection]
+ net-libs/libsoup:2.4[introspection]
+ net-im/telepathy-logger[introspection]
+"
+RDEPEND="${DEPEND}
+ >=net-irc/telepathy-idle-0.2
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ dev-libs/json-glib
+ )
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}