summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2021-05-30 15:51:29 +1000
committerSam Jorna <wraeth@gentoo.org>2021-05-30 15:51:44 +1000
commit2c09bd72e05b61c94cbaa31dc2586433c9ed8ec1 (patch)
tree4ea7d8b3d717c90a99d6b043e9911ace884245c4 /net-irc
parentgames-board/scid: add Python 3.9 (diff)
downloadgentoo-2c09bd72e05b61c94cbaa31dc2586433c9ed8ec1.tar.gz
gentoo-2c09bd72e05b61c94cbaa31dc2586433c9ed8ec1.tar.bz2
gentoo-2c09bd72e05b61c94cbaa31dc2586433c9ed8ec1.zip
net-irc/limnoria-plugins-chantracker: bump to p20210530
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Sam Jorna <wraeth@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/limnoria-plugins-chantracker/Manifest1
-rw-r--r--net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.5_p20210530.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-chantracker/Manifest b/net-irc/limnoria-plugins-chantracker/Manifest
index c421b12e8482..f1afaabf8c3f 100644
--- a/net-irc/limnoria-plugins-chantracker/Manifest
+++ b/net-irc/limnoria-plugins-chantracker/Manifest
@@ -1 +1,2 @@
DIST limnoria-plugins-chantracker-1.5_p20210210.tar.gz 46836 BLAKE2B f97418160f6261a87ef6239def036b629ffe88d06e5f4980722ca1b6d05c1cd0c12d8c6d425150c8aa2a43a1b21e3f0070dfe55fc71a8aa0cf5bed20d57adcaa SHA512 c6d25d2d84cda24a5e589952e75dd79569296d23e24f3872c553d1b78ebb782c2f6257248238a4bdd9d6a1efdad2836e4fad1546adb81581d7daedcc153a90b5
+DIST limnoria-plugins-chantracker-1.5_p20210530.tar.gz 47071 BLAKE2B b38cbe399d6cda9ee9d5e873a50d2f529d91b697c32ed4d74fb8812b8090a42103283878f8874f0a974cfdf1d117e2401935edef678d1d71af338760555a7a92 SHA512 7b5e459d17b28fd00b9306a7acd8c2a36eb668031c24eb05b9c51354e5cf270fb1b388949047c0531d9e8cd62291d8f7ec9bd339d3b3b6c1680dc184c44d3b21
diff --git a/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.5_p20210530.ebuild b/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.5_p20210530.ebuild
new file mode 100644
index 000000000000..03beadaac2ce
--- /dev/null
+++ b/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.5_p20210530.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+COMMIT="7a60d9912171b3f6fb927b03c18710773d7f4227"
+
+DESCRIPTION="supybot ban management and channel flood/spam/repeat protections plugin"
+HOMEPAGE="https://github.com/ncoevoet/ChanTracker"
+SRC_URI="https://github.com/ncoevoet/ChanTracker/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+
+RDEPEND="net-irc/limnoria"
+
+DOCS="README.md"
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/ncoevoet/ChanTracker
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before this plugin can be used, your bot will need to be told where to"
+ elog "load it from. To do this, add /usr/share/limnoria-extra-plugins/ncoevoet when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/ncoevoet"
+}