summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2021-04-17 12:01:03 +1000
committerSam Jorna <wraeth@gentoo.org>2021-04-17 12:01:03 +1000
commit2f4acd62e9001a26412bd228cf51d8a036cd5ebf (patch)
tree05a86232985d737859be777da0f5d82bbeb36835 /net-irc
parentsci-geosciences/gnome-maps: Track subslot of dev-libs/folks (diff)
downloadgentoo-2f4acd62e9001a26412bd228cf51d8a036cd5ebf.tar.gz
gentoo-2f4acd62e9001a26412bd228cf51d8a036cd5ebf.tar.bz2
gentoo-2f4acd62e9001a26412bd228cf51d8a036cd5ebf.zip
net-irc/limnoria: bump to 2021-04-11
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sam Jorna <wraeth@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/limnoria/Manifest1
-rw-r--r--net-irc/limnoria/limnoria-20210411.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-irc/limnoria/Manifest b/net-irc/limnoria/Manifest
index 1c3927732131..d333682b929c 100644
--- a/net-irc/limnoria/Manifest
+++ b/net-irc/limnoria/Manifest
@@ -1,2 +1,3 @@
DIST limnoria-20200124.tar.gz 1034653 BLAKE2B 895a0820efcd58429e457e0cb8dbcb864e56a3bce9fab9546cf622aabc7711a015432812c4193d2dabe7a85043c623ce427504c1c8e78530499c8db2c589bd8e SHA512 828c4927e2ce00c012d17f8a2b2d629370c34915e7e4f71de6df67259e643448c33a60d9cf742b2d827e21e17326a8fc20be875eac826edf64406eda906567a4
DIST limnoria-20210326.tar.gz 1046488 BLAKE2B fcbaab1ecebcd74438be4c2fce96c7e289aa01dcb67c324130d5c768727e159c87b5d96cc4ffefdf629287d59f02cc72ea17ba4a61e9157d7626ebceb9e072e8 SHA512 1d612a2ce42edec909255474f99b4785ff7eb7a7554ee5090e05db92cadb071821f6962659d8f1846f238a257d6b8d513881f27be44a7582d154bd0cf398f7db
+DIST limnoria-20210411.tar.gz 1084991 BLAKE2B 6bca9a2583748ae2b1c26670a762d0ee1307478b6d587e32c816c880d4d1ac6495f79d07bd8d7068867b1a9dd1bff51233e5636c0d0371e2ee1c19617a9a7872 SHA512 2c53d6ecd2457fae77076ad5ee0c4fa61c42970f8d43891b6d9adbabae80176ccab2789fc6a7129db3545a76f1850cf86de50aa3814b335d42f1220a2818c36c
diff --git a/net-irc/limnoria/limnoria-20210411.ebuild b/net-irc/limnoria/limnoria-20210411.ebuild
new file mode 100644
index 000000000000..03b9171f694b
--- /dev/null
+++ b/net-irc/limnoria/limnoria-20210411.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PN="Limnoria"
+MY_P="${MY_PN}-${MY_PV}"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/ProgVal/${MY_PN}.git"
+ EGIT_BRANCH="testing"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ProgVal/${MY_PN}/archive/master-${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-master-${MY_PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Python based extensible IRC infobot and channel bot"
+HOMEPAGE="https://docs.limnoria.net"
+LICENSE="BSD GPL-2 GPL-2+"
+SLOT="0"
+IUSE="crypt ssl test"
+RESTRICT=" !test? ( test )"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ crypt? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+ !net-irc/supybot
+ !net-irc/supybot-plugins"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_prepare() {
+ einfo "Removing the RSS plugin because of clashes between libxml2's Python3"
+ einfo "bindings and feedparser."
+ rm -r "plugins/RSS" || die
+}
+
+python_test() {
+ pushd "${T}" > /dev/null || die
+ PLUGINS_DIR="${BUILD_DIR}"/lib/supybot/plugins
+ EXCLUDE_PLUGINS=()
+ # intermittent failure due to issues loading libsandbox.so from LD_PRELOAD
+ # runs successfully when running the tests on the installed system
+ EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Unix" )
+ # Runs despite --no-network (GH #1392)
+ EXCLUDE_PLUGINS+=( --exclude="${PLUGINS_DIR}/Aka" )
+ "${EPYTHON}" "${BUILD_DIR}"/scripts/supybot-test "${BUILD_DIR}/../test" \
+ --plugins-dir="${PLUGINS_DIR}" --no-network \
+ --disable-multiprocessing "${EXCLUDE_PLUGINS[@]}" \
+ || die "Tests failed under ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/*
+}
+
+pkg_postinst() {
+ elog "Complete user documentation is available at https://limnoria-doc.readthedocs.org/"
+ elog ""
+ elog "Use supybot-wizard to create a configuration file."
+ elog "Run supybot </path/to/config> to use the bot."
+}