summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-20 06:26:28 +0000
committerSam James <sam@gentoo.org>2020-12-20 06:26:28 +0000
commit413caca27b689fd28ae964cd4802802b1ee5d32d (patch)
tree308af4582d781bf56918a60ffc7e5ea58966ae45 /net-irc
parentnet-analyzer/scapy: cleanup old (diff)
downloadgentoo-413caca27b689fd28ae964cd4802802b1ee5d32d.tar.gz
gentoo-413caca27b689fd28ae964cd4802802b1ee5d32d.tar.bz2
gentoo-413caca27b689fd28ae964cd4802802b1ee5d32d.zip
net-irc/anope: cleanup old
Package-Manager: Portage-3.0.12-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/anope/Manifest1
-rw-r--r--net-irc/anope/anope-2.0.7.ebuild154
2 files changed, 0 insertions, 155 deletions
diff --git a/net-irc/anope/Manifest b/net-irc/anope/Manifest
index 1e406ccf6b6b..db202f75903b 100644
--- a/net-irc/anope/Manifest
+++ b/net-irc/anope/Manifest
@@ -1,2 +1 @@
-DIST anope-2.0.7-source.tar.gz 1817484 BLAKE2B 13a4628db8cb885d4636ab1897aab322f7846740e4a3fccd02a417d84a8eb3c942aebf5e0a51f8ca1108f455b44b4e280e7386b42e03f640c9b0e68943252814 SHA512 22a9f3e0d9fe7f68304062829a19b693a3414f94c90f8da601ab98995cbff7310dc22ca40749d50d6722dfb4649817d2f4b1dbe4afa3254b28980f03a491de65
DIST anope-2.0.9.tar.gz 1808866 BLAKE2B db5755dbb88edb9fcc2f00c1dc324894f22b9e6bc97c9cf57b40d2296014341fe3ade8a8e1b64879b852aef6637e1bb89947deb7a41e009e25101a0a992515e7 SHA512 0ce2caa5ede2831215781a333d896f1169f90bbb515078912f32beaff1699b7957384974cca7c86f1d584d624cb43c76769299ce245ee1fb6836ce7f14ada3e0
diff --git a/net-irc/anope/anope-2.0.7.ebuild b/net-irc/anope/anope-2.0.7.ebuild
deleted file mode 100644
index f00b232f80bd..000000000000
--- a/net-irc/anope/anope-2.0.7.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Anope IRC Services"
-HOMEPAGE="https://anope.org/ https://github.com/anope/anope/"
-SRC_URI="https://github.com/anope/anope/releases/download/${PV}/${P}-source.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="gnutls ldap mysql pcre sql sqlite ssl tre"
-REQUIRED_USE="
- sql? ( || ( mysql sqlite ) )
-"
-
-BDEPEND="sys-devel/gettext"
-DEPEND="
- acct-group/anope
- acct-user/anope
- mysql? ( dev-db/mysql-connector-c:0= )
- ssl? ( dev-libs/openssl:0= )
- gnutls? ( net-libs/gnutls:0= dev-libs/libgcrypt:0= )
- ldap? ( net-nds/openldap )
- pcre? ( dev-libs/libpcre )
- sqlite? ( dev-db/sqlite:3 )
- tre? ( dev-libs/tre )
- virtual/libintl
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.0.6-example.conf-pid-path.patch"
- "${FILESDIR}/${PN}-2.0.7-example.conf-user.patch"
- "${FILESDIR}/${PN}-2.0.7-musl-libintl.patch"
-)
-
-S="${WORKDIR}/${P}-source"
-
-src_prepare() {
- anope_enable_mod() {
- local modulefile=${1}
- ln -s "extra/${modulefile}" "modules/" || \
- die "Failed to use ${modulefile}"
- }
-
- # These all require MySQL specifically
- if use mysql ; then
- anope_enable_mod "m_mysql.cpp"
- anope_enable_mod "stats/irc2sql/irc2sql.cpp"
- anope_enable_mod "stats/irc2sql/irc2sql.h"
- anope_enable_mod "stats/irc2sql/tables.cpp"
- anope_enable_mod "stats/irc2sql/utils.cpp"
- anope_enable_mod "stats/m_chanstats.cpp"
- anope_enable_mod "stats/cs_fantasy_top.cpp"
- anope_enable_mod "stats/cs_fantasy_stats.cpp"
- anope_enable_mod "m_sql_log.cpp"
- anope_enable_mod "m_sql_oper.cpp"
- fi
-
- use sqlite && anope_enable_mod "m_sqlite.cpp"
-
- # Any SQL implementation
- if use sql ; then
- anope_enable_mod "m_sql_authentication.cpp"
- fi
-
- if use ldap ; then
- anope_enable_mod "m_ldap.cpp"
- anope_enable_mod "m_ldap_authentication.cpp"
- anope_enable_mod "m_ldap_oper.cpp"
- fi
-
- use gnutls && anope_enable_mod "m_ssl_gnutls.cpp"
- use pcre && anope_enable_mod "m_regex_pcre.cpp"
- use ssl && anope_enable_mod "m_ssl_openssl.cpp"
- use tre && anope_enable_mod "m_regex_tre.cpp"
-
- # Unconditional modules
- anope_enable_mod "m_regex_posix.cpp"
-
- # Avoid a silly sandbox error - tries to delete /usr/lib/modules
- sed -i '/install.*REMOVE_RECURSE.*/d' CMakeLists.txt || die
-
- # Copy anope.conf for fixup to comply w/ prefix
- cp "${FILESDIR}/anope-conf.d-v2" "${T}" || die
-
- # Look in the right place for modules
- sed -i "s~%LIBDIR%~${EPREFIX}/usr/$(get_libdir)/anope/~" \
- "${T}/anope-conf.d-v2" || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBIN_DIR="libexec/anope"
- -DDB_DIR="../var/lib/anope"
- -DDOC_DIR="share/doc/${PF}"
- -DLIB_DIR="$(get_libdir)/anope"
- -DLOCALE_DIR="share/locale"
- -DCONF_DIR="/etc/anope"
- -DLOGS_DIR="../var/log/anope/"
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- newinitd "${FILESDIR}/anope-init.d" "${PN}"
- newconfd "${T}/anope-conf.d-v2" "${PN}"
-
- dosym ../libexec/anope/services /usr/bin/services
- dosym ../libexec/anope/anopesmtp /usr/bin/anopesmtp
-
- keepdir /var/log/anope /var/lib/anope/backups
- fowners anope:anope /var/{lib,log}/anope /var/lib/anope/backups
-
- dodoc -r docs/* data/example.conf
-
- insinto /etc/anope
- newins data/example.conf services.conf
-
- fowners anope:anope /var/log/anope
- fowners anope:anope /var/lib/anope/backups/
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- # Only tell them about this on a fresh install.
- elog
- ewarn "Anope won't run out of the box, you still have to configure it to match your IRCd's configuration."
- ewarn "Edit /etc/anope/services.conf to configure Anope."
- elog
- else
- # We're replacing some versions. Find out which.
- local ver
- for ver in ${REPLACING_VERSIONS} ; do
- if ver_test ${ver} -lt 2.0.7 ; then
- # In this version, we introduced correct FHS structure
- # We need the users to make some changes to their services.conf
- ewarn "Please modify your services.conf to include the following directive:"
- ewarn "in options{}, please include user=\"anope\" and group=\"anope\""
- ewarn "This is needed because Anope now starts as root and drops down."
- ewarn "Reference: https://wiki.anope.org/index.php/2.0/Configuration#Services_Process_Options"
- fi
- done
- fi
-}