summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWade Cline <wadecline@hotmail.com>2020-11-01 19:52:14 -0800
committerJoonas Niilola <juippis@gentoo.org>2020-11-05 10:10:15 +0200
commit589054a8dea690c28816d96363ff69d29ee43f11 (patch)
tree936126db07598fbdd2d3d1ae56dfe19bd0934118 /net-irc
parentnet-misc/batctl: Remove outdated ebuilds (diff)
downloadgentoo-589054a8dea690c28816d96363ff69d29ee43f11.tar.gz
gentoo-589054a8dea690c28816d96363ff69d29ee43f11.tar.bz2
gentoo-589054a8dea690c28816d96363ff69d29ee43f11.zip
net-irc/inspircd: Bump to 3.8.0
Signed-off-by: Wade Cline <wadecline@hotmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/inspircd/Manifest1
-rw-r--r--net-irc/inspircd/inspircd-3.8.0.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/net-irc/inspircd/Manifest b/net-irc/inspircd/Manifest
index 476845bc2307..4d7d53cac407 100644
--- a/net-irc/inspircd/Manifest
+++ b/net-irc/inspircd/Manifest
@@ -1,3 +1,4 @@
DIST inspircd-2.0.29.tar.gz 736116 BLAKE2B bd634b81e5a21f4d5e12a4057c4dfb65a241b696be373d24a047594d1d175028dcabff2f28defcf4c340859cfc50637afec755f399c24366e1134c7d69c843f2 SHA512 83da7b089dca8035ffa4f30a2e757661150bb9337aa8124958daa317b44a98fb15fdcb872f8512737b5a39f1b641616eb27c4398d4c8d8fcd40d1f8872bd2052
DIST inspircd-3.4.0.tar.gz 809845 BLAKE2B 6529d53c3cbff07727eceea5e1eb321bb8b7f6b231b3d5ea3ed0ced01fe5b66c2da83039a1ac11ff49e6536ef482483a9be26762feb30511a0016bab07d6790a SHA512 871fefff5e337dc6228fae223ff7ac534e159b5bfb838419247b1d16339c860b0b939a28dd4610cf3b8c37328b5e6ccba2ddd80adbd27638f4f3fa28e4f99066
DIST inspircd-3.7.0.tar.gz 855041 BLAKE2B 8b65c6d29ecf448503201d6d3d9b5416775f7ea97dd3e3acb947cbfcecd4a137f5c4dfd5902f8de43c03b5c5d799acc4a833631982f9815053beec07366a7ccb SHA512 d683d54a046f9bf17ae1a7bb1e2ce94000455c0249478250fd7263f8ede12048ce3982b990bb47461a1c7d9ea5fc20836b3dd255924e72d187eb3a6d591fd51d
+DIST inspircd-3.8.0.tar.gz 849843 BLAKE2B 6233d697329d50df272af904a00bde844c2b8121d75638894cda05f4e6b6d04321c969a293b82bff17f0254bed897574bb2a56acc9283c0b9223b0a8b4747ddc SHA512 efb382b5aa744d42712f9f4ad41d3b939b83bbf702aace2daaff257a96480aa1244a20a63a33b8755e9bab6f15fc39ddde910b1d92022ebcca2ab43af7b4f04e
diff --git a/net-irc/inspircd/inspircd-3.8.0.ebuild b/net-irc/inspircd/inspircd-3.8.0.ebuild
new file mode 100644
index 000000000000..60448a5f4f90
--- /dev/null
+++ b/net-irc/inspircd/inspircd-3.8.0.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Inspire IRCd - The Stable, High-Performance Modular IRCd"
+HOMEPAGE="https://inspircd.github.com/"
+SRC_URI="https://github.com/inspircd/inspircd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug gnutls ldap maxminddb mbedtls mysql pcre postgres re2 regex-posix regex-stdlib sqlite ssl sslrehashsignal tre"
+
+RDEPEND="
+ acct-group/inspircd
+ acct-user/inspircd
+ dev-lang/perl
+ gnutls? ( net-libs/gnutls:= dev-libs/libgcrypt:0 )
+ ldap? ( net-nds/openldap )
+ maxminddb? ( dev-libs/libmaxminddb )
+ mbedtls? ( net-libs/mbedtls:= )
+ mysql? ( dev-db/mysql-connector-c:= )
+ pcre? ( dev-libs/libpcre )
+ postgres? ( dev-db/postgresql:= )
+ re2? ( dev-libs/re2:= )
+ sqlite? ( >=dev-db/sqlite-3.0 )
+ ssl? ( dev-libs/openssl:= )
+ tre? ( dev-libs/tre )"
+DEPEND="${RDEPEND}"
+
+DOCS=( docs/. )
+PATCHES=( "${FILESDIR}"/${PN}-3.7.0-fix-path-builds.patch )
+
+src_prepare() {
+ default
+
+ # Patch the inspircd launcher with the inspircd user
+ sed -i -e "s/@UID@/${PN}/" "make/template/${PN}" || die
+}
+
+src_configure() {
+ local extras=""
+
+ use gnutls && extras+="m_ssl_gnutls.cpp,"
+ use ldap && extras+="m_ldap.cpp,"
+ use maxminddb && extras+="m_geo_maxmind.cpp,"
+ use mbedtls && extras+="m_ssl_mbedtls.cpp,"
+ use mysql && extras+="m_mysql.cpp,"
+ use pcre && extras+="m_regex_pcre.cpp,"
+ use postgres && extras+="m_pgsql.cpp,"
+ use re2 && extras+="m_regex_re2.cpp,"
+ use regex-posix && extras+="m_regex_posix.cpp,"
+ use regex-stdlib && extras+="m_regex_stdlib.cpp,"
+ use sqlite && extras+="m_sqlite3.cpp,"
+ use ssl && extras+="m_ssl_openssl.cpp,"
+ use sslrehashsignal && extras+="m_sslrehashsignal.cpp,"
+ use tre && extras+="m_regex_tre.cpp,"
+
+ # The first configuration run enables certain "extra" InspIRCd
+ # modules, the second run generates the actual makefile.
+ if [[ -n "${extras}" ]]; then
+ ./configure --disable-interactive --enable-extras=${extras%,}
+ fi
+
+ local myconf=(
+ --disable-interactive
+ --disable-auto-extras
+ --prefix="/usr/$(get_libdir)/${PN}"
+ --config-dir="/etc/${PN}"
+ --data-dir="/var/lib/${PN}/data"
+ --log-dir="/var/log/${PN}"
+ --binary-dir="/usr/bin"
+ --module-dir="/usr/$(get_libdir)/${PN}/modules"
+ --manual-dir="/usr/share/man")
+ CXX="$(tc-getCXX)" ./configure "${myconf[@]}"
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" CXXFLAGS="${CXXFLAGS}" $(usex debug 'INSPIRCD_DEBUG=2' '') INSPIRCD_VERBOSE=1
+}
+
+src_install() {
+ default
+
+ insinto "/usr/include/${PN}"
+ doins -r include/.
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ keepdir "/var/log/${PN}"
+
+ diropts -o"${PN}" -g"${PN}" -m0700
+ keepdir "/var/lib/${PN}/data"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You will find example configuration files under "
+ elog "/usr/share/doc/${PN}"
+ elog "Read the ${PN}.conf.example file carefully before "
+ elog "starting the service."
+ fi
+ local pv
+ for pv in ${REPLACING_VERSIONS}; do
+ if ver_test "${pv}" -lt "2.0.24-r1"; then
+ elog "Starting with 2.0.24-r1 the daemon is no longer started"
+ elog "with the --logfile option and you are thus expected to define"
+ elog "logging in the InspIRCd configuration file if you want it."
+ fi
+ if ver_test "${pv}" -lt "3.0.0"; then
+ elog "Version 3.0 is a major upgrade which contains breaking"
+ elog "changes. You will need to update your configuration files."
+ elog "See: https://docs.inspircd.org/3/configuration-changes"
+ fi
+ done
+}