summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2022-06-05 14:38:39 +0200
committerSam James <sam@gentoo.org>2022-06-12 01:48:28 +0100
commit73ecc6c24d708bbc8c0c72e5fb4e77e10b72fe47 (patch)
tree85a5075a27557b0f9359b0ac6997b49fd0933b58 /net-irc
parentdev-util/pkgconf: use HTTPS for SRC_URI (diff)
downloadgentoo-73ecc6c24d708bbc8c0c72e5fb4e77e10b72fe47.tar.gz
gentoo-73ecc6c24d708bbc8c0c72e5fb4e77e10b72fe47.tar.bz2
gentoo-73ecc6c24d708bbc8c0c72e5fb4e77e10b72fe47.zip
net-irc/znc-clientbuffer: QA fixes; adopt
- Add myself as a maintainer - Migrate to cmake.eclass Removes the implicit dependency on Python (due to znc-buildmod) and allows for more flexible options during building. - Use PV in SRC_URI Previous SRC_URI had the version hard-coded, although it's equal to PV. - update EAPI 7 -> 8 - Remove unneded DOCS The default DOCS doesn't need to be modified for the docs to be installed as expected. Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de> Closes: https://github.com/gentoo/gentoo/pull/25768 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/znc-clientbuffer/files/CMakeLists.txt8
-rw-r--r--net-irc/znc-clientbuffer/metadata.xml9
-rw-r--r--net-irc/znc-clientbuffer/znc-clientbuffer-1.0.48-r1.ebuild35
3 files changed, 51 insertions, 1 deletions
diff --git a/net-irc/znc-clientbuffer/files/CMakeLists.txt b/net-irc/znc-clientbuffer/files/CMakeLists.txt
new file mode 100644
index 000000000000..92048a07b19d
--- /dev/null
+++ b/net-irc/znc-clientbuffer/files/CMakeLists.txt
@@ -0,0 +1,8 @@
+# Autogenerated using znc-buildmod -v from net-irc/znc-1.8.2
+cmake_minimum_required(VERSION 3.1)
+project(ExternalModules LANGUAGES CXX)
+find_package(ZNC HINTS /usr/share/znc REQUIRED)
+
+add_library(module_clientbuffer MODULE clientbuffer.cpp)
+znc_setup_module(TARGET module_clientbuffer NAME clientbuffer)
+target_link_libraries(module_clientbuffer PRIVATE)
diff --git a/net-irc/znc-clientbuffer/metadata.xml b/net-irc/znc-clientbuffer/metadata.xml
index 51ac8d02eab7..8cca526cf091 100644
--- a/net-irc/znc-clientbuffer/metadata.xml
+++ b/net-irc/znc-clientbuffer/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>nex+b-g-o@nexadn.de</email>
+ <name>Adrian Schollmeyer</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<bugs-to>https://git.jordanko.ch/Igloo/Push/issues</bugs-to>
<remote-id type="github">CyberShadow/znc-clientbuffer</remote-id>
diff --git a/net-irc/znc-clientbuffer/znc-clientbuffer-1.0.48-r1.ebuild b/net-irc/znc-clientbuffer/znc-clientbuffer-1.0.48-r1.ebuild
new file mode 100644
index 000000000000..1575980e13a7
--- /dev/null
+++ b/net-irc/znc-clientbuffer/znc-clientbuffer-1.0.48-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A ZNC module which provides client specific buffers"
+HOMEPAGE="https://github.com/CyberShadow/znc-clientbuffer"
+SRC_URI="https://github.com/CyberShadow/znc-clientbuffer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ net-irc/znc:="
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cp -v "${FILESDIR}/CMakeLists.txt" "${S}" || die
+ cmake_src_prepare
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/znc
+ doexe "${BUILD_DIR}"/clientbuffer.so
+
+ einstalldocs
+}