summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-10-05 11:05:41 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-10-05 11:05:58 +0200
commitec0152d219b9d7db6859d8257072c1b78f12dd77 (patch)
tree3862d806ae139ba6dc02b325b1c1ef0f1bb00112 /net-irc
parentsys-kernel/git-sources: Automated version bump to 5.9_rc8. (diff)
downloadgentoo-ec0152d219b9d7db6859d8257072c1b78f12dd77.tar.gz
gentoo-ec0152d219b9d7db6859d8257072c1b78f12dd77.tar.bz2
gentoo-ec0152d219b9d7db6859d8257072c1b78f12dd77.zip
net-irc/irssi: Revbump to fix input issue with >=dev-libs/glib-2.63
Thanks-to: Tomasz Golinski <tomaszg@alpha.uwb.edu.pl> Closes: https://bugs.gentoo.org/746704 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irssi/files/irssi-1.2.2-glib-2.63_NUL_unicode_fix.patch38
-rw-r--r--net-irc/irssi/irssi-1.2.2-r1.ebuild67
2 files changed, 105 insertions, 0 deletions
diff --git a/net-irc/irssi/files/irssi-1.2.2-glib-2.63_NUL_unicode_fix.patch b/net-irc/irssi/files/irssi-1.2.2-glib-2.63_NUL_unicode_fix.patch
new file mode 100644
index 000000000000..63d26958b7bf
--- /dev/null
+++ b/net-irc/irssi/files/irssi-1.2.2-glib-2.63_NUL_unicode_fix.patch
@@ -0,0 +1,38 @@
+From a0544571a80196e5b7705f56e6e2cbcdf7b4d80e Mon Sep 17 00:00:00 2001
+From: ailin-nemui <ailin-nemui@users.noreply.github.com>
+Date: Thu, 23 Apr 2020 21:45:15 +0200
+Subject: [PATCH] manually handle NUL unicode in g_utf8_get_next_char_validated
+
+A change in GLib 2.63 broke some assumptions in Irssi that the null-byte
+NUL / U+0000 is a valid Unicode character. This would occur when the
+user types Ctrl+Space. As a result, the input loop never manages to
+process the NUL-byte (and any other user input that follows, ever).
+
+This patch adds a manual check that properly advances the input loop if
+GLib returns -2 (incomplete character) despite the length being positive
+and a NUL is in first position.
+
+Fixes #1180
+https://gitlab.gnome.org/GNOME/glib/-/merge_requests/967
+https://gitlab.gnome.org/GNOME/glib/-/issues/2093
+---
+ src/fe-text/term-terminfo.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/src/fe-text/term-terminfo.c b/src/fe-text/term-terminfo.c
+index 5235f72d2..78496a64f 100644
+--- a/src/fe-text/term-terminfo.c
++++ b/src/fe-text/term-terminfo.c
+@@ -672,7 +672,11 @@ void term_stop(void)
+
+ static int input_utf8(const unsigned char *buffer, int size, unichar *result)
+ {
+- unichar c = g_utf8_get_char_validated((char *)buffer, size);
++ unichar c = g_utf8_get_char_validated((char *) buffer, size);
++
++ /* GLib >= 2.63 do not accept Unicode NUL anymore */
++ if (c == (unichar) -2 && *buffer == 0 && size > 0)
++ c = 0;
+
+ switch (c) {
+ case (unichar)-1:
diff --git a/net-irc/irssi/irssi-1.2.2-r1.ebuild b/net-irc/irssi/irssi-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..ed231dbb3fa3
--- /dev/null
+++ b/net-irc/irssi/irssi-1.2.2-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GENTOO_DEPEND_ON_PERL="no"
+
+inherit perl-module
+
+# Keep for _rc compability
+MY_P="${P/_/-}"
+
+DESCRIPTION="A modular textUI IRC client with IPv6 support"
+HOMEPAGE="https://irssi.org/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV/_/-}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="otr +perl selinux socks5 +proxy libressl"
+
+COMMON_DEPEND="
+ sys-libs/ncurses:0=
+ >=dev-libs/glib-2.6.0
+ !libressl? ( dev-libs/openssl:= )
+ libressl? ( >=dev-libs/libressl-2.7.4:= )
+ otr? ( >=dev-libs/libgcrypt-1.2.0:0=
+ >=net-libs/libotr-4.1.0 )
+ perl? ( dev-lang/perl:= )
+ socks5? ( >=net-proxy/dante-1.1.18 )"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-irc )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.2.2-glib-2.63_NUL_unicode_fix.patch" #746704
+)
+
+src_configure() {
+ # Disable automagic dependency on dev-libs/libutf8proc (bug #677804)
+ export ac_cv_lib_utf8proc_utf8proc_version=no
+
+ local myeconfargs=(
+ --with-perl-lib=vendor
+ --enable-true-color
+ $(use_with otr)
+ $(use_with proxy)
+ $(use_with perl)
+ $(use_with socks5 socks)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ use perl && perl_delete_localpod
+ rm -f "${ED}"/usr/$(get_libdir)/irssi/modules/*.{a,la} || die
+}