summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-08-30 13:50:31 +0200
committerSam James <sam@gentoo.org>2020-09-29 20:13:20 +0000
commitfc7a3a5ed3576f8793ca4b2baa959745142166f5 (patch)
tree5b18fedfe142af62532c8479dfe4c6c2f0256f3a /net-irc
parentdev-perl/Class-Method-Modifiers: Keyword 2.130.0 arm64, #745219 (diff)
downloadgentoo-fc7a3a5ed3576f8793ca4b2baa959745142166f5.tar.gz
gentoo-fc7a3a5ed3576f8793ca4b2baa959745142166f5.tar.bz2
gentoo-fc7a3a5ed3576f8793ca4b2baa959745142166f5.zip
net-irc/quasselgrep: bump to 0_p20200830
Closes: https://bugs.gentoo.org/694678 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quasselgrep/Manifest1
-rw-r--r--net-irc/quasselgrep/quasselgrep-0_p20200830.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-irc/quasselgrep/Manifest b/net-irc/quasselgrep/Manifest
index 7f07601f6323..627c40411d2c 100644
--- a/net-irc/quasselgrep/Manifest
+++ b/net-irc/quasselgrep/Manifest
@@ -1 +1,2 @@
DIST quasselgrep-0_p20190211.tar.gz 29954 BLAKE2B 33862b642d6a24bd7ab8cc4f3628e19cf332feb24e0dba17849f4ee85af4d1d17a641e6ccaef89bcb44c47f28a674ab620610b8b624f9de71b8460b197953e27 SHA512 0d2bfccb87b7463ba032b9515c4a089518a3ca57f9ef6cbb0f00db9c5d0404cc9fe128329b12e1dbe022cbddeb6a3db473564ee734ddc30be56d4c1da5036f56
+DIST quasselgrep-0_p20200830.tar.gz 29944 BLAKE2B 011633afee9d9519b0c343c5d0b1a9ba775c870802532515a42a7c22d39af5138a051707a82f2b6a19dda3523fe9f04d2b56b62a36c554ff873275c095e7dd94 SHA512 88f568852cc9e85e0019335d3362f192766a2ce3e94ff1947485ad6eaf43d49873d94396791165f74e95edb25601c078a947a7740b4ae2e40424b5bdfecc2a48
diff --git a/net-irc/quasselgrep/quasselgrep-0_p20200830.ebuild b/net-irc/quasselgrep/quasselgrep-0_p20200830.ebuild
new file mode 100644
index 000000000000..4ade54031303
--- /dev/null
+++ b/net-irc/quasselgrep/quasselgrep-0_p20200830.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE=( sqlite )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Tool for searching quassel logs from the commandline"
+HOMEPAGE="https://github.com/fish-face/quasselgrep"
+
+MY_COMMIT="9b6b0bc1252daa6e574363d87d04eebd981215a5"
+SRC_URI="https://github.com/fish-face/quasselgrep/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="dev-python/future[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ optfeature "access postgres db" dev-python/psycopg:2
+}