summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-20 15:54:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-20 16:37:56 +0100
commit5559fe0a4337202d0f03d8e9a0e9d7e63cd8f421 (patch)
tree26f2ed310e60b86dd1491ff3301df37eb3f6385c /net-libs/accounts-qt/accounts-qt-1.16.ebuild
parentx11-libs/libfakekey: 0.3 version bump, EAPI-7 bump (diff)
downloadgentoo-5559fe0a4337202d0f03d8e9a0e9d7e63cd8f421.tar.gz
gentoo-5559fe0a4337202d0f03d8e9a0e9d7e63cd8f421.tar.bz2
gentoo-5559fe0a4337202d0f03d8e9a0e9d7e63cd8f421.zip
net-libs/accounts-qt: 1.16 version bump
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/accounts-qt/accounts-qt-1.16.ebuild')
-rw-r--r--net-libs/accounts-qt/accounts-qt-1.16.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-libs/accounts-qt/accounts-qt-1.16.ebuild b/net-libs/accounts-qt/accounts-qt-1.16.ebuild
new file mode 100644
index 000000000000..1770e7ed667d
--- /dev/null
+++ b/net-libs/accounts-qt/accounts-qt-1.16.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Qt5 bindings for libaccounts-glib"
+HOMEPAGE="https://accounts-sso.gitlab.io/"
+SRC_URI="https://gitlab.com/accounts-sso/lib${PN}/repository/VERSION_${PV}/archive.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc test"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtxml:5
+ >=net-libs/libaccounts-glib-1.23:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+# dbus problems
+RESTRICT="test"
+
+S="${WORKDIR}/lib${PN}-VERSION_${PV}-5b272ae218ccdf1f67f4eed92e2cdbe21c56ceb8"
+
+src_prepare() {
+ default
+
+ sed -e "s|share/doc/\$\${PROJECT_NAME}|share/doc/${PF}|" \
+ -i doc/doc.pri || die
+ if ! use doc; then
+ sed -e "/include( doc\/doc.pri )/d" -i ${PN}.pro || die
+ fi
+ if ! use test; then
+ sed -e '/^SUBDIRS/s/tests//' \
+ -i accounts-qt.pro || die "couldn't disable tests"
+ fi
+}
+
+src_configure() {
+ eqmake5 LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}