summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-03-26 14:31:05 +0200
committerUlrich Müller <ulm@gentoo.org>2017-03-26 14:34:10 +0200
commit14d049f4480fd2a1b49bc9e60a00f3ae39e29424 (patch)
tree9b0721e4f54e8de7a56a425d7aa6e4501e5270e4 /net-libs/adns/adns-1.4.ebuild
parentnet-mail/notmuch: Follow guidlines for completion files (diff)
downloadgentoo-14d049f4480fd2a1b49bc9e60a00f3ae39e29424.tar.gz
gentoo-14d049f4480fd2a1b49bc9e60a00f3ae39e29424.tar.bz2
gentoo-14d049f4480fd2a1b49bc9e60a00f3ae39e29424.zip
net-libs/adns: [QA] Don't access FILESDIR in pkg_postinst.
Bump to EAPI 6. Avoid dohtml. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-libs/adns/adns-1.4.ebuild')
-rw-r--r--net-libs/adns/adns-1.4.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-libs/adns/adns-1.4.ebuild b/net-libs/adns/adns-1.4.ebuild
index b91bea2796fc..92258217447e 100644
--- a/net-libs/adns/adns-1.4.ebuild
+++ b/net-libs/adns/adns-1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
inherit eutils multilib toolchain-funcs
@@ -25,8 +25,9 @@ src_install () {
emake prefix="${D}"/usr libdir="${D}"/usr/$(get_libdir) install || die "emake install failed"
dodoc README TODO changelog "${FILESDIR}"/README.security
dohtml *.html
+ MY_POSTINST_MSG=$(<"${FILESDIR}"/README.security)
}
pkg_postinst() {
- ewarn "$(<${FILESDIR}/README.security)"
+ ewarn "${MY_POSTINST_MSG}"
}