summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2021-03-31 15:06:43 +0200
committerHanno Böck <hanno@gentoo.org>2021-03-31 15:06:43 +0200
commit47e9cf1a90abc3f6792797c08dd5dc57f625383c (patch)
tree09a9e104c01867889e5d3cdbdadd1fb4310b395e /net-libs/courier-authlib
parentsci-mathematics/glpk: don't install build artifacts with USE=examples. (diff)
downloadgentoo-47e9cf1a90abc3f6792797c08dd5dc57f625383c.tar.gz
gentoo-47e9cf1a90abc3f6792797c08dd5dc57f625383c.tar.bz2
gentoo-47e9cf1a90abc3f6792797c08dd5dc57f625383c.zip
net-libs/courier-authlib: Version bump
Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.18, Repoman-3.0.3
Diffstat (limited to 'net-libs/courier-authlib')
-rw-r--r--net-libs/courier-authlib/Manifest1
-rw-r--r--net-libs/courier-authlib/courier-authlib-0.71.2.ebuild148
2 files changed, 149 insertions, 0 deletions
diff --git a/net-libs/courier-authlib/Manifest b/net-libs/courier-authlib/Manifest
index 27f8ac5997c5..7f602ce6de18 100644
--- a/net-libs/courier-authlib/Manifest
+++ b/net-libs/courier-authlib/Manifest
@@ -2,3 +2,4 @@ DIST courier-authlib-0.69.0.tar.bz2 2197718 BLAKE2B 63c273a85983ce7bd57496eeefac
DIST courier-authlib-0.70.0.tar.bz2 2183323 BLAKE2B ebf58f8c4e7b58766edc684ced590ea7bfa692eff19a483f4ab7748a73e96e1c66858985ac89e281205838660a72e9a33e3b3c28fce3f94d981b61ca56b1e2b1 SHA512 61ce62860cc7ceb51f255a0659bf9b8f4172d0c1c8aee06d9821144330f9526f54e6bdb0158f2fd754d6ad92fd4cc84306b949d46c92e8aed47a397023b36b65
DIST courier-authlib-0.71.0.tar.bz2 2207895 BLAKE2B 8eb92b2c07acfb662b34a2234759a80f3a1b5a96c9e537cd6215bd9a9a607ed8995461dd599e4fe2698e70510f11815ad13a0511446303ae5e26ff616f05d92f SHA512 7a9700c472fd9d6942bd15dfd8db474a738817608bcd8106b6211b24cdc0631fd69f99e7a5c9e9f6088c16b53a9304ec429c031b16621f8ef52581af8a4256ec
DIST courier-authlib-0.71.1.tar.bz2 2208870 BLAKE2B 5058a5d3182c53020c3be0a693908bd90e6e2397f03124df3efd7c3bd39ebdc794166d49c6153880bbf93518afbf4388160680cd701236b075b6e59624fb6882 SHA512 a1b36f4f3b0f11fb34e5dab197b3a0471bc6a99528fe77836b3b2d12f9dac292be4c181aeba5afa3410685dd6882ed00ff6692e74cd0132ba591de1294d0f2d7
+DIST courier-authlib-0.71.2.tar.bz2 2208460 BLAKE2B 49aaea85032166ba4867e7834bb2f6c8d3eccb0ebe24b94bac3033a3da2154e3162d06892354b37eb0c38db092ce0096b050246db341b18a32065c19f322238a SHA512 b0bd2356013d48a998908d4825901e8e730ec276699005696948781e8af4014e25eded3116fa5a8a38b6236e9713f454170628b51aedab7b7d2ebec082643a47
diff --git a/net-libs/courier-authlib/courier-authlib-0.71.2.ebuild b/net-libs/courier-authlib/courier-authlib-0.71.2.ebuild
new file mode 100644
index 000000000000..923d27fc838a
--- /dev/null
+++ b/net-libs/courier-authlib/courier-authlib-0.71.2.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+DESCRIPTION="Courier authentication library"
+SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
+HOMEPAGE="https://www.courier-mta.org/authlib/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="berkdb crypt debug gdbm ldap libressl mysql pam postgres sqlite static-libs"
+
+RESTRICT="!berkdb? ( test )"
+
+DEPEND="net-mail/mailbase
+ >=net-libs/courier-unicode-2.2.3
+ gdbm? ( sys-libs/gdbm )
+ !gdbm? ( sys-libs/db:= )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ mysql? ( dev-db/mysql-connector-c )
+ pam? ( sys-libs/pam )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( dev-db/sqlite:3 )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! has_version 'dev-tcltk/expect' ; then
+ ewarn 'The dev-tcltk/expect package is not installed.'
+ ewarn 'Without it, you will not be able to change system login passwords.'
+ ewarn 'However non-system authentication modules (LDAP, MySQL, PostgreSQL,'
+ ewarn 'and others) will work just fine.'
+ fi
+}
+
+src_configure() {
+ filter-flags -fomit-frame-pointer
+ local myconf
+ if use berkdb ; then
+ if use gdbm ; then
+ ewarn "Both gdbm and berkdb selected. Using gdbm."
+ else
+ myconf="--with-db=db"
+ fi
+ fi
+ use gdbm && myconf="--with-db=gdbm"
+ use debug && myconf+=" debug=true"
+ use sqlite && myconf+=" --with-sqlite-libs"
+
+ econf \
+ --sysconfdir=/etc/courier \
+ --datadir=/usr/share/courier \
+ --localstatedir=/var/lib/courier \
+ --sharedstatedir=/var/lib/courier/com \
+ --with-authdaemonvar=/var/lib/courier/authdaemon \
+ --with-authshadow \
+ --without-redhat \
+ --with-mailuser=mail \
+ --with-mailgroup=mail \
+ --cache-file="${S}/configuring.cache" \
+ $(use_with pam authpam) \
+ $(use_with ldap authldap) \
+ $(use_with mysql authmysql) \
+ $(use_with postgres authpgsql) \
+ $(use_with sqlite authsqlite) \
+ ${myconf}
+}
+
+orderfirst() {
+ file="${D}/etc/courier/authlib/${1}" ; option="${2}" ; param="${3}"
+ if [[ -e "${file}" ]] ; then
+ orig="$(grep ^${option}= ${file} | cut -d\" -f 2)"
+ new="${option}=\"${param} `echo ${orig} | sed -e\"s/${param}//g\" -e\"s/ / /g\"`\""
+ sed -i -e "s/^${option}=.*$/${new}/" "${file}" || die
+ fi
+}
+
+finduserdb() {
+ for dir in \
+ /etc/courier/authlib /etc/courier /etc/courier-imap \
+ /usr/lib/courier/etc /usr/lib/courier-imap/etc \
+ /usr/local/etc /usr/local/etc/courier /usr/local/courier/etc \
+ /usr/local/lib/courier/etc /usr/local/lib/courier-imap/etc \
+ /usr/local/share/sqwebmail /usr/local/etc/courier-imap ; do
+ if [[ -e "${dir}/userdb" ]] ; then
+ einfo "Found userdb at: ${dir}/userdb"
+ cp -fR "${dir}/userdb" "${D}/etc/courier/authlib/" || die
+ chmod go-rwx "${D}/etc/courier/authlib/userdb" || die
+ continue
+ fi
+ done
+}
+
+src_install() {
+ diropts -o mail -g mail
+ dodir /etc/courier
+ keepdir /var/lib/courier/authdaemon
+ keepdir /etc/courier/authlib
+ emake DESTDIR="${D}" install
+ [[ ! -e "${D}/etc/courier/authlib/userdb" ]] && finduserdb
+ emake DESTDIR="${D}" install-configure
+ rm -f "${D}"/etc/courier/authlib/*.bak
+ chown mail:mail "${D}"/etc/courier/authlib/* || die
+ for y in "${D}"/etc/courier/authlib/*.dist ; do
+ [[ ! -e "${y%%.dist}" ]] && cp -f "${y}" "${y%%.dist}"
+ done
+ use pam && orderfirst authdaemonrc authmodulelist authpam
+ use ldap && orderfirst authdaemonrc authmodulelist authldap
+ use sqlite && orderfirst authdaemonrc authmodulelist authsqlite
+ use postgres && orderfirst authdaemonrc authmodulelist authpgsql
+ use mysql && orderfirst authdaemonrc authmodulelist authmysql
+
+ DOCS=( AUTHORS ChangeLog* INSTALL NEWS README )
+ HTML_DOCS=( README.html README_authlib.html NEWS.html INSTALL.html README.authdebug.html )
+ if use mysql ; then
+ DOCS+=( README.authmysql.myownquery )
+ HTML_DOCS+=( README.authmysql.html )
+ fi
+ if use postgres ; then
+ HTML_DOCS+=( README.authpostgres.html README.authmysql.html )
+ fi
+ if use ldap ; then
+ DOCS+=( README.ldap )
+ dodir /etc/openldap/schema
+ cp -f authldap.schema "${D}/etc/openldap/schema/" || die
+ fi
+ if use sqlite ; then
+ HTML_DOCS+=( README.authsqlite.html README.authmysql.html )
+ fi
+ einstalldocs
+
+ newinitd "${FILESDIR}/${PN}-r2" "${PN}"
+
+ use static-libs || find "${D}" -name "*.a" -delete
+}
+
+pkg_postinst() {
+ if [[ -e /etc/courier/authlib/userdb ]] ; then
+ einfo "Running makeuserdb ..."
+ chmod go-rwx /etc/courier/authlib/userdb || die
+ makeuserdb
+ fi
+}