summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-16 03:14:45 +0100
committerSam James <sam@gentoo.org>2021-08-16 03:23:35 +0100
commitae4b36193858f28bb15a04c15d69459d7f95d45d (patch)
treef818ac20e43fec093c7f105e6f9eded64e95b55a /net-libs/courier-unicode/courier-unicode-2.2.3-r1.ebuild
parentmetadata/install-qa-check.d: add check for missing tmpfiles_process call (diff)
downloadgentoo-ae4b36193858f28bb15a04c15d69459d7f95d45d.tar.gz
gentoo-ae4b36193858f28bb15a04c15d69459d7f95d45d.tar.bz2
gentoo-ae4b36193858f28bb15a04c15d69459d7f95d45d.zip
net-libs/courier-unicode: add subslot for ABI breakage
SONAME from 2.1 -> 2.2 went from 4.1.0 -> 7.0.0. Bug: https://bugs.gentoo.org/806595 Bug: https://bugs.gentoo.org/807292 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/courier-unicode/courier-unicode-2.2.3-r1.ebuild')
-rw-r--r--net-libs/courier-unicode/courier-unicode-2.2.3-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-libs/courier-unicode/courier-unicode-2.2.3-r1.ebuild b/net-libs/courier-unicode/courier-unicode-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..dbb52817c9bf
--- /dev/null
+++ b/net-libs/courier-unicode/courier-unicode-2.2.3-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Unicode library used by the courier mail server"
+HOMEPAGE="https://www.courier-mta.org/"
+SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0/7"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ dodoc AUTHORS ChangeLog README
+}