summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/cvm/cvm-0.76.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/cvm/cvm-0.76.ebuild')
-rw-r--r--net-libs/cvm/cvm-0.76.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/cvm/cvm-0.76.ebuild b/net-libs/cvm/cvm-0.76.ebuild
new file mode 100644
index 000000000000..d5b1d71ba269
--- /dev/null
+++ b/net-libs/cvm/cvm-0.76.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Credential Validation Modules by Bruce Guenter"
+HOMEPAGE="http://untroubled.org/cvm/"
+SRC_URI="${HOMEPAGE}archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc sparc x86"
+IUSE="mysql postgres test"
+
+RDEPEND="dev-db/cdb"
+DEPEND="${RDEPEND}
+ >=dev-libs/bglibs-1.041
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql[server] )
+ test? ( app-editors/vim )"
+# some of the testcases use ex/vi/xxd
+
+src_unpack() {
+ unpack ${A}
+ # disable this test, as it breaks under Portage
+ # and there is no easy fix
+ sed -i.orig -e '/qmail-lookup-nodomain/,/^END_OF_TEST_RESULTS/d' "${S}"/tests.sh || die "sed failed"
+}
+
+src_compile() {
+ echo "/usr/include/bglibs" > conf-bgincs
+ echo "/usr/lib/bglibs" > conf-bglibs
+ echo "${D}/usr/include" > conf-include
+ echo "${D}/usr/lib" > conf-lib
+ echo "${D}/usr/bin" > conf-bin
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS} -lcrypt" > conf-ld
+ emake || die
+
+ if use mysql; then
+ make mysql || die "making mysql support failed"
+ fi
+
+ if use postgres; then
+ make pgsql || die "making postgres support failed"
+ fi
+}
+
+src_install() {
+ einstall || die
+
+ dodoc ANNOUNCEMENT NEWS NEWS.sql NEWS.vmailmgr README README.vchkpw
+ dodoc README.vmailmgr TODO VERSION
+ dohtml *.html
+}
+
+src_test() {
+ sh tests.sh || die "Testing Failed"
+}