summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-01 14:44:13 -0400
committerMatt Turner <mattst88@gentoo.org>2021-05-01 15:42:24 -0400
commit55cd5e095b56c4ac9382ed52b175244a034d04cb (patch)
tree313937ab6112c79700cdd2158f124720292cf9c6 /net-libs/dleyna-core/dleyna-core-0.7.0.ebuild
parentapp-portage/gs-elpa: Generate ebuilds for EAPI 7 (diff)
downloadgentoo-55cd5e095b56c4ac9382ed52b175244a034d04cb.tar.gz
gentoo-55cd5e095b56c4ac9382ed52b175244a034d04cb.tar.bz2
gentoo-55cd5e095b56c4ac9382ed52b175244a034d04cb.zip
net-libs/dleyna-core: Version bump to 0.7.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/dleyna-core/dleyna-core-0.7.0.ebuild')
-rw-r--r--net-libs/dleyna-core/dleyna-core-0.7.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-libs/dleyna-core/dleyna-core-0.7.0.ebuild b/net-libs/dleyna-core/dleyna-core-0.7.0.ebuild
new file mode 100644
index 000000000000..119dfa74760a
--- /dev/null
+++ b/net-libs/dleyna-core/dleyna-core-0.7.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="utility library for higher level dLeyna libraries"
+HOMEPAGE="https://github.com/phako/dleyna-core"
+SRC_URI="https://github.com/phako/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0/5" # soname of libdleyna-core-1.0.so
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=net-libs/gupnp-1.2.0:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"