summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-11-24 08:30:55 -0300
committerMatt Turner <mattst88@gentoo.org>2022-12-20 11:54:55 -0500
commit0e9b89db44f2c6023d31567179a9514551567da1 (patch)
tree4e3c1351a7710f43edbfb0794a0e7e45dd77abf5 /net-libs/dleyna
parentnet-libs/libupnp: Stabilize 1.14.15 ppc, #887441 (diff)
downloadgentoo-0e9b89db44f2c6023d31567179a9514551567da1.tar.gz
gentoo-0e9b89db44f2c6023d31567179a9514551567da1.tar.bz2
gentoo-0e9b89db44f2c6023d31567179a9514551567da1.zip
net-libs/dleyna: Version bump to 0.8.2
Closes: https://github.com/gentoo/gentoo/pull/28412 Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/dleyna')
-rw-r--r--net-libs/dleyna/Manifest1
-rw-r--r--net-libs/dleyna/dleyna-0.8.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-libs/dleyna/Manifest b/net-libs/dleyna/Manifest
index ce9605a2d526..db519b631f9c 100644
--- a/net-libs/dleyna/Manifest
+++ b/net-libs/dleyna/Manifest
@@ -1 +1,2 @@
DIST dLeyna-v0.8.1.tar.bz2 146410 BLAKE2B a26ebc01df4a8d5cefeb900001e06605d4dffe6beebd6df650e9425048b787edb7dd144399fd66916dee360bc6bb3cf1071e24464ec52d0cdce36e5440272e41 SHA512 9b93ddb0b1a7a29d99da875aba1ae0e3e9c61d003353e4705cbf4274449af6c4ca454e68fe4d618749b7ff7cd215ad3361b07575494dadd8be34c589b8e48641
+DIST dLeyna-v0.8.2.tar.bz2 149691 BLAKE2B c9837da15c18b25c0e9021776cabdcffe52acfaac0f2858ab004b554d9a212ca45cc08f2893383248c5bb5ce57df854d79c329f80511b9f098663326f1badecc SHA512 25a62ad6b623a8d67d90af608d0fa68e4dcef916c5b44f51eb927f6e276555b978414c95f59a680c5938c7b67abe0cc09afa4e58d068f115d73ce6cb40959144
diff --git a/net-libs/dleyna/dleyna-0.8.2.ebuild b/net-libs/dleyna/dleyna-0.8.2.ebuild
new file mode 100644
index 000000000000..6449f06f331b
--- /dev/null
+++ b/net-libs/dleyna/dleyna-0.8.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="A set of services and D-Bus APIs to simplify access to UPnP/DLNA media devices"
+HOMEPAGE="https://gitlab.gnome.org/World/dLeyna"
+SRC_URI="https://gitlab.gnome.org/World/dLeyna/-/archive/v${PV}/dLeyna-v${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0/6" # soname of libdleyna-core-1.0.so
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=net-libs/gssdp-1.6.0:1.6=
+ >=net-libs/gupnp-1.6.0:1.6=
+ >=net-libs/gupnp-av-0.12.9:0=
+ >=media-libs/gupnp-dlna-0.9.4:2.0=
+ >=net-libs/libsoup-3.0:3.0
+ dev-libs/libxml2
+
+ !net-libs/dleyna-connector-dbus
+ !net-libs/dleyna-core
+ !net-libs/dleyna-renderer
+ !net-misc/dleyna-server
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/docutils
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}"/dLeyna-v${PV}
+
+src_configure() {
+ local emesonargs=(
+ -Ddbus_service_dir="${EPREFIX}/usr/share/dbus-1/services"
+ -Dman_pages=true
+ -Ddocs=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}