summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/enet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/enet')
-rw-r--r--net-libs/enet/Manifest3
-rw-r--r--net-libs/enet/enet-1.2.2.ebuild23
-rw-r--r--net-libs/enet/enet-1.3.12.ebuild33
-rw-r--r--net-libs/enet/enet-1.3.7.ebuild33
-rw-r--r--net-libs/enet/metadata.xml8
5 files changed, 100 insertions, 0 deletions
diff --git a/net-libs/enet/Manifest b/net-libs/enet/Manifest
new file mode 100644
index 000000000000..712f39627ca4
--- /dev/null
+++ b/net-libs/enet/Manifest
@@ -0,0 +1,3 @@
+DIST enet-1.2.2.tar.gz 413454 SHA256 6ce4e183ebfe980201b39174ad952993dbd8e8a7c325903fd520074ac7c2e20f SHA512 2c28ab4b650dd4165ee5913c1bc80dc47e43f2363a5fdd7f3aa9be8fb3afbc8aff7a6bce731f7dac45eb930fc6338cd811c07e8dedca5554a7dd32293685062d WHIRLPOOL f63da36d2cc5c1dc15f0f88234620536c300c64906c1e9f3bfddcd6cf70aa81bd37b653c34dd0d25baae4022addcd17b9b9f4863f7899e1630fc22f08c095fcd
+DIST enet-1.3.12.tar.gz 550604 SHA256 a5851cbd0dde2ddb47bca487a61976825159cb508ece3b1e34605420ac7e1d0b SHA512 cd41f807dedd2a2d2e55ef9094d210a5dcc1df8f6371c7d974414eecec91b59d094dfb0ea5ac091875466a9c95141f340f82da2143698df8c95f787fffe04ee3 WHIRLPOOL fdf709830e272a0aa0ca35c28092cc65dd52e1d5870d185c863b90fb81e2bda99863886ef559098188cf0b5abffb02a4e01c7ad495995f6a9e14862719f1c5eb
+DIST enet-1.3.7.tar.gz 522150 SHA256 15acbfd8e3aaf353320a60c785093cdf34f2ae207bcdd489503ca3f37659fe15 SHA512 b715347d94d8c5361033002e366f2cd7b8dd263faf7e84bd3d120de770f85025749fed4325c08f12d27875a112fb534a0464f8776bea6c3df2f048b57e5623f0 WHIRLPOOL 2ed39a5669ba74e11a08b70a5518a5314b43dad7629132f7e75f10445bea6491bdf27cd6ca34f9434a65fee236074169173687823f76bba3d66a2959a3478916
diff --git a/net-libs/enet/enet-1.2.2.ebuild b/net-libs/enet/enet-1.2.2.ebuild
new file mode 100644
index 000000000000..be0618bb7245
--- /dev/null
+++ b/net-libs/enet/enet-1.2.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit base
+
+DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
+HOMEPAGE="http://enet.bespin.org/"
+SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE="static-libs"
+
+DOCS=( "ChangeLog" "README" )
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
diff --git a/net-libs/enet/enet-1.3.12.ebuild b/net-libs/enet/enet-1.3.12.ebuild
new file mode 100644
index 000000000000..fc29b1c024ff
--- /dev/null
+++ b/net-libs/enet/enet-1.3.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base
+
+DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
+HOMEPAGE="http://enet.bespin.org/"
+SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1.3/2.2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="!${CATEGORY}/${PN}:0"
+
+DOCS=( "ChangeLog" "README" )
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ base_src_install
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + || die
+ fi
+}
diff --git a/net-libs/enet/enet-1.3.7.ebuild b/net-libs/enet/enet-1.3.7.ebuild
new file mode 100644
index 000000000000..26de62ae8437
--- /dev/null
+++ b/net-libs/enet/enet-1.3.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base
+
+DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
+HOMEPAGE="http://enet.bespin.org/"
+SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1.3/2.2"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="static-libs"
+
+RDEPEND="!${CATEGORY}/${PN}:0"
+
+DOCS=( "ChangeLog" "README" )
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ base_src_install
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + || die
+ fi
+}
diff --git a/net-libs/enet/metadata.xml b/net-libs/enet/metadata.xml
new file mode 100644
index 000000000000..5b80fb94c393
--- /dev/null
+++ b/net-libs/enet/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>