summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-08 05:37:22 +0100
committerSam James <sam@gentoo.org>2023-08-08 05:37:22 +0100
commit55579ccfe7243a03d0cbe77d95c550913841d451 (patch)
treefae3bd99103c5990f74813c8c2208e07a8a51b93 /net-libs/gnutls
parentapp-editors/vim-core: add 9.0.1678, drop 9.0.1677 (diff)
downloadgentoo-55579ccfe7243a03d0cbe77d95c550913841d451.tar.gz
gentoo-55579ccfe7243a03d0cbe77d95c550913841d451.tar.bz2
gentoo-55579ccfe7243a03d0cbe77d95c550913841d451.zip
net-libs/gnutls: fix 3.8.0 headers
Closes: https://bugs.gentoo.org/911872 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/gnutls')
-rw-r--r--net-libs/gnutls/files/gnutls-3.8.1-fix-gnutls-header.patch46
-rw-r--r--net-libs/gnutls/gnutls-3.8.1-r1.ebuild (renamed from net-libs/gnutls/gnutls-3.8.1.ebuild)4
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/gnutls/files/gnutls-3.8.1-fix-gnutls-header.patch b/net-libs/gnutls/files/gnutls-3.8.1-fix-gnutls-header.patch
new file mode 100644
index 000000000000..b3d10c1788f6
--- /dev/null
+++ b/net-libs/gnutls/files/gnutls-3.8.1-fix-gnutls-header.patch
@@ -0,0 +1,46 @@
+https://bugs.gentoo.org/911872
+https://gitlab.com/gnutls/gnutls/-/commit/abfa8634db940115a11a07596ce53c8f9c4f87d2
+
+From abfa8634db940115a11a07596ce53c8f9c4f87d2 Mon Sep 17 00:00:00 2001
+From: Adrian Bunk <bunk@debian.org>
+Date: Sun, 6 Aug 2023 22:46:22 +0300
+Subject: [PATCH] Move the GNUTLS_NO_EXTENSIONS compatibility #define to
+ gnutls.h
+
+Signed-off-by: Adrian Bunk <bunk@debian.org>
+--- a/lib/ext/ext_master_secret.h
++++ b/lib/ext/ext_master_secret.h
+@@ -23,9 +23,6 @@
+ #ifndef GNUTLS_LIB_EXT_EXT_MASTER_SECRET_H
+ #define GNUTLS_LIB_EXT_EXT_MASTER_SECRET_H
+
+-/* Keep backward compatibility */
+-#define GNUTLS_NO_EXTENSIONS GNUTLS_NO_DEFAULT_EXTENSIONS
+-
+ #include <hello_ext.h>
+
+ extern const hello_ext_entry_st ext_mod_ext_master_secret;
+--- a/lib/includes/gnutls/gnutls.h.in
++++ b/lib/includes/gnutls/gnutls.h.in
+@@ -542,6 +542,9 @@ typedef enum {
+ #define GNUTLS_ENABLE_CERT_TYPE_NEG 0
+ // Here for compatibility reasons
+
++/* Keep backward compatibility */
++#define GNUTLS_NO_EXTENSIONS GNUTLS_NO_DEFAULT_EXTENSIONS
++
+ /**
+ * gnutls_alert_level_t:
+ * @GNUTLS_AL_WARNING: Alert of warning severity.
+--- a/lib/state.h
++++ b/lib/state.h
+@@ -110,7 +110,4 @@ inline static int _gnutls_PRF(gnutls_session_t session, const uint8_t *secret,
+
+ #define DEFAULT_CERT_TYPE GNUTLS_CRT_X509
+
+-/* Keep backward compatibility */
+-#define GNUTLS_NO_EXTENSIONS GNUTLS_NO_DEFAULT_EXTENSIONS
+-
+ #endif /* GNUTLS_LIB_STATE_H */
+--
+GitLab
diff --git a/net-libs/gnutls/gnutls-3.8.1.ebuild b/net-libs/gnutls/gnutls-3.8.1-r1.ebuild
index 19eb1aa7b6f0..730ced6f1866 100644
--- a/net-libs/gnutls/gnutls-3.8.1.ebuild
+++ b/net-libs/gnutls/gnutls-3.8.1-r1.ebuild
@@ -60,6 +60,10 @@ DOCS=( README.md doc/certtool.cfg )
HTML_DOCS=()
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-gnutls-header.patch
+)
+
src_prepare() {
default