summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/gsoap/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/gsoap/files')
-rw-r--r--net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch98
-rw-r--r--net-libs/gsoap/files/gsoap-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch12
2 files changed, 110 insertions, 0 deletions
diff --git a/net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch b/net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch
new file mode 100644
index 000000000000..5762d5282211
--- /dev/null
+++ b/net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch
@@ -0,0 +1,98 @@
+--- gsoap/samples/factorytest/factorytest.cpp.orig 2009-03-04 01:16:22.300484305 +0100
++++ gsoap/samples/factorytest/factorytest.cpp 2009-03-04 01:15:47.656485143 +0100
+@@ -49,7 +49,7 @@
+ #include "soapH.h"
+ #include "factorytest.nsmap"
+
+-#include <iostream.h>
++#include <iostream>
+
+ // default factory service endpoint:
+ const char *factory = "http://localhost:18085";
+@@ -167,7 +167,7 @@
+ int main(int argc, char **argv)
+ { if (argc > 1)
+ factory = argv[1]; // use factory from command line arg by default
+- cout << "Connecting to factory " << factory << endl;
++ std::cout << "Connecting to factory " << factory << std::endl;
+ Adder adder; // create unique new remote adder object
+ Counter counter1("myCounter"); // new counter object "myCounter" (created if not exists)
+ Counter counter2("myCounter"); // lookup and use counter "myCounter" (this is an alias to counter1!)
+@@ -175,22 +175,22 @@
+ counter1.set(adder.get());
+ adder.add(3.0);
+ counter1.inc();
+- cout << "Adder=" << adder.get() << endl;
+- cout << "Counter=" << counter2.get() << endl; // counter2 is an alias for counter1 so this prints the value of counter1
+- cout << "Sleep for 90 seconds to test factory server purging objects:" << endl;
++ std::cout << "Adder=" << adder.get() << std::endl;
++ std::cout << "Counter=" << counter2.get() << std::endl; // counter2 is an alias for counter1 so this prints the value of counter1
++ std::cout << "Sleep for 90 seconds to test factory server purging objects:" << std::endl;
+ // counter is periodically incremented which keeps it alive
+ sleep(30);
+ counter1.inc();
+- cout << "Counter=" << counter2.get() << endl;
++ std::cout << "Counter=" << counter2.get() << std::endl;
+ sleep(30);
+ counter1.inc();
+- cout << "Counter=" << counter2.get() << endl;
++ std::cout << "Counter=" << counter2.get() << std::endl;
+ sleep(30);
+ counter1.inc();
+- cout << "Counter=" << counter2.get() << endl;
++ std::cout << "Counter=" << counter2.get() << std::endl;
+ // after 90 secs, the adder should be gone
+- cout << "Adder is no longer available:" << endl;
++ std::cout << "Adder is no longer available:" << std::endl;
+ adder.add(3.0);
+- cout << "Adder status = " << adder.status << endl;
++ std::cout << "Adder status = " << adder.status << std::endl;
+ return 0;
+ }
+--- gsoap/samples/lu/luclient.cpp.orig 2009-03-04 01:16:48.632483467 +0100
++++ gsoap/samples/lu/luclient.cpp 2009-03-04 01:17:54.550483188 +0100
+@@ -32,7 +32,7 @@
+ */
+
+ #include "soapH.h"
+-#include <iostream.h>
++#include <iostream>
+
+ const char luserver[] = "http://websrv.cs.fsu.edu/~engelen/luserver.cgi";
+
+@@ -51,14 +51,14 @@
+ a[3].resize(2,3); // 2-element vector indexed from 2 to 3
+ a[3][2] = 1;
+ a[3][3] = 2;
+- cout << "* Demonstration example *" << endl;
+- cout << "Matrix:" << endl;
++ std::cout << "* Demonstration example *" << std::endl;
++ std::cout << "Matrix:" << std::endl;
+ a.print();
+ vector b(soap, 3);
+ b[1] = 1;
+ b[2] = 2;
+ b[3] = 3;
+- cout << "Vector:" << endl;
++ std::cout << "Vector:" << std::endl;
+ b.print();
+ vector x(soap);
+ if (argc < 2)
+@@ -71,7 +71,7 @@
+ soap_print_fault_location(soap, stderr);
+ }
+ else
+- { cout << "Solution vector from service:" << endl;
++ { std::cout << "Solution vector from service:" << std::endl;
+ x.print();
+ }
+ matrix a1(soap);
+@@ -80,7 +80,7 @@
+ soap_print_fault_location(soap, stderr);
+ }
+ else
+- { cout << "Inverse matrix matrix from service:" << endl;
++ { std::cout << "Inverse matrix matrix from service:" << std::endl;
+ a1.print();
+ }
+ soap_destroy(soap);
diff --git a/net-libs/gsoap/files/gsoap-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch b/net-libs/gsoap/files/gsoap-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch
new file mode 100644
index 000000000000..673deb17c35f
--- /dev/null
+++ b/net-libs/gsoap/files/gsoap-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch
@@ -0,0 +1,12 @@
+--- gsoap-2.7/gsoap/Makefile.am 2008-01-27 15:02:36.000000000 -0600
++++ gsoap-2.7mf/gsoap/Makefile.am 2008-01-28 10:24:26.000000000 -0600
+@@ -12,6 +12,9 @@ CLEANFILES=soapcpp2 stdsoap2_cpp.cpp std
+ AM_CXXFLAGS=$(SOAPCPP2_DEBUG) -D$(platform)
+ AM_CFLAGS=$(SOAPCPP2_DEBUG) -D$(platform)
+
++# Install all soapcpp2 and wsdl2h files into /usr/share/gsoap
++nobase_pkgdata_DATA = import/* plugin/* WS/* custom/* extras/*
++
+ ## we cannot build stdsoap2.o from 2 different sources (stdsoap2.cpp and stdsoap2.c), so we need an intermediate target:
+ stdsoap2_ck.c: stdsoap2.cpp
+ $(LN_S) $(srcdir)/stdsoap2.cpp stdsoap2_ck.c