summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-26 15:42:16 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-26 15:42:50 +0100
commitbc06e171bbb527bb92b8afbfd2f2982919955e6d (patch)
treeefad14b457fc22e74fd6f86139f0e7898c7ad953 /net-libs/gsoap
parentapp-misc/tmux: restrict utempter dependency by Yuta SATOH, bug #575712 (diff)
downloadgentoo-bc06e171bbb527bb92b8afbfd2f2982919955e6d.tar.gz
gentoo-bc06e171bbb527bb92b8afbfd2f2982919955e6d.tar.bz2
gentoo-bc06e171bbb527bb92b8afbfd2f2982919955e6d.zip
net-libs/gsoap: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-libs/gsoap')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.29.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index c6a5fec9c059..dd6a94fa0005 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -2,3 +2,4 @@ DIST gsoap_2.7.17.zip 10224444 SHA256 d3af1ce9464b28cacdf1dfbe09b689f8927cbcf394
DIST gsoap_2.8.23.zip 22482000 SHA256 e1c30743f1c2cf40b2760568127e14af1b2a00c3026b2e5f0750e8c33d94c061 SHA512 cc90aadfe09aa6406172c9ffa07696851ff594ca7c5b40819494badd8ce978d908d66de63a5831e7aec1bca18ee8b51ed02187057688a3b36eb0a21fe6e0f5a4 WHIRLPOOL e5cfc9c5758847d1fc94cbd38108b80c7548abc0316fe201b58604a3b22d30b9748c81d4aec13f53356593f3ddc2dcba14170a53d63795eab9229ec49d4bc585
DIST gsoap_2.8.27.zip 22643224 SHA256 cdd9188f3a00caf14fae54d7cc975227128118e818036e5b6bd6e87550e1dc35 SHA512 45c2a653ef588acf41b23c14fdfe2524b37b3324d9ca332a1f8c7ec37fd6e1cf297c798dc7eeb2f90aaa2dd3a72a87f5cde1daf0a513b0259e08a89e386846ad WHIRLPOOL b82a7e9e4ff7b1042ef0c3346ea9cdeb343232d0cc23ec96845adcc44a4b4d773df42fe72a1eaeadb4e33cc63d5458d7bcb0dc97184ab6d0f5e82682eaaba8ad
DIST gsoap_2.8.28.zip 23729531 SHA256 453b36d97a98b35c2829284219dd09a4d60f073a5b77c658c403961c54cfa328 SHA512 1ada2993ca2fe52ff8337484f1be387a0d74b894c633fb0a947f0c160bf875a17825983c174d6e0d84dc8292964f854638dbd9bb54402a8de618036a7db9623b WHIRLPOOL 5c2255d868b140646d0609d25681dea7cf2861d5ee39c771c84e16af77d4f2b6a8541f93bcf1dcefb642f35571936b63fc69acdcec0ae46de87fc96fb7af75bd
+DIST gsoap_2.8.29.zip 24006374 SHA256 a9dacc4f862892df6cf9119d1c5d627af3a864c17f17b6542c560e72070b1381 SHA512 ce79cf52210e8ce34b39dc25931dbdc36bdd770ac01e70583e1e4a2f1006f20d259dd57d02a1baf2f937016c63837b9a9befca3d71f992f7a798a55de70a8c61 WHIRLPOOL a5c884b7c7e9144d293674d4977edbe8fda780003cca554acd08db5aade0f09702b294d69bb67f26f668d3a6f195791f9f6483d4a94df83f09ab79bc8985fb08
diff --git a/net-libs/gsoap/gsoap-2.8.29.ebuild b/net-libs/gsoap/gsoap-2.8.29.ebuild
new file mode 100644
index 000000000000..e8c1c2e6b7c7
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.29.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Fix Pre-ISO headers
+ eapply "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+ use ssl || myconf+=( --disable-ssl )
+ use gnutls && myconf+=( --enable-gnutls )
+ use ipv6 && myconf+=( --enable-ipv6 )
+ econf \
+ ${myconf[@]} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.md
+
+ prune_libtool_files --all
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}