summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/gssdp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/gssdp')
-rw-r--r--net-libs/gssdp/Manifest2
-rw-r--r--net-libs/gssdp/gssdp-0.14.10.ebuild60
-rw-r--r--net-libs/gssdp/gssdp-0.14.11.ebuild60
-rw-r--r--net-libs/gssdp/metadata.xml5
4 files changed, 127 insertions, 0 deletions
diff --git a/net-libs/gssdp/Manifest b/net-libs/gssdp/Manifest
new file mode 100644
index 000000000000..a1df3c5ffebe
--- /dev/null
+++ b/net-libs/gssdp/Manifest
@@ -0,0 +1,2 @@
+DIST gssdp-0.14.10.tar.xz 291236 SHA256 b9b3be6354d6a0dcc7c29a7da4120847350011e5614383626552e15c28f3058c SHA512 ee974794fa82388f305c24802ca2a42fe8d3abcfff98a7e810470f772a8adec596b7d81a5e991763043f37b7cac7e6b4a16642e58d440adef2989b7ca27fc489 WHIRLPOOL f37ca8b781fdc442a8a9b08a57efce95563fa96d350d4aee4f9f71fa9f425a65aefdf5561f35dc5dbd7d590212d533175380631629fce5fd998d91e42676ac1e
+DIST gssdp-0.14.11.tar.xz 291872 SHA256 7bf5aeaf2119fe0bec5f3632ecf39dae15bc85276c72c2ad8dd4b0e345c6535a SHA512 1954f048b073338a744cc3d8b31c3e006a52ab2223d1b4adbeed5c563fb4cd0bd51bb4dfa018b0fd200e175e4c12d11b9a1de43a5109c5c647dcc26398dd774b WHIRLPOOL 069647057f4feaffeff6dd5fadd4a51ba2a3fba742a6b2c022292bcdafdea72dc5db5405c6417db4e7962824105978c487ed2cffe30ca347282565bff18c4887
diff --git a/net-libs/gssdp/gssdp-0.14.10.ebuild b/net-libs/gssdp/gssdp-0.14.10.ebuild
new file mode 100644
index 000000000000..df05bc4b6902
--- /dev/null
+++ b/net-libs/gssdp/gssdp-0.14.10.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 multilib-minimal vala
+
+DESCRIPTION="A GObject-based API for handling resource discovery and announcement over SSDP"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
+
+LICENSE="LGPL-2"
+SLOT="0/3"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="+introspection +gtk"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=net-libs/libsoup-2.44.2:2.4[${MULTILIB_USEDEP},introspection?]
+ gtk? ( >=x11-libs/gtk+-3.0:3 )
+ introspection? (
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-0.6.7 )
+ !<net-libs/gupnp-vala-0.10.3
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ sys-devel/gettext
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ # Disable functional test as it requires port that might be used by rygel to
+ # be free of use
+ sed 's/\(check_PROGRAMS.*\)test-functional$(EXEEXT)/\1/' \
+ -i "${S}"/tests/gtest/Makefile.in || die
+
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection) \
+ $(multilib_native_use_with gtk) \
+ --disable-static
+
+ if multilib_is_native_abi; then
+ # fix gtk-doc
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/net-libs/gssdp/gssdp-0.14.11.ebuild b/net-libs/gssdp/gssdp-0.14.11.ebuild
new file mode 100644
index 000000000000..2c1d02ff1ca8
--- /dev/null
+++ b/net-libs/gssdp/gssdp-0.14.11.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 multilib-minimal vala
+
+DESCRIPTION="A GObject-based API for handling resource discovery and announcement over SSDP"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
+
+LICENSE="LGPL-2"
+SLOT="0/3"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="+introspection +gtk"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=net-libs/libsoup-2.44.2:2.4[${MULTILIB_USEDEP},introspection?]
+ gtk? ( >=x11-libs/gtk+-3.0:3 )
+ introspection? (
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-0.6.7 )
+ !<net-libs/gupnp-vala-0.10.3
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ sys-devel/gettext
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ # Disable functional test as it requires port that might be used by rygel to
+ # be free of use
+ sed 's/\(check_PROGRAMS.*\)test-functional$(EXEEXT)/\1/' \
+ -i "${S}"/tests/gtest/Makefile.in || die
+
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection) \
+ $(multilib_native_use_with gtk) \
+ --disable-static
+
+ if multilib_is_native_abi; then
+ # fix gtk-doc
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/net-libs/gssdp/metadata.xml b/net-libs/gssdp/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/net-libs/gssdp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>