summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-12 12:55:14 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-12 15:28:00 +0100
commite1273c061a1978f468e258892effd62561d0d8df (patch)
tree68369409f31f9d2da82dc818a64a585ad6f89fdd /net-libs/gssdp
parentapp-misc/gnote: Drop old (diff)
downloadgentoo-e1273c061a1978f468e258892effd62561d0d8df.tar.gz
gentoo-e1273c061a1978f468e258892effd62561d0d8df.tar.bz2
gentoo-e1273c061a1978f468e258892effd62561d0d8df.zip
net-libs/gssdp: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'net-libs/gssdp')
-rw-r--r--net-libs/gssdp/Manifest1
-rw-r--r--net-libs/gssdp/gssdp-0.14.12.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/gssdp/Manifest b/net-libs/gssdp/Manifest
index a1df3c5ffebe..d1edd5b3a18b 100644
--- a/net-libs/gssdp/Manifest
+++ b/net-libs/gssdp/Manifest
@@ -1,2 +1,3 @@
DIST gssdp-0.14.10.tar.xz 291236 SHA256 b9b3be6354d6a0dcc7c29a7da4120847350011e5614383626552e15c28f3058c SHA512 ee974794fa82388f305c24802ca2a42fe8d3abcfff98a7e810470f772a8adec596b7d81a5e991763043f37b7cac7e6b4a16642e58d440adef2989b7ca27fc489 WHIRLPOOL f37ca8b781fdc442a8a9b08a57efce95563fa96d350d4aee4f9f71fa9f425a65aefdf5561f35dc5dbd7d590212d533175380631629fce5fd998d91e42676ac1e
DIST gssdp-0.14.11.tar.xz 291872 SHA256 7bf5aeaf2119fe0bec5f3632ecf39dae15bc85276c72c2ad8dd4b0e345c6535a SHA512 1954f048b073338a744cc3d8b31c3e006a52ab2223d1b4adbeed5c563fb4cd0bd51bb4dfa018b0fd200e175e4c12d11b9a1de43a5109c5c647dcc26398dd774b WHIRLPOOL 069647057f4feaffeff6dd5fadd4a51ba2a3fba742a6b2c022292bcdafdea72dc5db5405c6417db4e7962824105978c487ed2cffe30ca347282565bff18c4887
+DIST gssdp-0.14.12.1.tar.xz 297532 SHA256 b3d570455746284f3e65843c7f94d9595be54d68a9525629b625196bad2cac07 SHA512 c0d1445858f4303e353ff1287eb6e28e150e8162d095c3ffde18dee8426486b0f7bcd120e67076380f5a7f4b559b335e759d2aea4032ec2152a20c5a1ac268f5 WHIRLPOOL 7d1e670c26271a8e7509159668b7c1f0fd3156c182f5aab06bb4509b04c026c25a439f0d97733150764bc954ba8f635d6dd09c682209120d3375f7e3154a9db1
diff --git a/net-libs/gssdp/gssdp-0.14.12.1.ebuild b/net-libs/gssdp/gssdp-0.14.12.1.ebuild
new file mode 100644
index 000000000000..a484bc59dcc9
--- /dev/null
+++ b/net-libs/gssdp/gssdp-0.14.12.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 multilib-minimal vala
+
+DESCRIPTION="A GObject-based API for handling resource discovery and announcement over SSDP"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
+
+LICENSE="LGPL-2"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+introspection +gtk"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=net-libs/libsoup-2.44.2:2.4[${MULTILIB_USEDEP},introspection?]
+ gtk? ( >=x11-libs/gtk+-3.0:3 )
+ introspection? (
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-0.6.7:= )
+ !<net-libs/gupnp-vala-0.10.3
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ sys-devel/gettext
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ # Disable functional test as it requires port that might be used by rygel to
+ # be free of use
+ sed 's/\(check_PROGRAMS.*\)test-functional$(EXEEXT)/\1/' \
+ -i "${S}"/tests/Makefile.in || die
+
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection) \
+ $(multilib_native_use_with gtk) \
+ --disable-static
+
+ if multilib_is_native_abi; then
+ # fix gtk-doc
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}