summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-16 14:02:33 -0700
committerMatt Turner <mattst88@gentoo.org>2022-07-16 14:27:03 -0700
commite17d66c52db01a45eb243bf662b5b7ed87b30453 (patch)
tree00de5b21476d76f4984f397187f6941d50ee331a /net-libs/gtk-vnc
parentgnome-extra/libgsf: Version bump to 1.14.50 (diff)
downloadgentoo-e17d66c52db01a45eb243bf662b5b7ed87b30453.tar.gz
gentoo-e17d66c52db01a45eb243bf662b5b7ed87b30453.tar.bz2
gentoo-e17d66c52db01a45eb243bf662b5b7ed87b30453.zip
net-libs/gtk-vnc: Version bump to 1.3.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/gtk-vnc')
-rw-r--r--net-libs/gtk-vnc/Manifest1
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-1.3.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/gtk-vnc/Manifest b/net-libs/gtk-vnc/Manifest
index 5eb0dc70e300..104466ae1586 100644
--- a/net-libs/gtk-vnc/Manifest
+++ b/net-libs/gtk-vnc/Manifest
@@ -1,2 +1,3 @@
DIST gtk-vnc-1.3.0-meson-0.63.patch.xz 5328 BLAKE2B d671622ad02bb253c6648515005db12306f9a093d8c26db12faa6a549397b0d18a696cdca5cf4eaead9d70fb827dc8f1715ba95051e11bc604f3af41821c6c19 SHA512 4ed806de86ac8c6773621d276f35e592f1f3e03c4f610d1386426833f345f1aac113dc31e24e86f93a4122d2fb49d00daa7f3df6883944c567daa4cda62c9249
DIST gtk-vnc-1.3.0.tar.xz 220488 BLAKE2B ea5070cc396fe4ef52fe980b766658f1a4f82eb7dec52856ab79836363c8fdb48827d52c0df7edb2c943f5087fcfd87898aa43457f7cbf5a544a4c7063f84f3d SHA512 ff25c19a1cbd4588990f1f3a2448fd2e0b694b933ca1a7be9565188db78055efe13f90ad1243bf8237d6a29d38987d7b3e77344e50d09191207b09200b01f5df
+DIST gtk-vnc-1.3.1.tar.xz 222204 BLAKE2B 03e51700ae0a477a2762a67ed5906ce5205025b2fb30df5fa75deb99315d2164f22ee0b97d3fc8c23648921cdba4b4a3e22045b2cb8226360ff9f468bef2162f SHA512 01c9af407f913b214814252d7b204822372293ffc5f658aa646936f9f8cdcd77589c127e4d0e893e914c61470d4616e32f7b1fa9bd3739b2a22caef6710953b9
diff --git a/net-libs/gtk-vnc/gtk-vnc-1.3.1.ebuild b/net-libs/gtk-vnc/gtk-vnc-1.3.1.ebuild
new file mode 100644
index 000000000000..05e2881bfd5d
--- /dev/null
+++ b/net-libs/gtk-vnc/gtk-vnc-1.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org vala meson python-any-r1 xdg
+
+DESCRIPTION="VNC viewer widget for GTK"
+HOMEPAGE="https://wiki.gnome.org/Projects/gtk-vnc https://gitlab.gnome.org/GNOME/gtk-vnc"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection pulseaudio sasl +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gdk-pixbuf-2.36.0:2
+ >=dev-libs/libgcrypt-1.8.0:0=
+ >=net-libs/gnutls-3.6.0:0=
+ >=sys-libs/zlib-1.2.11
+ sasl? ( >=dev-libs/cyrus-sasl-2.1.27:2 )
+ >=x11-libs/gtk+-3.22.0:3[introspection?]
+ >=x11-libs/cairo-1.15.0
+ >=x11-libs/libX11-1.6.5
+ pulseaudio? ( >=media-sound/pulseaudio-11.0 )
+ introspection? ( >=dev-libs/gobject-introspection-1.56.0:= )
+"
+# Keymap databases code is generated with python3; configure picks up $PYTHON exported from python-any-r1_pkg_setup
+# perl for pod2man
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/perl-5
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+
+ use vala & vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature introspection)
+ $(meson_feature pulseaudio)
+ $(meson_feature sasl)
+ -Dwith-coroutine=auto # gthread on windows, libc ucontext elsewhere; neither has extra deps
+ $(meson_feature vala with-vala)
+ )
+ meson_src_configure
+}