summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-02-20 14:18:40 +0100
committerPacho Ramos <pacho@gentoo.org>2016-02-20 14:52:52 +0100
commit417802e2e6c7a92c71fbc1cfb73f362fb27444ad (patch)
tree2c9f2933e5d419e36d8d844d28f9afa83a1557da /net-libs/gupnp-av/gupnp-av-0.12.8.ebuild
parentnet-libs/gupnp-av: Drop old (diff)
downloadgentoo-417802e2e6c7a92c71fbc1cfb73f362fb27444ad.tar.gz
gentoo-417802e2e6c7a92c71fbc1cfb73f362fb27444ad.tar.bz2
gentoo-417802e2e6c7a92c71fbc1cfb73f362fb27444ad.zip
net-libs/gupnp-av: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-libs/gupnp-av/gupnp-av-0.12.8.ebuild')
-rw-r--r--net-libs/gupnp-av/gupnp-av-0.12.8.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-libs/gupnp-av/gupnp-av-0.12.8.ebuild b/net-libs/gupnp-av/gupnp-av-0.12.8.ebuild
new file mode 100644
index 000000000000..fa953a449d0c
--- /dev/null
+++ b/net-libs/gupnp-av/gupnp-av-0.12.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 vala
+
+DESCRIPTION="Utility library aiming to ease the handling UPnP A/V profiles"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
+
+LICENSE="LGPL-2"
+SLOT="0/2" # subslot: soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.16:2
+ >=net-libs/gssdp-0.9.2[introspection?]
+ >=net-libs/libsoup-2.28.2:2.4[introspection?]
+ dev-libs/libxml2
+ >=net-libs/gupnp-0.19[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ !net-libs/gupnp-vala
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ virtual/pkgconfig
+ introspection? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-static
+}