summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-16 11:23:55 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-16 11:47:30 +0200
commit9de1e5f78e1cdcfe837580b10ac212c3e278fa74 (patch)
tree764e8a1ed53ba46452d517f9a45761d331adf838 /net-libs/http-parser/http-parser-2.9.2.ebuild
parentgnustep-base/gnustep-base: fix compressed man pages install (diff)
downloadgentoo-9de1e5f78e1cdcfe837580b10ac212c3e278fa74.tar.gz
gentoo-9de1e5f78e1cdcfe837580b10ac212c3e278fa74.tar.bz2
gentoo-9de1e5f78e1cdcfe837580b10ac212c3e278fa74.zip
net-libs/http-parser: Version 2.9.2
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/http-parser/http-parser-2.9.2.ebuild')
-rw-r--r--net-libs/http-parser/http-parser-2.9.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/http-parser/http-parser-2.9.2.ebuild b/net-libs/http-parser/http-parser-2.9.2.ebuild
new file mode 100644
index 000000000000..2abe7cff69f8
--- /dev/null
+++ b/net-libs/http-parser/http-parser-2.9.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs multilib-minimal
+
+DESCRIPTION="HTTP request/response parser for C"
+HOMEPAGE="https://github.com/nodejs/http-parser"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2.9.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x64-macos ~x64-solaris"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ tc-export CC AR
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" CFLAGS_FAST="${CFLAGS}" library
+ use static-libs && emake CFLAGS_FAST="${CFLAGS}" package
+}
+
+multilib_src_test() {
+ emake CFLAGS_DEBUG="${CFLAGS}" CFLAGS_FAST="${CFLAGS}" test
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+ use static-libs && dolib.a libhttp_parser.a
+}