summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-12 11:03:06 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-12 13:23:25 +0200
commitc14ef0c24725790b302031beb351349a93ff7178 (patch)
tree3ae0c6fc20e6dc5ac4bf9a41d2dd63c6b8a60fd6 /net-libs/ignition-transport
parentnet-libs/ignition-transport: remove old (diff)
downloadgentoo-c14ef0c24725790b302031beb351349a93ff7178.tar.gz
gentoo-c14ef0c24725790b302031beb351349a93ff7178.tar.bz2
gentoo-c14ef0c24725790b302031beb351349a93ff7178.zip
net-libs/ignition-transport: bump to 1.4.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-libs/ignition-transport')
-rw-r--r--net-libs/ignition-transport/Manifest1
-rw-r--r--net-libs/ignition-transport/ignition-transport-1.4.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/ignition-transport/Manifest b/net-libs/ignition-transport/Manifest
index 84347137370b..838fe790c81c 100644
--- a/net-libs/ignition-transport/Manifest
+++ b/net-libs/ignition-transport/Manifest
@@ -1 +1,2 @@
DIST ignition-transport-1.3.0.tar.bz2 348943 SHA256 5fd2d54b6554bd61b10d66cf5e4d597b44a55e30e16c8ba3e1f4382efcdee006 SHA512 a374325840263464ef6b1eef84f332106ac999ba3c2cb2dc425f5eecead27768007a3178f188cdb450ea72423148098333ee34a37344130afaaa4f6b75112d02 WHIRLPOOL 1e8d703757cedd67d0c6bcb36ee62e78c662eb7875426e928e5d7af5e141bf9fdf0998ab8c918e2786e890daa71c72c9ea40926d197628fe61c9a4dafbded31f
+DIST ignition-transport-1.4.0.tar.bz2 349098 SHA256 bc612e9781f9cab81cc4111ed0de07c4838303f67c25bc8b663d394b40a8f5d4 SHA512 23f1d1b6982441786a764f902a849d8466943c457a989638ab5d57e936c9a0d4bab324d60c8d7190e40ecc153736d55cf903df6a57cb2cbbda86bbe79ba1055d WHIRLPOOL 6b019c025bc41ad6e7f3e94f220767a652442a05678718f5e686c71f1e2ed30be60f16fb29cfd8df976d87827647f74b3b8664aeea319cb68e44802fbd9f81fa
diff --git a/net-libs/ignition-transport/ignition-transport-1.4.0.ebuild b/net-libs/ignition-transport/ignition-transport-1.4.0.ebuild
new file mode 100644
index 000000000000..51f5f088c76b
--- /dev/null
+++ b/net-libs/ignition-transport/ignition-transport-1.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils vcs-snapshot flag-o-matic
+
+DESCRIPTION="Combines ZeroMQ with Protobufs to create a fast and efficient message passing system"
+HOMEPAGE="http://ignitionrobotics.org/libraries/transport"
+SRC_URI="http://gazebosim.org/distributions/ign-transport/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0/0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-libs/protobuf:=
+ >=net-libs/zeromq-3.2.0:=
+ sys-apps/util-linux
+ net-libs/cppzmq
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=( "${FILESDIR}/protobuf3.patch" )
+
+src_configure() {
+ # upstream appends this conditionally...
+ append-flags "-fPIC"
+ echo "set (CMAKE_C_FLAGS_ALL \"${CXXFLAGS} \${CMAKE_C_FLAGS_ALL}\")" > "${S}/cmake/HostCFlags.cmake"
+ sed -i -e "s/LINK_FLAGS_RELWITHDEBINFO \" \"/LINK_FLAGS_RELWITHDEBINFO \" ${LDFLAGS} \"/" cmake/DefaultCFlags.cmake || die
+ cmake-utils_src_configure
+}