summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-09-04 20:53:34 +0000
committerZero_Chaos <zerochaos@gentoo.org>2018-09-04 20:54:29 +0000
commit25a6def0fb2acebe908412892dd8be516c68de0f (patch)
tree6d53d0e05696b31875631d89d14f27ead62f34b5 /net-libs/libad9361-iio/files
parentnet-libs/libiio: import from pentoo (diff)
downloadgentoo-25a6def0fb2acebe908412892dd8be516c68de0f.tar.gz
gentoo-25a6def0fb2acebe908412892dd8be516c68de0f.tar.bz2
gentoo-25a6def0fb2acebe908412892dd8be516c68de0f.zip
net-libs/libad9361-iio: import from pentoo
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'net-libs/libad9361-iio/files')
-rw-r--r--net-libs/libad9361-iio/files/7206bb2a9b655be3bdb66c6cf03aa504817ed240.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/libad9361-iio/files/7206bb2a9b655be3bdb66c6cf03aa504817ed240.patch b/net-libs/libad9361-iio/files/7206bb2a9b655be3bdb66c6cf03aa504817ed240.patch
new file mode 100644
index 000000000000..6b1668f0a0e5
--- /dev/null
+++ b/net-libs/libad9361-iio/files/7206bb2a9b655be3bdb66c6cf03aa504817ed240.patch
@@ -0,0 +1,36 @@
+From 7206bb2a9b655be3bdb66c6cf03aa504817ed240 Mon Sep 17 00:00:00 2001
+From: Lars-Peter Clausen <lars@metafoo.de>
+Date: Tue, 14 Aug 2018 09:48:59 +0200
+Subject: [PATCH] Fix building outside git repository
+
+Currently when building the project on a machine that has git installed,
+but the source is not inside a git repository cmake fails with the
+following error.
+
+ CMake Error at CMakeLists.txt:35 (if):
+ if given arguments:
+
+ "STREQUAL" "/home/lars/libad9361-iio"
+
+This is due to LIBAD9361_GIT_REPO variable being empty. In order to handle
+empty variables in CMake in a string comparison they need to be
+encapsulated in quotes.
+
+Signed-off-by: Lars-Peter Clausen <lars@metafoo.de>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7af5444..8d04ba0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -32,7 +32,7 @@ if (GIT_FOUND)
+ OUTPUT_STRIP_TRAILING_WHITESPACE
+ )
+
+-if (${LIBAD9361_GIT_REPO} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR})
++if ("${LIBAD9361_GIT_REPO}" STREQUAL "${CMAKE_CURRENT_SOURCE_DIR}")
+ execute_process(
+ COMMAND ${GIT_EXECUTABLE} rev-parse --short HEAD
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}